LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-21-2007, 06:03 PM   #1
flebber
Member
 
Registered: Jan 2005
Location: Newcastle, Australia
Distribution: debian stable
Posts: 394

Rep: Reputation: 30
Qemu error and kqemu not enabled


Hi I have just set up QEMU on suse 10.3 following the guides from http://en.opensuse.org/Qemu and http://en.opensuse.org/Qemu_with_kqe...module_support and http://fabrice.bellard.free.fr/qemu/kqemu-doc.html however each time I start qemu I receive these errors is there a way to permanently get rid of them ?
Code:
flebber@focus:~> qemu -m 256 -hda myharddisk.qcow -cdrom /dev/cdrom -boot c -localtime
Could not configure '/dev/rtc' to have a 1024 Hz timer. This is not a fatal
error, but for better emulation accuracy either use a 2.6 host Linux kernel or
type 'echo 1024 > /proc/sys/dev/rtc/max-user-freq' as root.
You do not have enough space in '/dev/shm' for the 256 MB of QEMU virtual RAM.
To have more space available provided you have enough RAM and swap, do as root:
umount /dev/shm
mount -t tmpfs -o size=272m none /dev/shm
Or disable the accelerator module with -no-kqemu
Also after following guides to enable kqemu support I still find that when I do ctrl+alt+2 and info kqemu it is still telling support is disabled.

What can I do to resolve these problems ? and/or are there other guides that are recommended reading ?
 
Old 10-21-2007, 06:42 PM   #2
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Did you do this bit:
Quote:
umount /dev/shm
mount -t tmpfs -o size=272m none /dev/shm
?

Dave
 
Old 10-22-2007, 06:11 AM   #3
flebber
Member
 
Registered: Jan 2005
Location: Newcastle, Australia
Distribution: debian stable
Posts: 394

Original Poster
Rep: Reputation: 30
Yes. but after a reboot you must do it each time.
 
Old 10-22-2007, 07:57 AM   #4
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Change your /dev/shm entry in /etc/fstab to:
Code:
tmpfs /dev/shm tmpfs defaults,size=272m 0 0
and it should survive a reboot.

Dave
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
QEMU & KQEMU on slackware sl4ckw4re Slackware 104 05-08-2007 08:37 AM
qemu installs but no kqemu acceleration google01103 SUSE / openSUSE 2 12-30-2006 07:08 PM
Qemu with kqemu support problem luke-indul Ubuntu 2 05-31-2006 03:35 PM
Got error in compiling kqemu with qemu depam Linux - Software 15 05-03-2006 06:47 PM
Qemu with KQemu cormack Linux - Software 12 04-05-2006 09:43 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration