LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-11-2003, 10:36 PM   #1
Oakstaff
Member
 
Registered: Nov 2003
Location: Tulsa, Ok
Posts: 121

Rep: Reputation: 15
Problem with gaim/glib


I have been tryign to install the newest version of Gaim and it keeps saying

*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at http://www.gtk.org/.

and i just did the install of GLib and this keeps coming up any ideas what i can do?
 
Old 11-12-2003, 12:32 AM   #2
kasperhans
Member
 
Registered: Oct 2003
Location: right behind the moon
Distribution: gentoo
Posts: 466

Rep: Reputation: 30
first you maybe have to remove the bad glib install and to reinstall the whole thing also check if all depencies are solved
 
Old 11-12-2003, 02:48 AM   #3
Oakstaff
Member
 
Registered: Nov 2003
Location: Tulsa, Ok
Posts: 121

Original Poster
Rep: Reputation: 15
I just reinstalled the bad install then reinstalled it 5 times and tried each time, then removed the install and so forth, each time it came up the same thing as above...i tried different versions of GLib and am getting very irritated...=( I just want Gaim to work for AIM and MSN.....lol any help if anyone knows what to do....I a headin to bed.
 
Old 11-12-2003, 03:32 AM   #4
dolvmin
Member
 
Registered: Jul 2003
Location: Florida
Distribution: Red Hat 7.2/8/9, Fedora Core 1/2/3, Smoothwall, Mandrake 7.0/10, Vecter 4, Arch 0.6, EnGuarde
Posts: 289

Rep: Reputation: 30
Quote:
Originally posted by Oakstaff
I just reinstalled the bad install then reinstalled it 5 times and tried each time, then removed the install and so forth, each time it came up the same thing as above...i tried different versions of GLib and am getting very irritated...=( I just want Gaim to work for AIM and MSN.....lol any help if anyone knows what to do....I a headin to bed.
Simply uninstalling Glib is not going to resolve your problem. Linux X is highly dependent on Glib and I believe it is not the only thing that is.

First, you need to do this in command line without anyone being logged in X. There is a possibility that you may need to startup Linux from an exterior source so the kernel in your computer is not booted up. Secondly, you must "COMPLETELY" remove ALL Glib related files. They must be purged or you will have the same problem. Finally, you want to install the new version that is "compatible with your Kernel"

Between you and me, this is not an easy task. Your going to be studying a very long time before you get this one off the ground. If you purchased your copy of Linux, you may want to contact your OEM for support. Otherwise, be ready to become a book worm for a good while.
 
Old 11-12-2003, 02:20 PM   #5
Oakstaff
Member
 
Registered: Nov 2003
Location: Tulsa, Ok
Posts: 121

Original Poster
Rep: Reputation: 15
uhm....uhg...=(
 
Old 04-21-2004, 01:27 AM   #6
dolvmin
Member
 
Registered: Jul 2003
Location: Florida
Distribution: Red Hat 7.2/8/9, Fedora Core 1/2/3, Smoothwall, Mandrake 7.0/10, Vecter 4, Arch 0.6, EnGuarde
Posts: 289

Rep: Reputation: 30
BTW, if your trying to use Gain (Linux version of AIM) I have a really easy solution for you.

Download the linux version of Netscape. Us the built in AIM version for that. It works fine with me and doesn't touch GAIN.

Might be a way for you to work around the problem.

As for MSN, I don't think I can help you with that until you move to a distro like Redhat.

Last edited by dolvmin; 04-23-2004 at 09:55 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
glib problem when trying to install GAIM icu5545 Linux - Software 2 06-15-2005 12:43 PM
Compiling GAIM says i need GLib 2.0, yet i have GLib 2.4 MadSkillzMan Linux - Newbie 3 07-10-2004 04:10 AM
Gaim .66 glib 2.0 error p1az Linux - Software 4 08-05-2003 11:32 AM
GAIM 0.62 and GLib kko88 Linux - Software 9 05-23-2003 03:33 PM
glib 2.0.0 and gaim 0.59 GT I.N.C Linux - Newbie 2 07-10-2002 12:10 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration