LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-28-2004, 04:56 AM   #1
neonico
LQ Newbie
 
Registered: Sep 2004
Posts: 2

Rep: Reputation: 0
problem install rpm


hi!
i have Mandrake 10 and i try to install the compilator gcc 3.4. I am trying to install the rpm: gcc-3.4.1-3mdk.i586.rpm but i am stuck with the following problems:
Code:
[root@nico gcc]# rpm -i gcc-3.4.1-3mdk.i586.rpm
attention: gcc-3.4.1-3mdk.i586.rpm: signature V3 DSA: NOKEY, key ID 26752624
erreur: Dépendances requises:
        gcc-cpp = 3.4.1-3mdk est nécessaire pour gcc-3.4.1-3mdk
[root@nico gcc]# rpm -i gcc-cpp-3.4.1-3mdk.i586.rpm
attention: gcc-cpp-3.4.1-3mdk.i586.rpm: signature V3 DSA: NOKEY, key ID 26752624
        le fichier /usr/share/man/man1/cpp.1.bz2 de l'installation de gcc-cpp-3.4.1-3mdk entre en conflit avec le fichier du paquetage gcc-cpp-3.3.2-6mdk
To sum up, gcc-3.4.1-3mdk need gcc-cpp-3.4.1-3mdk. When i try to install gcc-cpp-3.4.1-3mdk, it is in conflict with gcc-cpp-3.3.2-6mdk. And i want to keep gcc-cpp-3.3.2-6mdk. How to do to solve this problem?

Thanks a lot.
Nico
 
Old 09-28-2004, 05:57 AM   #2
Boby
Member
 
Registered: Feb 2004
Posts: 781

Rep: Reputation: Disabled
I don't think you can keep your old packacke when upgrading from RPM.
To upgrade gcc-3.4.1 and gcc-cpp-3.4.1 use
rpm -Uhv gcc-3.4.1-3mdk.i586.rpm gcc-cpp-3.4.1-3mdk.i586.rpm

Boby
 
Old 09-28-2004, 08:25 AM   #3
neonico
LQ Newbie
 
Registered: Sep 2004
Posts: 2

Original Poster
Rep: Reputation: 0
Code:
[root@nico gcc]# rpm -Uhv gcc-3.4.1-3mdk.i586.rpm gcc-cpp-3.4.1-3mdk.i586.rpm
attention: gcc-3.4.1-3mdk.i586.rpm: signature V3 DSA: NOKEY, key ID 26752624
erreur: Dépendances requises:
        gcc = 3.3.2-6mdk est nécessaire pour (déjà installé) gcc-c++-3.3.2-6mdk
        gcc = 3.3.2-6mdk est nécessaire pour (déjà installé) gcc-objc-3.3.2-6mdk
        gcc = 3.3.2-6mdk est nécessaire pour (déjà installé) gcc-java-3.3.2-6mdk
        gcc = 3.3.2-6mdk est nécessaire pour (déjà installé) gcc-g77-3.3.2-6mdk
To sum up, here, the modules gcc-c++-3.3.2-6mdk, gcc-objc-3.3.2-6mdk, gcc-java-3.3.2-6, gcc-g77-3.3.2-6mdk need gcc-3.3.2-6mdk which is installed!!
Any ideas on this problem? or is there other means to install the compilator 3.4 keeping the 3.3?
Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Install rpm problem ust Linux - Software 2 06-24-2004 09:20 PM
rpm install problem pasalacqua128 Linux - Software 2 06-03-2004 04:31 PM
RPM install problem RHGilman Linux - Newbie 4 05-02-2004 06:49 AM
rpm install problem wedgeworth Linux - Software 5 09-12-2003 02:30 PM
rpm install problem SeanBoz Linux - Software 7 09-11-2003 05:19 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration