LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-09-2006, 04:19 AM   #1
p_test
Member
 
Registered: Aug 2004
Location: Jaipur(Rajasthan), INDIA
Posts: 35

Rep: Reputation: 15
Probelm while " make " Nist Net


Hi

I am facing a problem while installing Nist Net. I ran ./configure which did not give any error.

[root@nistnet include]# uname -rm
2.4.21-15.ELhugemem i686


Following is the output & error that i got on runnung "make"

[root@nistnet nistnet.2.0.12b]# make
set -e; for i in math lib cli monitor kernel man; do make -C $i ; done
make[1]: Entering directory `/root/nistnet.2.0.12b/math'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/root/nistnet.2.0.12b/math'
make[1]: Entering directory `/root/nistnet.2.0.12b/lib'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/root/nistnet.2.0.12b/lib'
make[1]: Entering directory `/root/nistnet.2.0.12b/cli'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/root/nistnet.2.0.12b/cli'
make[1]: Entering directory `/root/nistnet.2.0.12b/monitor'
making all in ./TextField-1.01...
make[2]: Entering directory `/root/nistnet.2.0.12b/monitor/TextField-1.01'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/root/nistnet.2.0.12b/monitor/TextField-1.01'
making all in ./Frame-1.0...
make[2]: Entering directory `/root/nistnet.2.0.12b/monitor/Frame-1.0'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/root/nistnet.2.0.12b/monitor/Frame-1.0'
rm -f xnistnet
gcc -m32 -o xnistnet -O2 -pipe -march=i386 -mcpu=i686 -fno-strict-aliasing -pip
e -L/usr/X11R6/lib hitmonitor.o xhitutil.o tabchain.o TextField-1.01/Text
Field.o Frame-1.0/Frame.o Frame-1.0/Gcs.o -lXaw3d -lXt -lSM -lICE -lXmu -lXt -lS
M -lICE -lXext -lX11 -lXext -lX11 ../lib/libnistnet.a -lm
/usr/bin/ld: cannot find -lXaw3d
collect2: ld returned 1 exit status
make[1]: *** [xnistnet] Error 1
make[1]: Leaving directory `/root/nistnet.2.0.12b/monitor'
make: *** [sub_dirs] Error 2
[root@nistnet nistnet.2.0.12b]#


Please help
Thanks
 
Old 08-11-2006, 01:33 PM   #2
pda_h4x0r
Member
 
Registered: Feb 2006
Location: somewhere in cyberspace
Distribution: Debian, Familiar
Posts: 380

Rep: Reputation: 30
It seems the library libxaw3D isn't installed. Try installing it and running "make" again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
So many errors when I typed the "make" and "make install" command Niceman2005 Linux - Software 23 07-22-2009 02:33 PM
window maker "make" / "make install" problem xiekke Fedora 2 08-08-2007 10:55 AM
Constant errors during "make" or "make install" with SUSE 10.1 Alpha 4 TehFlyingDutchman Linux - Software 3 12-30-2005 06:25 PM
Linux Installation Probelm - "Invalid System Disk" wfernley Linux - Newbie 2 08-06-2005 05:36 PM
problem "make"ing gtk+ "/usr/bin/env: perl -w" caid Linux - Newbie 8 07-29-2005 04:51 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration