LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-07-2004, 11:34 AM   #1
jasarien
Member
 
Registered: Apr 2004
Location: Wales, UK
Distribution: Fedora Core 3
Posts: 31

Rep: Reputation: 15
Please Help!? gDesklets Install Errors


I'm trying to install gDesklets-0.26.1, but during ./configure, it says that gnome-python-2.0 can't be found.... heres the full error:
Code:
checking for gnome-python-2.0 >= 1.99.17 pygtk-2.0 >= 1.99.17... Package gnome-python-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gnome-python-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gnome-python-2.0' found
 
configure: error: Library requirements (gnome-python-2.0 >= 1.99.17 pygtk-2.0 >= 1.99.17) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
[jamie@localhost gDesklets-0.26.1]$
I downloaded Python-2.3.3 and installed that without a hitch, but I still get the exact same error.... can someone help please??? I would do as it says and add the DIR to the variable.......... But I don't know how to do that....

Last edited by jasarien; 04-07-2004 at 11:35 AM.
 
Old 04-07-2004, 12:46 PM   #2
redhatnoob
Member
 
Registered: Jun 2003
Location: NY
Distribution: Red Hat 9
Posts: 66

Rep: Reputation: 15
I used to have the same problem. Just try to uninstall the python packages and full install the newer version. you can also research setting the variable to the location of the pc file. i believe its in the /usr/bin/include but its been while since i dealt with this issue.
 
Old 04-07-2004, 12:51 PM   #3
jasarien
Member
 
Registered: Apr 2004
Location: Wales, UK
Distribution: Fedora Core 3
Posts: 31

Original Poster
Rep: Reputation: 15
Ok, I've set the variable to point to the correct PKG_CONFIG_PATH, and it finds the gnome-python-2.0.pc now - but now I'm getting the same error when compiling but with PYGTK-2.0.pc.. The thing is, PYGTK-2.0.pc isn't in the dir with the gnome-python-2.0.pc.... i might need to install PYGTK right? but will that .pc file come with it?

geez....

Last edited by jasarien; 04-07-2004 at 12:53 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
.. "Gdesklets" how can I install it ??? .. Blue Jacket Linux - Software 2 10-18-2005 03:28 AM
How-To: Install gdesklets on Slackware 9.0 artistikone LinuxQuestions.org Member Success Stories 34 01-12-2005 06:32 PM
gdesklets display install... nicoli33 Linux - Software 0 01-05-2005 02:10 PM
Network Install errors during the install steve_f60 Linux - General 0 07-13-2004 06:25 PM
Can't install gDesklets! :( Tyir Linux - Software 2 11-20-2003 10:07 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration