LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-05-2003, 02:01 AM   #1
chem1
Member
 
Registered: Jun 2002
Location: White House, Washignton DC
Distribution: Red Hat 9
Posts: 270

Rep: Reputation: 30
Question PHP Installation Error


Hi Guys,
I am trying to install PHP 4.3.2 form source but when I try to 'make it' I get the following error:

ln: creating hard link `ctype.o' to `ctype.lo': Operation not permitted

I am using :

./configure --with-mysql --with-apxs2=/usr/local/apache2/bin/apxs
to get the make file

Any ideas whats happening here?

Thankx in advance...
 
Old 07-05-2003, 05:59 AM   #2
nautilus_1987
Member
 
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Rep: Reputation: 30
use that tuorial to make your Apache+PHP work
Code:
# Move to /usr/local
cd /usr/local
# Get the following source:

ftp://ftp.openssl.org/source/openssl-0.9.7.tar.gz
ftp://ftp.modssl.org/source/mod_ssl-...-1.3.27.tar.gz
http://www.apache.org/dist/httpd/apache_1.3.27.tar.gz
http://www.linuxguruz.org/downloads/php-4.3.0.tar.gz
http://mysql.secsup.org/Downloads/My...3.23.55.tar.gz
http://www.boutell.com/gd/http/gd-2.0.11.tar.gz

# Decompress the sources:
tar -xvzf openssl-0.9.7.tar.gz
tar -xzvf mod_ssl-2.8.12-1.3.27.tar.gz
tar -xvzf apache_1.3.27.tar.gz
tar -xvzf php-4.3.0.tar.gz
tar -xvzf mysql-3.23.55.tar.gz
tar -xvzf gd-2.0.11.tar.gz
# Compile the sources:
cd gd-2.0.11
./configure
make
cd ../mysql-3.23.55
./configure
make
make install
scripts/mysql_install_db
adduser mysql
# In the file /etc/login.access add this line:
-:mysql:ALL
# So the user mysql never actualy logs in
# For Slackware:
chown -R mysql.users /usr/local/var
# For Redhat:
chown -R mysql.mysql /usr/local/var
safe_mysqld --user=mysql &
# Hit <Enter>
mysqladmin -u root password 'yourpasswordhere'
cd ../openssl-0.9.7
sh config -fPIC
make
# If you get a "Not enough room for program headers" error here,
# install the LATEST version of binutils.
cd ../mod_ssl-2.8.12-1.3.27
./configure --with-apache=../apache_1.3.27
cd ../apache_1.3.27
SSL_BASE=../openssl-0.9.7 \
./configure --prefix=/usr/local/apache --enable-module=most \
 --enable-shared=max --enable-module=ssl --enable-shared=ssl
make
# Note: There is a Redhat bug that complains about mod_auth_dbm.so
# durning the Apache `make` proccess. Adding the configuration
# switch --disable-module=auth_dbm to the end of the ./configure line
# will fix it.
make certificate
# If you presently have a libphp4.so module you should make a backup:
cp /usr/local/apache/libexec/libphp4.so /usr/local/apache/libexec/libphp4.so.was
# If you have a file called /usr/local/apache/conf/httpd.conf already you
# should make a backup:
mv /usr/local/apache/conf/httpd.conf /usr/local/apache/conf/httpd.conf.was
# This way you'll get a fresh httpd.conf with all your Apache modules listed
# and 100% loadable.
# Don't worry if your web server is presently running. The httpd.conf file
# is only read by the httpd binary when starting the web server.
make install
cd ../php-4.3.0
./configure \
 --with-apxs=/usr/local/apache/bin/apxs \
 --with-config-file-path=/usr/local/apache/conf \
 --enable-versioning \
 --with-mysql=/usr/local \
 --enable-ftp \
 --with-gd=/usr/local/gd-2.0.11 \
 --enable-bcmath \
 --disable-debug \
 --enable-memory-limit=yes \
 --enable-track-vars
make
make install
# Make sure you have, Uncomment (remove the #'s), Change or Create
# the following lines in the file /usr/local/apache/conf/httpd.conf
LoadModule php4_module        libexec/libphp4.so
AddModule mod_php4.c
<IfModule mod_dir.c>
DirectoryIndex index.html index.php index.php3 index.phtml
</IfModule>
    # And for PHP 4.x, use:
    #
AddType application/x-httpd-php .php .php3 .phtml
AddType application/x-httpd-php-source .phps
cp /usr/local/php-4.3.0/php.ini-dist /usr/local/apache/conf/php.ini
# Start Apache:
/usr/local/apache/bin/apachectl startssl
# Create a file in /usr/local/apache/htdocs called index.php
<html>
<head><title>PHP Test Page</title></head>
<body>
<? phpinfo(); ?>
</body>
</html>
# Point your Web Browser at:
http://localhost/index.php
 
Old 07-05-2003, 03:13 PM   #3
chem1
Member
 
Registered: Jun 2002
Location: White House, Washignton DC
Distribution: Red Hat 9
Posts: 270

Original Poster
Rep: Reputation: 30
Nopes ...
same error.......
Why does it say "operation not permitted"......


Thankx in advance...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
PHP Installation Error Raggit Linux - Software 9 07-30-2008 11:18 PM
How to add options in php.in after installation of PHP? touqeeransar Linux - Software 1 11-30-2005 04:52 AM
PHP parse error in config.inc.php.in Confusedious Linux - Software 2 11-03-2005 05:08 AM
php installation gubak Linux - Networking 1 08-18-2004 01:16 PM
php-4.3.4 installation jules_fraser Linux - Software 0 12-14-2003 05:15 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration