LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-24-2006, 03:09 AM   #1
ilnli
Member
 
Registered: Jul 2004
Location: Pakistan
Distribution: Slackware 10.0, SUSE 9.1, RH 7, 7.3, 8, 9, FC2
Posts: 413

Rep: Reputation: 32
php error


I'm trying to install php from source with following command
./configure --prefix=/www/php --with-apxs2=/www/bin/apxs --with-config-filepath=/www/php --enable-sockets --with-mysql=/usr/local/mysql --with-zlibdir=/usr/include –with-gd
its giving me the following error.

[root@dd-wrt php-4.3.11]# make install
Installing PHP SAPI module: apache2handler
/www/build/instdso.sh SH_LIBTOOL='/www/build/libtool' libphp4.la /www/modules
/www/build/libtool --mode=install cp libphp4.la /www/modules/
cp .libs/libphp4.lai /www/modules/libphp4.la
cp .libs/libphp4.a /www/modules/libphp4.a
ranlib /www/modules/libphp4.a
chmod 644 /www/modules/libphp4.a
libtool: install: warning: remember to run `libtool --finish /root/cacti-install/php-4.3.11/libs'
Warning! dlname not found in /www/modules/libphp4.la.
Assuming installing a .so rather than a libtool archive.
chmod 755 /www/modules/libphp4.so
chmod: cannot access `/www/modules/libphp4.so': No such file or directory
apxs:Error: Command failed with rc=65536
 
Old 08-25-2006, 08:43 AM   #2
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,542

Rep: Reputation: 101Reputation: 101
Here's my PHP configure line:

./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-mysql=/usr/local/mysql --with-apache2 --with-config-file-path=/usr/local/lib --with-gd --with-zlib --with-zlib-dir=/home/monitor/cvs-1.11.5/zlib/ --with-jpeg-dir=/home/stefan/jpeglib --with-png-dir=/home/stefan/pnglib --with-tiff-dir=/home/stefan/tiff --with-freetype-dir=/home/stefan/freetype-2.1.10 --with-libxml-dir=/home/stefan/libxml2-2.6.19 --with-java=/usr/java/j2sdk1.4.2_05/ --with-pear=/usr/local/lib/php --with-dom --enable-sockets --enable-ftp --enable-gd-native-ttf --enable-dbx --enable-shmop --enable-filepro --enable-bcmath --enable-calendar --enable-dio --enable-exif --with-fam --enable-mbstring --enable-soap --enable-wddf --enable-yp --enable-zend-multibyte --enable-force-cgi-redirect --enable-safe-mode --enable-versioning --enable-url-includes --enable-trans-sid --with-ldap --enable-discard-path --with-mcal --with-mod-dav --with-kerberos --enable-gd-imgstrttf --with-gdbm --with-gettext --disable-cgi --with-openssl --with-zip

Note that my --with-apxs2 refers to my installed Apache instance's directory... might this be the problem? Your's doesn't seem to...
 
Old 08-25-2006, 09:50 AM   #3
ilnli
Member
 
Registered: Jul 2004
Location: Pakistan
Distribution: Slackware 10.0, SUSE 9.1, RH 7, 7.3, 8, 9, FC2
Posts: 413

Original Poster
Rep: Reputation: 32
no my --with-apxs2 is also pointing to apache folder.
 
Old 08-25-2006, 09:54 AM   #4
isuck@linux
Member
 
Registered: Jun 2006
Distribution: messed up debian
Posts: 250

Rep: Reputation: 30
/www/modules/libphp4.so find that file in your hd or create a soft link to the existing file and you'll be on your way. for example if you have a library called libphph4.so.1 make a soft link ln -s /xxx/yyy/libphp4.so.1 /www/modules/libphp4.so and should work.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error compiling php 5.1 and also a fantastico error arachn1d Linux - Software 0 02-19-2006 04:52 PM
PHP parse error in config.inc.php.in Confusedious Linux - Software 2 11-03-2005 05:08 AM
PHP error? jacksmash Programming 4 03-28-2004 09:33 PM
PHP error? Or MySQL error? DoobyWho Linux - General 5 04-09-2003 10:31 AM
php error TravisB Programming 4 06-26-2002 06:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration