LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-21-2004, 12:08 PM   #1
tbriden
LQ Newbie
 
Registered: Sep 2004
Posts: 11

Rep: Reputation: 0
LIRC and the Creative RM-1000


has anybody got this working? i have the latest lirc running and have created /etc/lircd.conf file using the one for RM-1000 on the website but don't know what else to do for the control to actually work. I've also got the xmms plugin and enabled it but nothing happens if i try the remote with that either (and yes the red light on my audigy2 flashes when i press any of the remote buttons)

thanks in advance

Tom
 
Old 12-06-2004, 12:11 AM   #2
thas
Member
 
Registered: Jan 2003
Location: Canada
Distribution: Mandrake
Posts: 30

Rep: Reputation: 15
Tom,

I have the very same issue. I am using MEPIS linux (based on Debian unstable) and I managed to build the module and install it. YET, when I run "mode2" command as root, I get absolutely nothing :-(

do you have the module loaded? ie. what does 'lsmod | grep -i lirc' return?
does the lircd daemon run without any errors? ie. what does 'ps -aux | grep -i lirc' return?

Cheers,
Thas
 
Old 12-15-2004, 02:38 PM   #3
thas
Member
 
Registered: Jan 2003
Location: Canada
Distribution: Mandrake
Posts: 30

Rep: Reputation: 15
Here are some more steps that I attempted. Could you please let me know if they work for you?

- First of all, CIMR100 does not appear to require a special kernel module. You just need the lircd daemon and it communicates via standard RS232 (I think).
- Sym link the serial device to which the IR receiver is connected to /dev/lirc: ln -s /dev/ttyS0 /dev/lirc
- Copy the appropriate lircd.conf to /etc/lircd.conf
- run the command: setserial /dev/ttyS0
- you should get something like: /dev/ttyS0, UART: 16550A, Port: 0x03f8, IRQ: 4
- now run lircd pointing it directly to the serial device:
lircd -d /dev/ttyS0

NOTE: I'm assuming that the creative IR receiver is connected to COM1 (/dev/ttyS0)

Came across above pointers at : http://mythtv.org/pipermail/mythtv-u...ne/008232.html

Please let me know if they work for you. I have had no luck (yet!).

-Thas
 
Old 01-11-2005, 11:03 AM   #4
tbriden
LQ Newbie
 
Registered: Sep 2004
Posts: 11

Original Poster
Rep: Reputation: 0
i dont get any output with the lsmod command. Im totally stumped for getting it working. the ir reciever is part of my audigy2 extigy box so what device would it be?
 
Old 02-05-2005, 10:16 AM   #5
tbriden
LQ Newbie
 
Registered: Sep 2004
Posts: 11

Original Poster
Rep: Reputation: 0
ok i originally just gave up on this but have now got more time so am playing again

the latest lirc is installed and the RM1000 config is in /etc/lircd.conf
the IR port itself is part of the Audigy2 Platinum Extigy Box, what is the device name for this or should it work with /dev/ttyS0?
running mode2 gives:

This program is only intended for receivers supporting the pulse/space layer.
Note that this is no error, but this program simply makes no sense for your
receiver.
In order to test your setup run lircd with the --nodaemon option and
then check if the remote works with the irw tool.

not sure what to do here but ran lircd --nodaemon and it just sits waiting for another input (i assume) saying:

lircd 0.7.0: lircd(dsp) ready


im thinkin that using the remote now should bring the code up of what was pressed but no joy, despite the red light on the extigy flashing when i press a button.

I think the problem is just gettin the device right or is there something else ive missed?

Tom
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
1000 pardons supern00b5 Linux - General 1 05-31-2005 12:49 PM
A 1000 Posts LinuxLala LQ Suggestions & Feedback 8 08-17-2004 10:56 AM
lirc and creative infra reciever cratos Slackware 1 06-14-2004 09:56 AM
1000 Posts XavierP LQ Suggestions & Feedback 3 10-11-2003 11:37 AM
1000 Posts Mathieu General 7 09-13-2003 04:04 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration