LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-04-2004, 11:56 PM   #1
DJOtaku
Member
 
Registered: Oct 2004
Location: USA
Distribution: Fedora 25;CentOS 7; Kubuntu; Debian
Posts: 860

Rep: Reputation: 37
language support in KDE


On a recent Fedora Core 2 install (third computer) I installed Spanish and Vietnamese language. Both languages worked on the Gnome desktop, changing my Kbar and desktop text to the proper language. In KDE, however, it didn't work - at least for Vietnamese (I didn't get to try spanish, but I think I tried it before and it didn't work) The way that I picked the language to use was in the beginning where I put in my user name and password. Is there something I need to do or download to make these languages work in KDE?

thanks!
 
Old 12-05-2004, 12:40 AM   #2
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 53
K-> Settings -> Controll Center -> Regional & Accessability -> Country/Region & Language
I believe you can choose three languages
if kde can't find a translation it will move down the list or at the end default to english
it may also work in the controlling shell before you startx to simply do
export LANG=
 
Old 12-05-2004, 10:21 AM   #3
DJOtaku
Member
 
Registered: Oct 2004
Location: USA
Distribution: Fedora 25;CentOS 7; Kubuntu; Debian
Posts: 860

Original Poster
Rep: Reputation: 37
Those instructions worked for adding spanish, but then when I logged back in with Spanish as the language, the K-bar wasn't in spanish. Yet, I know it will be in Gnome. Perhaps I'm missing a step?

I added spanish in the default languages in that menu that you told me about.
 
Old 12-05-2004, 10:41 AM   #4
DJOtaku
Member
 
Registered: Oct 2004
Location: USA
Distribution: Fedora 25;CentOS 7; Kubuntu; Debian
Posts: 860

Original Poster
Rep: Reputation: 37
Ok, I figured out one way to do it, but it's so roundabout, there must be some other way.

I set spanish as the top default language in the country region/language. This made help files and dialogues in spanish, but the kicker and desktop were still in english. Then I logged out and logged back in (setting spanish as the language for good measure) and viola! everything was in spanish. This is all fine and dandy, but it is a bit roundabout. Is there a way to reload the desktop without logging out and back in?

Thanks,
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
all language support in X apikoros Linux - Software 0 11-22-2005 03:45 AM
Language Support BattousaiX Linux - Newbie 3 07-03-2004 03:43 PM
Language Support mikeshn Linux - General 2 06-26-2003 11:36 PM
KDE 3 Support arbic Language !!!! unixman Linux - General 0 01-27-2003 11:04 AM
language support UNIX Linux - Newbie 1 12-07-2002 07:32 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration