LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-07-2006, 07:59 AM   #1
pingvina
Member
 
Registered: Nov 2005
Distribution: slack
Posts: 188

Rep: Reputation: 30
keyboard input problem


Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbLayout" "us,bg"
Option "XkbOptions" "grp:shift_toggle"
EndSection

i have this i /etx/X11/xorg.conf
press shift_alt - i can only write numbers and symbols in console
in firefox - squares
 
Old 08-07-2006, 10:27 AM   #2
twoHats
Member
 
Registered: Apr 2006
Location: New Hampshire, USA
Distribution: Mandriva - Kubuntu - FC4 - Mepis
Posts: 35

Rep: Reputation: 15
keyboard?

I assume the kbd works elsewhere?

may be font or locale setting - may be console configuration.

Here is my config - seems much more comprehensive ...

Code:
Section "InputDevice"
    Identifier "Keyboard1"
    Driver "kbd"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"

    # For most OSs the protocol can be omitted (it defaults to "Standard").
    # When using XQUEUE (only for SVR3 and SVR4, but not Solaris),
    # uncomment the following line.

    # Option     "Protocol"      "Xqueue"

    Option "AutoRepeat" "500 30"

    # Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
    # Option    "Xleds"      "1 2 3"

    # Option "LeftAlt"     "Meta"
    # Option "RightAlt"    "ModeShift"

    # To customise the XKB settings to suit your keyboard, modify the
    # lines below (which are the defaults).  For example, for a non-U.S.
    # keyboard, you will probably want to use:
    # Option "XkbModel"    "pc105"
    # If you have a US Microsoft Natural keyboard, you can use:
    # Option "XkbModel"    "microsoft"
    #
    # Then to change the language, change the Layout setting.
    # For example, a german layout can be obtained with:
    # Option "XkbLayout"   "de"
    # or:
    # Option "XkbLayout"   "de"
    # Option "XkbVariant"  "nodeadkeys"
    #
    # If you'd like to switch the positions of your capslock and
    # control keys, use:
    # Option "XkbOptions"  "ctrl:swapcaps"

    # These are the default XKB settings for Xorg
    # Option "XkbRules"    "xorg"
    # Option "XkbModel"    "pc105"
    # Option "XkbLayout"   "us"
    # Option "XkbVariant"  ""
    # Option "XkbOptions"  ""

    # Option "XkbDisable"

    Option "XkbRules" "xorg"
    Option "XkbOptions" "compose:rwin"
EndSection

Last edited by twoHats; 08-07-2006 at 10:34 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
weird emacs/xemacs problem Suse 10.0: no keyboard input rewtedesco Linux - Software 3 07-13-2006 10:08 AM
how do i disable keyboard input? thebover Linux - Newbie 5 08-24-2004 10:13 AM
my mouse input is takes as keyboard input in BASH e1000 Slackware 5 12-08-2003 03:00 PM
newbie installation problem: no keyboard/mouse input vytlacil Linux - Newbie 0 08-09-2003 06:03 PM
No keyboard input seen neo77777 Linux - General 5 07-12-2002 09:32 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration