LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-30-2008, 10:36 PM   #1
waelaltaqi
Member
 
Registered: Sep 2005
Location: USA, TN
Distribution: CentOS & Ubuntu for Desktop
Posts: 454

Rep: Reputation: 31
Kernal Panic when installing CentOS 5


I'm trying to install CentOS 5 IBM Netfinty 5000. I recently rebuilt the RAID setup and now it looks like this:

- logical drive 1: 2x4GB RAID 1
- logical drive 2: 3x9GB RAID 5

When i try to boot from CentOS cd i get the following message.
Code:
Cannot open root device "(NULL)" or unknown-block(253,0)
Please append a correct "root=" boot option
Kernel Panic - not syncing : VFS : Unable to mount root of on uknown-block(253,0)
Note that the server was working perfect with CentOS 4 for a long time.
when i boot into IBM's RAID utility (which is a linux little distro by the way), the utility tells me that everything is alright. My disks are online , arrays are healthy and should be working like a champ.

i tried to boot "linux rescue" hoping i could modify some options but it's getting back to the same error. Any suggestions?
 
Old 01-30-2008, 10:42 PM   #2
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Linux Mint 17, Debian 8
Posts: 7,865

Rep: Reputation: 311Reputation: 311Reputation: 311Reputation: 311
One possibility is that your initrd doesn't conform to your new raid configuration. After you rebuilt the RAID setup did you install a new initrd?

----------------------
Steve Stites
 
Old 01-31-2008, 12:24 AM   #3
waelaltaqi
Member
 
Registered: Sep 2005
Location: USA, TN
Distribution: CentOS & Ubuntu for Desktop
Posts: 454

Original Poster
Rep: Reputation: 31
i tried installing ubuntu server and that gave me a little more details. As you suspected there was a problem loading initrd to the memory due 'sda read error' which lead me to think that it's a problem with my RAID config

Well i think it's the stupid RAID utility. After running the 'create logical disk' the RAID utility asks you if you want to exit before it finishes syncing and consolidating the new disks. I rebuild the drives and the utility is running through the build process right now but that's gonna take all night so i will let you guys know tomorrow.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernal panic after installing more memory, won't boot 9nine9 Fedora 5 11-21-2007 11:19 AM
kernal Panic while installing rhel 3 Mclaren Red Hat 2 03-23-2007 01:03 AM
kernal panic after update redhat enterprice 4 from kernal(2.6.9-5) to kernal(2.6.9-42 TAREK-SALAMA Linux - Enterprise 3 09-10-2006 10:07 AM
centos wont install, kernal panic no sync - fatal exception in interrupt Atown Linux - Hardware 1 05-23-2006 07:31 PM
kernal panic problem installing red hat 7.1 chl Linux - Software 6 11-27-2001 08:36 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration