LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-08-2005, 02:00 PM   #1
linux-rulz
Member
 
Registered: Dec 2004
Distribution: Windows XP Home, Ubuntu Hoary
Posts: 584

Rep: Reputation: 30
Java Segmentation Fault


I am trying to run a bunch of different programs and Java keeps giving me a segmentation fault. I hava deleted the .java folder in my home folder and reinstalled java and it still does it.

Here is the output when I try to run Limewire from a console. Oh and Firefox crashes when I try to run a Java applet.

[rmcgregor@RyanHP ~]$ limewire
Starting LimeWire...
Java exec found in PATH. Verifying...
Suitable java version found [java = 1.5.0_02]
Configuring environment...
Loading LimeWire:
runLime.sh: line 86: 21401 Segmentation fault ${JAVA_PROGRAM_DIR}java -Dorg.apache.commons.logging.Log=org.apache.commons.logging.impl.NoOpLog -Djava.library.path=. -jar LimeWire.jar

******************************************************************
Something went wrong with LimeWire.
Maybe you're using the wrong version of Java?
(LimeWire is tested against and works best with with Sun's JRE, Java 1.4+)
The version of Java in your PATH is:
java version "1.5.0_02"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_02-b09)
Java HotSpot(TM) Client VM (build 1.5.0_02-b09, mixed mode, sharing)

[rmcgregor@RyanHP ~]$
 
Old 04-08-2005, 02:19 PM   #2
linux-rulz
Member
 
Registered: Dec 2004
Distribution: Windows XP Home, Ubuntu Hoary
Posts: 584

Original Poster
Rep: Reputation: 30
Does anyone think it is wise installing the IBM JRE?
 
Old 04-08-2005, 02:25 PM   #3
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 52
i've used the ibm jre before -- it runs good

it might just be the wrong version of java like the output says
or over the years new versions of java lots of time have troubles on linux
 
Old 04-08-2005, 02:30 PM   #4
linux-rulz
Member
 
Registered: Dec 2004
Distribution: Windows XP Home, Ubuntu Hoary
Posts: 584

Original Poster
Rep: Reputation: 30
lol, too bad sun doesnt let you download older versions of java....but i got it working again with Sun's JRE.

Now Java applets in Firefox won't work? lol
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
yast segmentation fault, system freezing - nvidia driver at fault? BaltikaTroika SUSE / openSUSE 2 12-02-2005 10:34 AM
Java Crash with Segmentation fault on 2.4.9-e.3smp.#1 SMP manojkp Red Hat 0 06-23-2005 05:39 PM
Firefox Java Install - Segmentation fault jrichardson Linux - Software 1 05-13-2005 11:51 AM
segmentation fault r_x Linux - Software 3 04-26-2005 06:22 AM
Why do i get a Segmentation fault laclac01 Programming 20 12-10-2004 10:33 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration