LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-05-2008, 08:16 PM   #16
sonichedgehog
Member
 
Registered: Oct 2007
Location: London UK
Distribution: Fedora Core 17
Posts: 296

Original Poster
Rep: Reputation: 32

I was puzzled to find that one of my boxes - the old self-build I want to use as a terminal- uses vncviewer without any trouble. It was built with a Debian Testing iso. However my larger server was built earlier using Debian Stable 4.0, but with testing written into sources.list so that any new apps are up to date. This had created a mix of versions, albeit one that works really well for me in all other respects. In this case, I can't set the passwords using vncpasswd because of the missing files as per my previous post. Research confirms (I believe) that this is an issue arising from updates. It relates to a number of distros, and all sorts of applications.
What is really confusing me is that the files are located on the Debian website within Stable- however it is the "stable" build that has the problem in my case.
Should I go ahead and synaptic remove the vnc apps, then apt-get update with stable in my sources list (and testing commented out) before reinstalling? Seems messy but perhaps the only way to set up vncviewer.
 
Old 05-06-2008, 02:56 AM   #17
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Testing"
Posts: 6,111

Rep: Reputation: 413Reputation: 413Reputation: 413Reputation: 413Reputation: 413
Quote:
error while loading shared libraries: libstdc++-libc6.2-2.so.3: cannot open shared object file: No such file or directory
I am not sure what is going on here.
Perhaps you should start by making sure you have both libstdc++ (my version is 6) and libc6 installed.
 
Old 05-06-2008, 03:48 PM   #18
Rustylinux
Member
 
Registered: Mar 2006
Posts: 177

Rep: Reputation: 30
Quote:
Originally Posted by sonichedgehog View Post
Made the suggested change to rc.local... problem now is:
$ vncviewer server:1
vncviewer: error while loading shared libraries: libstdc++-libc6.2-2.so.3: cannot open shared object file: No such file or directory
Hopping around the net, this is a common error message but none of the posts seem to lead to a solution, including, I think, on LQ. Perhaps I haven't looked hard enough? I can't see anything that exactly fits the bill in synaptic, and don't want to get into installing stuff at random. I haven't spent long on this because as you all use Debian or similar I hoped you might have dealt with this...?
Hey,

I worked in an enviroment where we had a bunch of red hat servers at one point and used vnc to remote into them. We had a simular problem where the display woudln't work on the first 1 or 2 views for some odd reason. We tried a bunch of stuff and couldn't get it going or find any answers as to why the first few video modes didn't work so as a work around we just started on video mode 3. If it ever started lower we just started a new session with a higher mode. Try running your vncserver4 for that user and see if it works.

If that doesn't work try running all the sessions at the same time and see what happens.

I also found this:

":1" here means that the server has been started on display 1. Vncserver will take up the first available display. To start vncserver on a specific display, use "vncserver :[display-number]".

vncserver :3

Now, let's connect to the server and check whether it is accessible. While in X, open a Xterm window and run vncviewer.

vncviewer [server]:[display]

vncviewer freeos:1

You can use hostnames or IP addresses here. Do not forget to include the display number to connect to. There can be multiple desktops running on separate displays so you should specify the one you want to connect to. Enter the password to connect with. If correct you will be looking at a desktop in a window.

By default VNC uses the twm window manger but this can easily be modified to your liking. Open the file $HOME/.vnc/xstartup in a editor. Look for "twm &" and modify that to run the window manger of your liking. Our choice was Windowmaker for which we modified the line to "wmaker &". KDE user may want to user "startkde &" here. You can also place any other commands here that you might want to run at startup. To stop a server use "vncserver -kill :display".

vncserver -kill :1 will kill the display running on 1.

For the life of me I can't remeber if we just started the display mode on 3 or we had 2 other sessions running in the background to force it to start on 3 all the time. All i can remeber is it only worked on 3 and higher for us for some reason :P

Sorry I couldn't be more help I forget what we exactly did to get around that. Its been a few years :P

Last edited by Rustylinux; 05-06-2008 at 03:55 PM.
 
Old 05-06-2008, 03:58 PM   #19
Rustylinux
Member
 
Registered: Mar 2006
Posts: 177

Rep: Reputation: 30
You can also try this:


sudo apt-get install libstdc++2.10-glibc2.2


and see if it will install the proper libraries, it seems you might be missing a few or the ones you have are an older version that is not compadable.
 
Old 05-06-2008, 06:34 PM   #20
sonichedgehog
Member
 
Registered: Oct 2007
Location: London UK
Distribution: Fedora Core 17
Posts: 296

Original Poster
Rep: Reputation: 32
Thanks tredegar & Rustylinux, I did apt-get upgrade- still same error but with a prettier desktop- then put etch back in sources.list, & searched on libstdc, installed libstdc++2.10-dbg, "-dev and "-glibc2.2, by sheer luck the next time I got the vncviewer option ok, set the vncpasswd as directed, back into vncviewer, gave dialogue box prompting for VNC server name, everything I put in gets "aborted" without error message. I have tried servername, servername:1 etc, <serveripaddress> & same with :1, etc. The clue here is in the boot messages. I have 3 virtual desktops now, 1 for each user, set up in rc.local as recommended. So it is logical that I have 3 messages: "You will need a password to access your desktops <SPACES> Password:getpassword error: Inappropriate ioctl for device".
I have also used vncserver- this gave me
Quote:
you will require a password to access your desktops.

Passwordentered)
Verifyentered)

New 'server:1 (username)' desktop is server:1

Creating default startup script /home/username/.vnc/xstartup
Starting applications specified in /home/username/.vnc/xstartup
I should add that username here (which is me) is in fact the first user written into rc.local

I am rather confused by the ioctl message- I've made some progress here but doubt I'll get further without guidance.

Thanks!

Log file is /home/phil/.vnc/jan:1.log
Now I am really puzzled-
 
Old 05-07-2008, 12:43 PM   #21
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Testing"
Posts: 6,111

Rep: Reputation: 413Reputation: 413Reputation: 413Reputation: 413Reputation: 413
Your last post is a bit hard to follow.
You seem to have resolved the dependencies
Now the problem is passwords? I think the trouble is that we are starting a vncserver, for the first time, from rc.local
The first time you start it, you need to think of and supply a password, but rc.local cannot interact with you because you are not logged in. I think that's the reason for the error message.
So:
Comment out those vncserver lines in rc.local
Reboot, or just kill all vnc processes

Start a vncserver for user1 like this (for simplicity, I am going to delete the old passwd file, if it exists):
Code:
su - user1
rm /home/user1/.vnc/passwd
vncserver  :1 -geometry 1024x768 -depth 24
You should be asked for a password (twice).
Give it. It then says "Starting applications specified in /home/user1/.vnc/xstartup"

Make sure that the file xstartup is starting the correct thing: I am using KDE so it just needs one line:
Code:
startkde &
If you are using gnome, you'll need something else, or when you login to your vnc "desktop" you might find yourself at no desktop, or a very strange one. If this happens, kill the vnc process, edit xstartup so it will start the right thing, and re-try starting up a vncserver

Now see if you can connect to the new desktop.
In a terminal:
vncviewer localhost:1
You will be asked for the password you gave earlier.
A new window will open in your GUI, for user1's desktop.

Once you have it working for user1, do the same (Assign passwords, make sure xstartup is starting the right window manager, make sure you can connect) for the other users.

When all is happiness, uncomment the entries in rc.local so the vncservers can be brought up on different displays for the different users at boot.

Last edited by tredegar; 05-07-2008 at 12:45 PM.
 
Old 05-07-2008, 06:17 PM   #22
sonichedgehog
Member
 
Registered: Oct 2007
Location: London UK
Distribution: Fedora Core 17
Posts: 296

Original Poster
Rep: Reputation: 32
Thanks Tredegar, apologies for muddle at end of post. I guessed it was the password issue, went into each user & set the password from terminal, then tested rc.local manually- the ioctl has disappeared. ""Aborted" is still happening, I guess the clue is http://www.realvnc.com/products/ente...nown-bugs.html, "Programs exit with "Aborted" when run against some versions of libstdc++." stated to be fixed in 4.2.7 altho I don't know how that fits in with the Debian repositories? Interestingly, before I got rc.local working, I was able to use vncviewer to connect to the active session here from another box, with -no surprise- window issues, which you have now shown me how to correct. I'm going to have another shot at this at the weekend.
 
Old 05-08-2008, 07:09 PM   #23
sonichedgehog
Member
 
Registered: Oct 2007
Location: London UK
Distribution: Fedora Core 17
Posts: 296

Original Poster
Rep: Reputation: 32
quick look @ xstartup:

Quote:
#!/bin/sh

[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
twm &
Ok so twm is the wm it will be trying to start, replace it with startkde? I don't know why I get twm here when I use KDE... however if I understand correctly the file needs nothing more than startkde &. Is this why I am getting "aborted?"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I tear down an active tcp/udp session thru my firewall drokmed Linux - Security 9 04-11-2008 01:07 PM
FC5 / Ubuntu home directory sharing without sharing session information cdhgee Fedora 1 07-26-2006 06:47 PM
Remote into active session??? tiger.woods Linux - General 11 03-29-2006 07:16 AM
remote desktop in suse 9.1 - grant access each session? spankmeister7 Linux - Networking 1 08-05-2004 03:34 AM
Active X session Sonte Linux - Newbie 1 03-06-2004 02:43 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration