LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-10-2008, 04:58 PM   #1
symidran
LQ Newbie
 
Registered: May 2006
Distribution: Kubuntu 11.10 "Oneiric"
Posts: 28

Rep: Reputation: 16
How to update KDE ?


Hi
I have just installed Fedora 9 from the Fedora Live CD KDE disk, and since this is a new experience I wanted to learn how to update KDE to the latest version 4.1.1
I get no updates when i do yum update kde or yum update kde4
Also, i downloaded the KDE base 4.1 .rpm file but when I try to open it I get errors or dependancy problems

Plz Help
 
Old 09-10-2008, 05:50 PM   #2
w3bd3vil
Senior Member
 
Registered: Jun 2006
Location: Hyderabad, India
Distribution: Fedora
Posts: 1,191

Rep: Reputation: 49
I guess the 4.1 version is still under testing, can you check if this works
Quote:
yum --enablerepo=updates-testing groupupdate "KDE (K Desktop Environment)"
A better thing would be to try and clear yum cache first
Quote:
yum clean all
yum update kde

Last edited by w3bd3vil; 09-10-2008 at 05:54 PM.
 
Old 09-11-2008, 01:41 AM   #3
symidran
LQ Newbie
 
Registered: May 2006
Distribution: Kubuntu 11.10 "Oneiric"
Posts: 28

Original Poster
Rep: Reputation: 16
I did and got this-
Code:
[root@localhost ]# yum clean all
Loaded plugins: refresh-packagekit
Cleaning up Everything
[root@localhost ]# yum update kde
Loaded plugins: refresh-packagekit
fedora                                                   | 2.4 kB     00:00
primary.sqlite.bz2                                       | 6.1 MB     00:57
updates                                                  | 2.6 kB     00:00
primary.sqlite.bz2                                       | 9.1 kB     00:00
Setting up Update Process
Could not find update match for kde
No Packages marked for Update
And yes KDE 4.1.1 is the latest stable release according to this
 
Old 09-11-2008, 06:54 AM   #4
w3bd3vil
Senior Member
 
Registered: Jun 2006
Location: Hyderabad, India
Distribution: Fedora
Posts: 1,191

Rep: Reputation: 49
what about this?
Quote:
yum --enablerepo=updates-testing groupupdate "KDE (K Desktop Environment)"
 
Old 09-11-2008, 07:04 AM   #5
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,083

Rep: Reputation: 404Reputation: 404Reputation: 404Reputation: 404Reputation: 404
Quote:
Originally Posted by symidran View Post
And yes KDE 4.1.1 is the latest stable release according to this
Be warned that the term "stable" is subjective.

If you don't mind an occasional hang-up, some memory leaks here and there, and some applications that randomly close then it's fine.

Don't misunderstand me. 4.1 is a big big leap, nothing to do with 4.0, but still needs some love and care. Also, some applications have not been ported. It can be usable for you or not, depending on your requirements.

If you want a really stable desktop, stay in 3.x which is still actively maintained.
 
Old 09-11-2008, 09:27 AM   #6
symidran
LQ Newbie
 
Registered: May 2006
Distribution: Kubuntu 11.10 "Oneiric"
Posts: 28

Original Poster
Rep: Reputation: 16
Thanks for the advice i92guboj but my main aim is to learn, updating KDE is just a step on that path.

w3bd3vil, could you plz explain what that command does ? Also if possible, can I manually download and the .rpm files and then install ?
Because I also need to install gcc and I guess I will have to do it manually.
Thx for trying to help me
EDIT : OK tried and got this
Code:
[root@localhost ~]# yum --enablerepo=updates-testing groupupdate "KDE (K Desktop Environment)"
Loaded plugins: refresh-packagekit
Setting up Group Process
Package kaffeine-0.8.6-4.fc9.i386 already installed and latest version
Package zenity-2.22.1-1.fc9.i386 already installed and latest version
Package konversation-1.0.1-6.fc9.i386 already installed and latest version
Package kpowersave-0.7.3-3.fc9.i386 already installed and latest version
Package 1:NetworkManager-gnome-0.7.0-0.9.3.svn3623.fc9.i386 already installed and latest version
Package 6:kdepim-3.5.9-9.fc9.i386 already installed and latest version
Package kipi-plugins-0.1.5-0.6.rc2.fc9.i386 already installed and latest version
Package kftpgrabber-0.8.1-6.fc9.i386 already installed and latest version
Package extragear-plasma-4.0.1-5.fc9.i386 already installed and latest version
Package kde-settings-pulseaudio-4.0-22.fc9.1.noarch already installed and latest version
Package pinentry-qt-0.7.4-5.fc9.i386 already installed and latest version
Package ksshaskpass-0.4-2.fc9.i386 already installed and latest version
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: kdebase-workspace = 4.0.3-20.fc9 for package: kdebase-workspace-libs
---> Package kdegames.i386 6:4.1.0-2.fc9 set to be updated
--> Processing Dependency: libkdegames.so.5 for package: kdegames
--> Processing Dependency: kdegames-libs = 6:4.1.0-2.fc9 for package: kdegames
---> Package kdeartwork.i386 0:4.1.0-1.fc9 set to be updated
--> Processing Dependency: kdelibs4 >= 4.1.0 for package: kdeartwork
---> Package kdebase.i386 6:4.1.0-1.fc9.1 set to be updated
--> Processing Dependency: kdebase-libs = 6:4.1.0-1.fc9.1 for package: kdebase
---> Package scribus.i386 0:1.3.4-5.fc9 set to be updated
--> Processing Dependency: python-imaging for package: scribus
--> Processing Dependency: tkinter for package: scribus
---> Package kdeaccessibility.i386 1:4.1.0-1.fc9 set to be updated
---> Package digikam.i386 0:0.9.3-2.fc9 set to be updated
---> Package kdeutils.i386 6:4.1.0-1.fc9.1 set to be updated
---> Package amarok.i386 0:1.4.8-5.fc9 set to be updated
--> Processing Dependency: libnjb.so.5 for package: amarok
--> Processing Dependency: libifp.so.4 for package: amarok
--> Processing Dependency: ruby for package: amarok
--> Processing Dependency: libmtp.so.7 for package: amarok
---> Package kdeedu.i386 0:4.1.0-1.fc9 set to be updated
--> Processing Dependency: libgps.so.17 for package: kdeedu
--> Processing Dependency: libcln.so.5 for package: kdeedu
--> Processing Dependency: kdeedu-math = 4.1.0-1.fc9 for package: kdeedu
--> Processing Dependency: libkdeeduui.so.4 for package: kdeedu
--> Processing Dependency: libcfitsio.so.0 for package: kdeedu
--> Processing Dependency: libnova-0.12.so.1 for package: kdeedu
--> Processing Dependency: libavogadro-kalzium.so.0 for package: kdeedu
--> Processing Dependency: libmarblewidget.so.4 for package: kdeedu
--> Processing Dependency: libqalculate.so.4 for package: kdeedu
--> Processing Dependency: libgsl.so.0 for package: kdeedu
--> Processing Dependency: libgslcblas.so.0 for package: kdeedu
--> Processing Dependency: libkiten.so.4 for package: kdeedu
--> Processing Dependency: libkeduvocdocument.so.4 for package: kdeedu
--> Processing Dependency: kdeedu-libs = 4.1.0-1.fc9 for package: kdeedu
--> Processing Dependency: kdeedu-kstars = 4.1.0-1.fc9 for package: kdeedu
--> Processing Dependency: libsbigudrv.so.1 for package: kdeedu
--> Processing Dependency: libopenbabel.so.3 for package: kdeedu
--> Processing Dependency: libphonon.so.4 for package: kdeedu
--> Processing Dependency: libscience.so.4 for package: kdeedu
--> Processing Dependency: libanalitza.so.4 for package: kdeedu
---> Package kdemultimedia.i386 6:4.1.0-1.fc9 set to be updated
--> Processing Dependency: kdemultimedia-libs = 6:4.1.0-1.fc9 for package: kdemultimedia
---> Package ktorrent.i386 0:3.1.2-1.fc9 set to be updated
---> Package kdebase-workspace.i386 0:4.1.0-8.fc9 set to be updated
--> Processing Dependency: libcapseo.so.0 for package: kdebase-workspace
--> Processing Dependency: ksysguardd = 4.1.0-8.fc9 for package: kdebase-workspace
--> Processing Dependency: kdebase-runtime >= 4.1.0 for package: kdebase-workspace
--> Processing Dependency: libQtWebKit.so.4 for package: kdebase-workspace
--> Processing Dependency: libcaptury.so.0 for package: kdebase-workspace
---> Package kdegraphics.i386 7:4.1.0-3.fc9 set to be updated
--> Processing Dependency: kdegraphics-libs = 7:4.1.0-3.fc9 for package: kdegraphics
--> Processing Dependency: libkolourpaint_lgpl.so.4 for package: kdegraphics
--> Processing Dependency: libgwenviewlib.so.4 for package: kdegraphics
--> Processing Dependency: libkipi.so.5 for package: kdegraphics
---> Package kdenetwork.i386 7:4.1.0-2.fc9 set to be updated
--> Processing Dependency: libkopete_oscar.so.4 for package: kdenetwork
--> Processing Dependency: libotr.so.2 for package: kdenetwork
--> Processing Dependency: libkopetestatusmenu.so.1 for package: kdenetwork
--> Processing Dependency: kdepimlibs >= 4.1.0 for package: kdenetwork
--> Processing Dependency: kdenetwork-libs = 7:4.1.0-2.fc9 for package: kdenetwork
--> Processing Dependency: libkopete_otr_shared.so.1 for package: kdenetwork
--> Running transaction check
---> Package kdeedu-kstars.i386 0:4.1.0-1.fc9 set to be updated
---> Package phonon.i386 0:4.2.0-2.fc9 set to be updated
--> Processing Dependency: phonon-backend for package: phonon
---> Package kdelibs.i386 6:4.1.0-5.fc9 set to be updated
--> Processing Dependency: soprano >= 2.1 for package: kdelibs
--> Processing Dependency: qt4 >= 4.4.0 for package: kdelibs
---> Package tkinter.i386 0:2.5.1-25.fc9 set to be updated
--> Processing Dependency: libTix.so for package: tkinter
--> Processing Dependency: libtcl8.5.so for package: tkinter
--> Processing Dependency: libtk8.5.so for package: tkinter
---> Package kdegames-libs.i386 6:4.1.0-2.fc9 set to be updated
---> Package gsl.i386 0:1.10-10.fc9 set to be updated
---> Package kdebase-libs.i386 6:4.1.0-1.fc9.1 set to be updated
---> Package qt-x11.i386 1:4.4.1-2.fc9 set to be updated
---> Package ruby.i386 0:1.8.6.114-1.fc9 set to be updated
---> Package libotr.i386 0:3.1.0-2.fc9 set to be updated
---> Package libnjb.i386 0:2.2.6-3.fc9 set to be updated
---> Package libnova.i386 0:0.12.1-3.fc9 set to be updated
---> Package libifp.i386 0:1.0.0.2-7.fc9 set to be updated
---> Package kdepimlibs.i386 0:4.1.0-2.fc9 set to be updated
--> Processing Dependency: libakonadiprotocolinternals.so.1 for package: kdepimlibs
---> Package libmtp.i386 0:0.2.6.1-1.fc9 set to be updated
---> Package libqalculate.i386 0:0.9.6-4.fc9 set to be updated
---> Package kdebase-workspace-libs.i386 0:4.1.0-8.fc9 set to be updated
---> Package kdebase-runtime.i386 0:4.1.0-1.fc9 set to be updated
---> Package cfitsio.i386 0:3.060-3.fc9 set to be updated
---> Package gpsd.i386 0:2.37-2.fc9 set to be updated
--> Processing Dependency: libplasma.so.1 for package: extragear-plasma
---> Package cln.i386 0:1.2.0-1.fc9 set to be updated
---> Package kdemultimedia-libs.i386 6:4.1.0-1.fc9 set to be updated
---> Package kdenetwork-libs.i386 7:4.1.0-2.fc9 set to be updated
---> Package kdeedu-math.i386 0:4.1.0-1.fc9 set to be updated
--> Processing Dependency: libboost_python-mt.so.3 for package: kdeedu-math
---> Package kdeedu.i386 0:4.1.0-1.fc9 set to be updated
--> Processing Dependency: libopenbabel.so.3 for package: kdeedu
---> Package python-imaging.i386 0:1.1.6-9.fc9 set to be updated
---> Package kdegraphics-libs.i386 7:4.1.0-3.fc9 set to be updated
---> Package ksysguardd.i386 0:4.1.0-8.fc9 set to be updated
---> Package kdeedu-libs.i386 0:4.1.0-1.fc9 set to be updated
--> Processing Dependency: libopenbabel.so.3 for package: kdeedu-libs
---> Package kdebase-workspace.i386 0:4.1.0-8.fc9 set to be updated
--> Processing Dependency: libcapseo.so.0 for package: kdebase-workspace
--> Processing Dependency: libcaptury.so.0 for package: kdebase-workspace
--> Running transaction check
---> Package phonon-backend-gst.i386 0:4.2.0-2.fc9 set to be updated
---> Package tix.i386 1:8.4.2-5.fc9 set to be updated
---> Package boost.i386 0:1.34.1-13.fc9 set to be updated
--> Processing Dependency: libicuuc.so.38 for package: boost
--> Processing Dependency: libicui18n.so.38 for package: boost
---> Package tcl.i386 1:8.5.1-4.fc9 set to be updated
---> Package akonadi.i386 0:1.0.0-2.fc9 set to be updated
--> Processing Dependency: qt4-mysql for package: akonadi
---> Package kdeplasma-addons.i386 0:4.1.0-1.fc9 set to be updated
---> Package tk.i386 1:8.5.1-3.fc9 set to be updated
---> Package qt.i386 1:4.4.1-2.fc9 set to be updated
---> Package kdeedu.i386 0:4.1.0-1.fc9 set to be updated
--> Processing Dependency: libopenbabel.so.3 for package: kdeedu
---> Package soprano.i386 0:2.1-1.fc9 set to be updated
---> Package kdeedu-libs.i386 0:4.1.0-1.fc9 set to be updated
--> Processing Dependency: libopenbabel.so.3 for package: kdeedu-libs
---> Package kdebase-workspace.i386 0:4.1.0-8.fc9 set to be updated
--> Processing Dependency: libcapseo.so.0 for package: kdebase-workspace
--> Processing Dependency: libcaptury.so.0 for package: kdebase-workspace
--> Running transaction check
---> Package libicu.i386 0:3.8.1-7.fc9 set to be updated
---> Package kdeedu.i386 0:4.1.0-1.fc9 set to be updated
--> Processing Dependency: libopenbabel.so.3 for package: kdeedu
---> Package qt-mysql.i386 1:4.4.1-2.fc9 set to be updated
---> Package kdeedu-libs.i386 0:4.1.0-1.fc9 set to be updated
--> Processing Dependency: libopenbabel.so.3 for package: kdeedu-libs
---> Package kdebase-workspace.i386 0:4.1.0-8.fc9 set to be updated
--> Processing Dependency: libcapseo.so.0 for package: kdebase-workspace
--> Processing Dependency: libcaptury.so.0 for package: kdebase-workspace
--> Finished Dependency Resolution
kdebase-workspace-4.1.0-8.fc9.i386 from updates-testing has depsolving problems
  --> Missing Dependency: libcapseo.so.0 is needed by package kdebase-workspace-4.1.0-8.fc9.i386 (updates-testing)
kdebase-workspace-4.1.0-8.fc9.i386 from updates-testing has depsolving problems
  --> Missing Dependency: libcaptury.so.0 is needed by package kdebase-workspace-4.1.0-8.fc9.i386 (updates-testing)
kdeedu-4.1.0-1.fc9.i386 from updates-testing has depsolving problems
  --> Missing Dependency: libopenbabel.so.3 is needed by package kdeedu-4.1.0-1.fc9.i386 (updates-testing)
kdeedu-libs-4.1.0-1.fc9.i386 from updates-testing has depsolving problems
  --> Missing Dependency: libopenbabel.so.3 is needed by package kdeedu-libs-4.1.0-1.fc9.i386 (updates-testing)
Error: Missing Dependency: libcapseo.so.0 is needed by package kdebase-workspace-4.1.0-8.fc9.i386 (updates-testing)
Error: Missing Dependency: libcaptury.so.0 is needed by package kdebase-workspace-4.1.0-8.fc9.i386 (updates-testing)
Error: Missing Dependency: libopenbabel.so.3 is needed by package kdeedu-libs-4.1.0-1.fc9.i386 (updates-testing)
Error: Missing Dependency: libopenbabel.so.3 is needed by package kdeedu-4.1.0-1.fc9.i386 (updates-testing)

Last edited by symidran; 09-11-2008 at 09:39 AM.
 
Old 09-11-2008, 09:15 PM   #7
w3bd3vil
Senior Member
 
Registered: Jun 2006
Location: Hyderabad, India
Distribution: Fedora
Posts: 1,191

Rep: Reputation: 49
Ok, so you do get the updates, oddly enough yum couldnt find some of the dependencies on the updates-repo.
The reason why I gave you the other command is that not all yum repos have kde as stable yet. They must be updating that and it should be done in a while.

Yeah you can use the rpm's to install, but there will be alot of dependencies that you will need to install with it. Yum, basically does that for you.
Installing gcc for you shouldnt bring up any problems with yum, try
Quote:
yum install gcc
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do you update KDE? Morbid Linux - Software 3 12-17-2005 07:20 PM
Can someone help me update suse 9.1 KDE 3.2.1 to newer version of KDE Screetch Linux - Software 2 03-18-2005 10:29 PM
How can i update kde to kde 3.3.1 using yum? wicho_the_one Fedora 2 10-21-2004 06:50 PM
kde-3.3 update greythorne Linux - Distributions 1 09-01-2004 01:23 AM
KDE update and RH 9.0 Kernel update massacre Linux - Newbie 1 02-02-2004 07:13 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration