LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 09-08-2005, 05:08 PM   #1
fannymites
Member
 
Registered: Nov 2004
Posts: 242

Rep: Reputation: 30
How to disable gnome-keyring?


After updating from ubuntu hoary to breezy, I was asked to select a password for the default keyring.
Not knowing what this was or what it did I just entered the root password and now whenever I run apps as root I get a dialogue box saying the default keyring is locked and to enter the password.
I now want to permenantly disable gnome keyring altogether as I don't have any use for it but I can't find a way.
I've also tried deleting the keyrings via gnome-keyring-manager but after a reboot I get asked again.
 
Old 09-08-2005, 07:23 PM   #2
deepsix
Member
 
Registered: Apr 2003
Distribution: ANY
Posts: 336

Rep: Reputation: 31
well why dont you send me your keyring and ill have a look at it ........
j/k.....
 
Old 09-09-2005, 01:49 PM   #3
kanem
LQ Newbie
 
Registered: Sep 2005
Posts: 1

Rep: Reputation: 0
I went to /home/me/.gnome2/keyrings/ and erased default.keyring in that folder, and that worked. No more prompt for the keyring password. I made a backup of it though somewhere else just in case it's actually needed.
 
Old 07-12-2006, 02:39 PM   #4
nsfx
LQ Newbie
 
Registered: Apr 2006
Location: New Jersey, U.S.
Distribution: Frugalware
Posts: 17

Rep: Reputation: 0
I know this is a pretty old post but I'm stuck with this same problem. I can't seem to disable gnome key ring and it's really annoying.
 
Old 08-25-2006, 09:06 AM   #5
tyoungblood
LQ Newbie
 
Registered: Oct 2004
Distribution: FC2
Posts: 8

Rep: Reputation: 0
I generated an rsa key a week or so ago thinking it would make things more convenient when I ssh to other machines. Man, was I wrong. Now I get asked for two passwords everytime (one for the local key and one for accessing the remote system) instead of just one as the keyring functionality in fc5 appears to ignore the 'save password on keyring' option.

What a PITA.
 
Old 06-18-2008, 12:19 PM   #6
hydride
LQ Newbie
 
Registered: Jun 2008
Posts: 1

Rep: Reputation: 0
worked for me

solution 1:

from menu: System -> Preferences -> Sessions. Add new, with command "killall gnome-keyring-manager"

solution 2:
edit /etc/gconf/schemas/gnome-keyring.schemas as root, and search for "TRUE" in text, there should be one for ssh and one for pkcs, substitute "TRUE" with "FALSE" and ur done..
 
Old 04-28-2009, 02:45 AM   #7
samrat563n
LQ Newbie
 
Registered: Apr 2009
Posts: 1

Rep: Reputation: 0
Hi hydride

tried both options but not working for me. I am using fedora 10.

Last edited by samrat563n; 04-28-2009 at 03:07 AM.
 
Old 04-28-2009, 03:10 AM   #8
Lee_Ball
Member
 
Registered: Jul 2005
Location: Manchester (UK)
Distribution: Fedora CentOS
Posts: 132

Rep: Reputation: 18
I fixed this one time on my system:

http://www.leenukes.co.uk/?p=50
 
Old 11-11-2009, 10:17 AM   #9
elbie
LQ Newbie
 
Registered: Nov 2009
Location: Waterloo, Canada
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by samrat563n View Post
Hi hydride

tried both options but not working for me. I am using fedora 10.
In Fedora 11, you should be able to go to System->Preferences->Startup Applications, and uncheck "GNOME Keyring Daemon". I imagine it's similar for FC10.

You can then either log out and log back in, or just search for the gnome-keyring related processes owned by your userid and kill them.
 
Old 08-31-2010, 06:20 AM   #10
tavvva
LQ Newbie
 
Registered: Aug 2010
Posts: 2

Rep: Reputation: 0
The gnome-keyring-daemon seems to be started by evolution each time I start evolution.
I workarounded the problem by renaming the /usr/bin/gnome-keyring-daemon to /usr/bin/gnome-keyring-daemon.bak

It doesn't bother me anymore
 
Old 08-31-2010, 06:35 AM   #11
10110111
Member
 
Registered: Jun 2008
Location: St.-Petersburg, Russia
Distribution: (B)LFS, Ubuntu, SliTaz
Posts: 402

Rep: Reputation: 51
The solution for me was when i was asked for new keyring password, i just pressed enter with empty password.
 
Old 08-31-2010, 06:52 AM   #12
tavvva
LQ Newbie
 
Registered: Aug 2010
Posts: 2

Rep: Reputation: 0
Empty password didn't work for me ... as well as the same password like the login password. It's a bug, because I was getting new keyring files in ~/.gnome2/keyrings each time I was asked to enter a password.
 
Old 08-31-2010, 07:00 AM   #13
rikijpn
Member
 
Registered: Jun 2007
Location: Japan
Distribution: Debian lenny, DSL, Solaris 10
Posts: 157

Rep: Reputation: 33
I'm so glad I wasn't the only one who got annoyed by this feature... especially when using ssh><. gnome is starting to get too "user-friendly" if you ask me, I didn't like having gnome-panel and the new gnome wouldn't allow me to just disable it, so I ended up switching to sawfish.
Anyway, the "easiest" way to disable anything gnome, is using the gconf-editor. In the terminal type gconf-editor. Search for keyring (or ssh, etc) then just unclick (set to false/null) all the values you don't need.
 
Old 06-07-2011, 07:32 AM   #14
agivati
LQ Newbie
 
Registered: Jun 2011
Posts: 1

Rep: Reputation: Disabled
Cool It's easy in Ubuntu 11.4

If you have Ubuntu 11.4 - this easy procedure worked for me:
1. Click on "Application" (in the application starter on the screen left side).
2. Type in the word "startup"
3. Select the "Startup Application" icon
4. In the "Additional Startup Programs" list, clear the check-box of all Keyring services. I have 3 of them:
- "Certificate and Keyring Storage"
- "Secret Storage Service"
- "SSH Key Agent"
5. Click "Close" button
6. Restart the machine
That's it...

Enjoy.
 
Old 01-12-2012, 01:14 PM   #15
krustybaguette
LQ Newbie
 
Registered: Feb 2011
Location: Olde Sturbridge MA
Distribution: Linux Mint and Bodhi Linux
Posts: 18

Rep: Reputation: 1
Talking

Quote:
Originally Posted by hydride View Post
solution 1:

from menu: System -> Preferences -> Sessions. Add new, with command "killall gnome-keyring-manager"

solution 2:
edit /etc/gconf/schemas/gnome-keyring.schemas as root, and search for "TRUE" in text, there should be one for ssh and one for pkcs, substitute "TRUE" with "FALSE" and ur done..
Under Linux Mint 9 isadora I had same problem and finding gnome-keyring.schemas was a bit of a problem but once there I found THREE "TRUE's" to swap to "FALSE". There's also a setting at Menu/Preferences/StartupApplications which has THREE keyring related items. I unchecked all three. (I'm guessing that it's just a GUI that would have accomplished the same thing as editing the file manually!) In any case, after a reboot I saw no need to login to a "default Keyring". I had to enter my password for my wireless router however, so it remains to be seen if I have disabled the auto login for my wireless network.

Wow. I rebooted and saved my Firefox tabs and they were still here when rebooting done. No need to login to router. Hooray
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
keyring jmaloy Debian 3 07-30-2005 12:36 PM
Disable F1 in Gnome? tvmaly Linux - General 0 04-20-2005 03:02 PM
help with library libgnome-keyring.so.0 Slackeriz Slackware 2 04-17-2005 05:12 AM
Automatically mounting a keyring usb flash device... Frustin Linux - Hardware 1 10-24-2003 10:45 AM
Disable Gnome? cmoloney Linux - General 2 06-03-2003 03:13 AM


All times are GMT -5. The time now is 07:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration