LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-21-2016, 02:45 PM   #1
laredotornado
Member
 
Registered: Apr 2011
Posts: 71

Rep: Reputation: 0
How do I get past "libsystemd0 but it is not installable" issues when trying to intsall PostGres on Ubuntu?


Hi,

Iím trying to install postgresql-9.6 on Ubuntu 14.04. Iím getting these baffling errors Ö

Code:
	laredotornado@remotebox:~$ sudo apt-get install postgresql-9.6
	Reading package lists... Done
	Building dependency tree       
	Reading state information... Done
	Some packages could not be installed. This may mean that you have
	requested an impossible situation or if you are using the unstable
	distribution that some required packages have not yet been created
	or been moved out of Incoming.
	The following information may help to resolve the situation:
	
	The following packages have unmet dependencies:
	 postgresql-9.6 : Depends: postgresql-common (>= 171~) but it is not going to be installed
	                  Depends: libsystemd0 but it is not installable
	                  Recommends: postgresql-contrib-9.6 but it is not going to be installed
	                  Recommends: sysstat but it is not going to be installed
	E: Unable to correct problems, you have held broken packages.
I tried running these commands

Code:
sudo apt-get purge postgr*
sudo apt-get autoremove
sudo apt-get install synaptic
sudo apt-get update
and then I ran the above command again, but I still get the same error. What am I missing?
 
Old 10-22-2016, 09:30 AM   #2
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,824

Rep: Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615
What did you do to even see postgresql-9.6 on 14.04 ? Did you add a xenial repo or a trusty?

libsystemd0 isn't in 14.04, so it's not going to work as is.

I assume that if you add the trusty repo it will work, but I haven't tried. Alternately, update to 16.04.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] What is the exact process involved in creating installable .iso "snapshots" .. exoshwarze Linux - Distributions 5 07-16-2011 12:59 PM
Ubuntu/PHP/Postgres guy saying "yo" ken koehler LinuxQuestions.org Member Intro 2 03-02-2010 07:05 AM
invalid binary "/usr/bin/postgres" while running postgresql ukrainet Linux - Newbie 1 12-01-2004 08:36 AM
psql: FATAL 1: IDENT authentication failed for user "postgres" linuxtesting2 Linux - General 3 06-16-2004 12:48 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration