LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-12-2014, 05:22 AM   #1
akseli0x61
LQ Newbie
 
Registered: Aug 2014
Distribution: Arch
Posts: 19

Rep: Reputation: Disabled
fglrx failed to read VBIOS - X doesn't start


I tried to install the fglrx driver following the arch wiki catalyst page. After all installation steps i am not able to start x.
This is my xorg log:
Code:
[   984.446] 
X.Org X Server 1.15.2
Release Date: 2014-06-27
[   984.447] X Protocol Version 11, Revision 0
[   984.447] Build Operating System: Linux 3.15.1-1-ARCH x86_64 
[   984.447] Current Operating System: Linux arch 3.16.4-1-ARCH #1 SMP PREEMPT Mon Oct 6 08:22:27 CEST 2014 x86_64
[   984.447] Kernel command line: \vmlinuz-linux ro root=UUID=bd983b6b-0c8e-42b3-a8fc-3ad540af90e8 quiet spash nomodeset acpi_osi=Linux net.ifnames=0 pcie_aspm=force radeon.dpm=1 hpet=force b43.hwpctl=1 initrd=\initramfs-linux.img
[   984.447] Build Date: 27 June 2014  07:32:26PM
[   984.447]  
[   984.447] Current version of pixman: 0.32.6
[   984.447] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[   984.447] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   984.448] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Oct 12 11:47:20 2014
[   984.448] (==) Using config file: "/etc/X11/xorg.conf"
[   984.448] (==) Using config directory: "/etc/X11/xorg.conf.d"
[   984.448] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   984.448] (==) ServerLayout "aticonfig Layout"
[   984.448] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[   984.448] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
[   984.449] (**) |   |-->Device "aticonfig-Device[0]-0"
[   984.449] (==) Automatically adding devices
[   984.449] (==) Automatically enabling devices
[   984.449] (==) Automatically adding GPU devices
[   984.449] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[   984.449] 	Entry deleted from font path.
[   984.449] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[   984.449] 	Entry deleted from font path.
[   984.449] 	(Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[   984.449] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[   984.449] 	Entry deleted from font path.
[   984.449] 	(Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[   984.449] (==) FontPath set to:
	/usr/share/fonts/misc/,
	/usr/share/fonts/TTF/,
	/usr/share/fonts/Type1/
[   984.449] (**) ModulePath set to "/usr/lib/xorg/modules/updates,/usr/lib/xorg/modules"
[   984.449] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[   984.449] (II) Loader magic: 0x811cc0
[   984.449] (II) Module ABI versions:
[   984.449] 	X.Org ANSI C Emulation: 0.4
[   984.449] 	X.Org Video Driver: 15.0
[   984.449] 	X.Org XInput driver : 20.0
[   984.449] 	X.Org Server Extension : 8.0
[   984.451] (--) PCI: (0:0:2:0) 8086:0116:106b:00dc rev 9, Mem @ 0xb0000000/4194304, 0xa0000000/268435456, I/O @ 0x00003000/64
[   984.451] (--) PCI:*(0:1:0:0) 1002:6741:106b:00e2 rev 0, Mem @ 0x90000000/268435456, 0xb0800000/131072, I/O @ 0x00002000/256, BIOS @ 0x????????/131072
[   984.451] (II) Open ACPI successful (/var/run/acpid.socket)
[   984.451] Initializing built-in extension Generic Event Extension
[   984.451] Initializing built-in extension SHAPE
[   984.452] Initializing built-in extension MIT-SHM
[   984.452] Initializing built-in extension XInputExtension
[   984.452] Initializing built-in extension XTEST
[   984.452] Initializing built-in extension BIG-REQUESTS
[   984.452] Initializing built-in extension SYNC
[   984.452] Initializing built-in extension XKEYBOARD
[   984.452] Initializing built-in extension XC-MISC
[   984.452] Initializing built-in extension SECURITY
[   984.452] Initializing built-in extension XINERAMA
[   984.452] Initializing built-in extension XFIXES
[   984.452] Initializing built-in extension RENDER
[   984.452] Initializing built-in extension RANDR
[   984.452] Initializing built-in extension COMPOSITE
[   984.452] Initializing built-in extension DAMAGE
[   984.452] Initializing built-in extension MIT-SCREEN-SAVER
[   984.452] Initializing built-in extension DOUBLE-BUFFER
[   984.452] Initializing built-in extension RECORD
[   984.452] Initializing built-in extension DPMS
[   984.453] Initializing built-in extension Present
[   984.453] Initializing built-in extension DRI3
[   984.453] Initializing built-in extension X-Resource
[   984.453] Initializing built-in extension XVideo
[   984.453] Initializing built-in extension XVideo-MotionCompensation
[   984.453] Initializing built-in extension XFree86-VidModeExtension
[   984.453] Initializing built-in extension XFree86-DGA
[   984.453] Initializing built-in extension XFree86-DRI
[   984.453] Initializing built-in extension DRI2
[   984.453] (II) "glx" will be loaded by default.
[   984.453] (II) LoadModule: "glx"
[   984.453] (II) Loading /usr/lib/xorg/modules/updates/extensions/libglx.so
[   984.453] (II) Module glx: vendor="Advanced Micro Devices, Inc."
[   984.454] 	compiled for 6.9.0, module version = 1.0.0
[   984.454] Loading extension GLX
[   984.454] (II) LoadModule: "fglrx"
[   984.454] (II) Loading /usr/lib/xorg/modules/drivers/fglrx_drv.so
[   984.480] (II) Module fglrx: vendor="FireGL - AMD Technologies Inc."
[   984.480] 	compiled for 1.4.99.906, module version = 14.30.4
[   984.480] 	Module class: X.Org Video Driver
[   984.480] (II) Loading sub module "fglrxdrm"
[   984.480] (II) LoadModule: "fglrxdrm"
[   984.480] (II) Loading /usr/lib/xorg/modules/linux/libfglrxdrm.so
[   984.480] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[   984.480] 	compiled for 1.4.99.906, module version = 14.30.4
[   984.480] (II) AMD Proprietary Linux Driver Version Identifier:14.30.4
[   984.480] (II) AMD Proprietary Linux Driver Release Identifier: UNSUPPORTED-14.301.1001              
[   984.480] (II) AMD Proprietary Linux Driver Build Date: Sep 15 2014 18:11:36
[   984.480] (++) using VT number 1

[   984.481] (WW) Falling back to old probe method for fglrx
[   984.502] (II) Loading PCS database from /etc/ati/amdpcsdb /etc/ati/amdpcsdb.default
[   984.504] ukiDynamicMajor: found major device number 249
[   984.504] ukiDynamicMajor: found major device number 249
[   984.504] ukiOpenByBusid: Searching for BusID PCI:1:0:0
[   984.504] ukiOpenDevice: node name is /dev/ati/card0
[   984.504] ukiOpenDevice: open result is 10, (OK)
[   984.504] ukiOpenByBusid: ukiOpenMinor returns 10
[   984.504] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
[   984.511] (--) Chipset Supported AMD Graphics Processor (0x6741) found
[   984.511] (WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found
[   984.512] (II) fglrx(0): pEnt->device->identifier=0x18468b0
[   984.512] (II) fglrx(0): === [xdl_xs115_atiddxPreInit] === begin
[   984.512] (II) fglrx(0): FB driver is enabled
[   984.512] (II) Loading sub module "vgahw"
[   984.512] (II) LoadModule: "vgahw"
[   984.512] (II) Loading /usr/lib/xorg/modules/libvgahw.so
[   984.512] (II) Module vgahw: vendor="X.Org Foundation"
[   984.512] 	compiled for 1.15.2, module version = 0.1.0
[   984.512] 	ABI class: X.Org Video Driver, version 15.0
[   984.513] (**) fglrx(0): Depth 24, (--) framebuffer bpp 32
[   984.513] (II) fglrx(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
[   984.513] (==) fglrx(0): Default visual is TrueColor
[   984.513] (**) fglrx(0): Option "DPMS" "true"
[   984.513] (==) fglrx(0): RGB weight 888
[   984.513] (II) fglrx(0): Using 8 bits per RGB 
[   984.513] (==) fglrx(0): Buffer Tiling is ON
[   984.513] (II) Loading sub module "fglrxdrm"
[   984.513] (II) LoadModule: "fglrxdrm"
[   984.513] (II) Loading /usr/lib/xorg/modules/linux/libfglrxdrm.so
[   984.513] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[   984.513] 	compiled for 1.4.99.906, module version = 14.30.4
[   984.515] ukiDynamicMajor: found major device number 249
[   984.515] ukiDynamicMajor: found major device number 249
[   984.515] ukiOpenByBusid: Searching for BusID PCI:1:0:0
[   984.515] ukiOpenDevice: node name is /dev/ati/card0
[   984.515] ukiOpenDevice: open result is 12, (OK)
[   984.515] ukiOpenByBusid: ukiOpenMinor returns 12
[   984.515] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
[   984.516] (**) fglrx(0): NoAccel = NO
[   984.516] (**) fglrx(0): AMD 2D Acceleration Architecture enabled
[   984.516] (--) fglrx(0): Chipset: "AMD Radeon 6600M and 6700M Series" (Chipset = 0x6741)
[   984.516] (--) fglrx(0): (PciSubVendor = 0x106b, PciSubDevice = 0x00e2)
[   984.516] (==) fglrx(0): board vendor info: third party graphics adapter - NOT original AMD
[   984.516] (--) fglrx(0): Linear framebuffer (phys) at 0x90000000
[   984.516] (--) fglrx(0): MMIO registers at 0xb0800000
[   984.516] (--) fglrx(0): I/O port at 0x00002000
[   984.516] (==) fglrx(0): ROM-BIOS at 0x000c0000
[   984.516] (II) fglrx(0): AC Adapter is used
[   984.516] (EE) fglrx(0): Failed to obtain VBIOS from Kernel!
[   984.516] (--) fglrx(0): Video RAM: 0 kByte, Type: 
[   984.516] (II) fglrx(0): PCIE card detected
[   984.516] (--) fglrx(0): Using per-process page tables (PPPT) as GART.
[   984.516] (WW) fglrx(0): board is an unknown third party board, chipset is supported
[   984.516] (II) fglrx(0): [FB] MC range(MCFBBase = 0x0, MCFBSize = 0x0)
[   984.516] (II) fglrx(0): RandR 1.2 support is enabled!
[   984.516] (II) fglrx(0): RandR 1.2 rotation support is enabled!
[   984.516] (II) Loading sub module "fb"
[   984.516] (II) LoadModule: "fb"
[   984.517] (II) Loading /usr/lib/xorg/modules/libfb.so
[   984.517] (II) Module fb: vendor="X.Org Foundation"
[   984.517] 	compiled for 1.15.2, module version = 1.0.0
[   984.517] 	ABI class: X.Org ANSI C Emulation, version 0.4
[   984.517] (II) fglrx(0): EDID Management option: EDID Management is enabled
[   984.517] (II) Loading sub module "ddc"
[   984.517] (II) LoadModule: "ddc"
[   984.517] (II) Module "ddc" already built-in
[   984.521] (EE) fglrx(0): DAL initialization failed!
[   984.521] (EE) fglrx(0): Display Infrastructure Failed
[   984.521] (EE) fglrx(0): PreInit failed
[   984.521] (II) fglrx(0): === [xdl_xs115_atiddxPreInit] === end
[   984.524] (II) UnloadModule: "fglrx"
[   984.524] (II) UnloadSubModule: "fb"
[   984.525] (II) Unloading fb
[   984.525] (II) UnloadSubModule: "fglrxdrm"
[   984.525] (II) Unloading fglrxdrm
[   984.525] (II) UnloadSubModule: "vgahw"
[   984.525] (II) Unloading vgahw
[   984.525] (II) UnloadSubModule: "fglrxdrm"
[   984.525] (EE) Screen(s) found, but none have a usable configuration.
[   984.525] (EE) 
Fatal server error:
[   984.525] (EE) no screens found(EE) 
[   984.525] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[   984.525] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   984.525] (EE) 
[   984.533] (EE) Server terminated with error (1). Closing log file.
I also get these errors from dmesg | grep fglrx
Code:
[ 6.500443] <3>[fglrx:hal_read_VBIOS] *ERROR* Invalid AMD VBIOS at bus 1!
[ 6.500446] <3>[fglrx:hal_init_gpu] *ERROR* Failed to read VBIOS!
[ 6.500448] <6>[fglrx] device open failed with code -1
So I guess the problem is that fglrx can't read VBIOS. Does anybody have an idea of how to fix that?

Some info in case it helps:
I'm running Arch Linux on Macbook Pro 8,2.
My GPU is amd radeon. I'm not sure which version but lspci outputs: 01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Whistler [Radeon HD 6630M/6650M/6750M/7670M/7690M]
My Xorg version is 1.15.2
My kernel parameters are: quiet spash nomodeset acpi_osi=Linux net.ifnames=0 pcie_aspm=force radeon.dpm=1 hpet=force b43.hwpctl=1
I'm booting with refind
I'm installing catalyst from AUR (i've tried catalyst-total and catalyst-test)

Thanks for helping!

Last edited by akseli0x61; 10-12-2014 at 05:31 AM.
 
Old 10-12-2014, 07:05 AM   #2
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
Is there a reason for not using the radeon driver supplied by your kernel rather than installing fglrx?
jdk
 
Old 10-12-2014, 07:13 AM   #3
akseli0x61
LQ Newbie
 
Registered: Aug 2014
Distribution: Arch
Posts: 19

Original Poster
Rep: Reputation: Disabled
I'd like to reduce power consumption and heating.
 
Old 10-13-2014, 12:36 AM   #4
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
Quote:
Originally Posted by akseli0x61 View Post
I'd like to reduce power consumption and heating.
And what makes you think that using the fglrx rather than the radeon driver will accomplish this goal?
jdk
 
Old 10-13-2014, 02:03 AM   #5
akseli0x61
LQ Newbie
 
Registered: Aug 2014
Distribution: Arch
Posts: 19

Original Poster
Rep: Reputation: Disabled
Quote:
Compared with the open source driver, Catalyst performs better in both 2D and 3D rendering, also having better power management
That's from the arch wiki's catalyst page.
The benchmarks that i've seen show that it performs better in any test. I guess that means it takes less to do the same?
I've set up and configured TLP and I use every powersaving & heating option I have found that I can use on my machine.
Since watching videos increase the power drain and heating significantly I thought that switching the driver would solve at least part of the problem.
 
Old 10-14-2014, 02:12 AM   #6
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
Over the years and starting before the radeon driver entered the kernel I also used the fglrx drivers (I built them with module-assistant as I recall) for my AMD cards. This was mainly to get direct rendering/3D effects to work with those cards. A few years ago I switched to the radeon driver and have not noticed any adverse effects. YMMV, I guess.
jdk
 
  


Reply

Tags
catalyst, failed, fglrx, xorg


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
service start script doesn't show OK or FAILED bboopathi Linux - Newbie 2 07-18-2010 02:41 AM
Experts read: "failed to start the x server..." ruhollah Linux - Laptop and Netbook 5 11-19-2007 12:28 PM
fedora 7, fglrx, X doesn't start tpetri1807 Linux - Hardware 3 08-04-2007 02:20 PM
fglrx - failed dependacies schneidz Linux - Software 3 08-25-2005 08:56 PM
unpacking of archive failed: cpio: read failed-input/output error rafc Linux - Newbie 0 04-21-2004 10:03 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration