LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-12-2005, 06:41 AM   #1
shanu
LQ Newbie
 
Registered: Mar 2005
Location: Pune
Posts: 2

Rep: Reputation: 0
Facing problem while configuring OpenLDAP server


Hi all,

I m facing a problem while installing and configuring the OpenLDAP server. I have used the following command:

export LD_LIBRARY_PATH="/usr/local/src/db-4.3.27/build_unix/.libs"
./configure --enable-wrappers
make depend
make
make test

The make test command fails and the few lines of output of the make test command are:
Running ./scripts/all...
>>>>> Executing all LDAP tests for bdb
>>>>> Starting test000-rootdse ...
running defines.sh
Starting slapd on TCP/IP port 9011...
Using ldapsearch to retrieve the root DSE...
Waiting 5 seconds for slapd to start...
Waiting 5 seconds for slapd to start...
Waiting 5 seconds for slapd to start...
Waiting 5 seconds for slapd to start...
Waiting 5 seconds for slapd to start...
Waiting 5 seconds for slapd to start...
./scripts/test000-rootdse: line 48: kill: (27579) - No such process
ldap_bind: Can't contact LDAP server (-1)
>>>>> Test failed
>>>>> ./scripts/test000-rootdse failed (exit 1)
make[2]: *** [bdb-yes] Error 1
make[2]: Leaving directory `/ldap/openldap-2.2.23/tests'
make[1]: *** [test] Error 2
make[1]: Leaving directory `/ldap/openldap-2.2.23/tests'
make: *** [test] Error 2


Plz help me to if any one can resolve this problem.


Regards,
Pankaj Jain
 
Old 03-13-2005, 05:51 PM   #2
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 53
im not sure at all about trying to use the database libs uninstalled in their build directory like that ?
i can't imagine that that would work
is that because you needed a different version that your system db for this version of slapd ?

but beyond that since you used tcp_wrappers make sure you have 127.0.0.1 in the slapd line in /etc/hosts.allow
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
iam facing problem with asterisk Jimmy911 Fedora 0 03-07-2005 09:17 AM
facing problem while patching kernel bhupee Linux - Networking 0 06-24-2004 12:32 PM
facing problem with cronjobs manojthakkar Linux - General 7 12-10-2003 12:55 AM
thre's a problem facing me in the openoffice reaky Linux - Software 2 10-23-2003 06:49 AM
Problem facing on setup ADSL connection leeswen Linux - Hardware 0 10-01-2003 09:56 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration