LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-19-2014, 11:32 PM   #1
metrx
LQ Newbie
 
Registered: Feb 2014
Distribution: Debian AMD64
Posts: 7

Rep: Reputation: Disabled
Red face dpkg -i and aptitude conflict? (Debian Wheezy)


Hello guys,

I installed an application via
Code:
dpkg -i binreader.deb
But I am getting problems with aptitude now, as it wants to remove such program when I want to install another program, here an example with libreoffice:
Code:
root@dbkakarot:/home/bs# aptitude install libreoffice
The following NEW packages will be installed:
  fonts-lyx{a} fonts-opensymbol{a} fonts-sil-gentium{a} fonts-sil-gentium-basic{a} fonts-stix{a} libboost-date-time1.54.0{a} libboost-system1.54.0{a} libcdr-0.0-0{a} 
  libclucene-contribs1{a} libclucene-core1{a} libcmis-0.3-3{a} libcolamd2.8.0{a} libexttextcat-2.0-0{a} libexttextcat-data{a} libhsqldb1.8.0-java{a} libhyphen0{a} liblangtag-common{a} 
  liblangtag1{a} libmhash2{a} libmspub-0.0-0{a} libmwaw-0.1-1{a} libmythes-1.2-0{a} libodfgen-0.0-0{a} liborcus-0.6-0{a} libpython3.3{a} libraptor2-0{a} librasqal3{a} librdf0{a} 
  libreoffice libreoffice-base{a} libreoffice-base-core{a} libreoffice-calc{a} libreoffice-common{a} libreoffice-core{a} libreoffice-draw{a} libreoffice-impress{a} 
  libreoffice-java-common{a} libreoffice-math{a} libreoffice-report-builder-bin{a} libreoffice-style-galaxy{a} libreoffice-writer{a} libservlet2.5-java libvisio-0.0-0{a} 
  libwpd-0.9-9{a} libwpg-0.2-2{a} libwps-0.2-2{a} lp-solve{a} python3-uno{a} uno-libs3{a} ure{a} xfonts-mathml{a} 
The following packages will be upgraded:
  libpython3.3-minimal libpython3.3-stdlib 
The following partially installed packages will be configured:
  binreader{b} 
2 packages upgraded, 51 newly installed, 0 to remove and 228 not upgraded.
Need to get 96.0 MB of archives. After unpacking 321 MB will be used.
The following packages have unmet dependencies:
 binreader : Depends: mplayer but it is not going to be installed.
 python3.3 : Depends: libpython3.3-stdlib (= 3.3.4~rc1-1) but 3.3.4-1 is to be installed.
 python3.3-minimal : Depends: libpython3.3-minimal (= 3.3.4~rc1-1) but 3.3.4-1 is to be installed.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
Internal error: found 2 (choice -> promotion) mappings for a single choice.
The following actions will resolve these dependencies:

      Remove the following packages:                                           
1)      alacarte                                                               
2)      binreader                                                              
3)      dh-python                                                              
4)      foomatic-db-compressed-ppds                                            
5)      gnome-menus                                                            
6)      ipython3                                                               
7)      packagekit                                                             
8)      packagekit-backend-aptcc                                               
9)      packagekit-tools                                                       
10)     printer-driver-dymo                                                    
11)     printer-driver-escpr                                                   
12)     printer-driver-foo2zjs                                                 
13)     printer-driver-foo2zjs-common                                          
14)     printer-driver-m2300w                                                  
15)     printer-driver-ptouch                                                  
16)     printer-driver-pxljr                                                   
17)     python3                                                                
18)     python3-dbus                                                           
19)     python3-decorator                                                      
20)     python3-gi                                                             
21)     python3-minimal                                                        
22)     python3-packagekit                                                     
23)     python3-pkg-resources                                                  
24)     python3-simplegeneric                                                  
25)     python3.3                                                              
26)     python3.3-minimal                                                      

      Keep the following packages at their current version:                    
27)     libreoffice [Not Installed]                                            
28)     python3-uno [Not Installed]                                            

      Leave the following dependencies unresolved:                             
29)     foomatic-db-engine recommends foomatic-db-compressed-ppds | foomatic-db
30)     libreoffice-common recommends python3-uno (>= 4.0~) | python-uno       
31)     printer-driver-min12xxw recommends foomatic-db                         
32)     libpackagekit-glib2-16 recommends packagekit (= 0.8.16-1)              
33)     printer-driver-all recommends printer-driver-dymo                      
34)     printer-driver-all recommends printer-driver-escpr                     
35)     printer-driver-all recommends printer-driver-foo2zjs                   
36)     printer-driver-all recommends printer-driver-m2300w                    
37)     printer-driver-all recommends printer-driver-ptouch                    
38)     printer-driver-all recommends printer-driver-pxljr                     
39)     python3.3-minimal recommends python3.3                                 


Accept this solution? [Y/n/q/?]
Also, I dont want to de-install Python 3, why are all these strange things happening?

My System:
Code:
bs@dbkakarot:~$ uname -a
Linux dbkakarot 3.12.3-031203-generic #201312041453 SMP Wed Dec 4 19:54:05 UTC 2013 x86_64 GNU/Linux
My /etc/apt/sources.list:
Code:
bs@dbkakarot:~$ cat /etc/apt/sources.list
# 

# deb cdrom:[Debian GNU/Linux 7.3.0 _Wheezy_ - Official amd64 DVD Binary-1 20131215-04:56]/ wheezy contrib main

#deb cdrom:[Debian GNU/Linux 7.3.0 _Wheezy_ - Official amd64 DVD Binary-1 20131215-04:56]/ wheezy contrib main

# Line commented out by installer because it failed to verify:
deb http://security.debian.org/ wheezy/updates main contrib
# Line commented out by installer because it failed to verify:
deb-src http://security.debian.org/ wheezy/updates main contrib

# wheezy-updates, previously known as 'volatile'
# A network mirror was not selected during install.  The following entries
# are provided as examples, but you should amend them as appropriate
# for your mirror of choice.
#
 deb http://ftp.debian.org/debian/ wheezy-updates main contrib
 deb-src http://ftp.debian.org/debian/ wheezy-updates main contrib

deb http://http.debian.net/debian wheezy main contrib non-free
deb http://http.debian.net/debian testing main contrib non-free
deb http://http.debian.net/debian experimental main contrib non-free
deb http://http.debian.net/debian wheezy-backports main
deb http://repository.spotify.com stable non-free
Sometimes I need testing and experimental, is there a way to remove experimental though and only use it when needed ? (Without modified the line in /etc/apt/sources.list all the time...)

I am looking forward to any help.
Thank you.

Edit:
Ok, sorry, just ignore me, its almost 5am and I was watching to many memory addresses, it just says it in the message....:
Code:
The following packages have unmet dependencies:
 binreader : Depends: mplayer but it is not going to be installed.
 python3.3 : Depends: libpython3.3-stdlib (= 3.3.4~rc1-1) but 3.3.4-1 is to be installed.
 python3.3-minimal : Depends: libpython3.3-minimal (= 3.3.4~rc1-1) but 3.3.4-1 is to be installed.
I installed mplayer and python3, everything got solved. I also uncommented the experimental though... Good night!

Last edited by metrx; 02-19-2014 at 11:44 PM.
 
Old 02-20-2014, 12:04 AM   #2
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with LFS.
Posts: 2,900

Rep: Reputation: 637Reputation: 637Reputation: 637Reputation: 637Reputation: 637Reputation: 637
Experimental does not install automatically so to install something from Experimental you have to give apt a specific instruction to do so.

The issue is happening because you installed a package that has unresolved dependencies. I'd remove binreader and then see if aptitude want to remove anything when you try to install something new using aptitude. If it works then reinstall binreader.
 
Old 02-20-2014, 12:24 AM   #3
descendant_command
Senior Member
 
Registered: Mar 2012
Posts: 1,712

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
Also you should remove all the "wheezy" lines and just leave the "testing" one and complete the dist-upgrade to jessie (or expect these problems to continue until your machine is totally screwed).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
aptitude-gtk not working at all in wheezy( testing ) rupeshforu Debian 3 01-02-2013 08:54 AM
How do I mark mplayer for non-installation w/ apt-get/ aptitude/ dpkg? NirvanaII Linux - General 5 04-10-2011 06:13 PM
Debian - Are dpkg, apt-get, aptitude... safely "mixable"? armandino Linux - General 5 02-07-2011 12:52 PM
Debian 4 Stable - dpkg/apt-get/aptitude - Database reading issue? Brian Ryans Debian 1 05-18-2007 05:09 AM
What is the difference between dpkg and aptitude/apt-get? Akhran Debian 13 03-14-2006 12:33 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration