LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-03-2004, 11:30 AM   #1
JediKnight2
LQ Newbie
 
Registered: Jul 2004
Posts: 22

Rep: Reputation: 15
Downgrade OpenSSH...Help


I am going from RH9 to FC1 and am getting

Package openssh needs libcom_err.so.3, this is not available.
Package openssh-clients needs libcom_err.so.3, this is not available.
Package openssh-server needs libcom_err.so.3, this is not available.

I found out that if I downgrade to openssh-3.6.1... from openssh-3.8.1... that I can fix this issue. Problem is that this is a remote computer that I connect to using Putty and SSH...So I am afraid to rpm -e any of it because I am in a session.

I have tried rpm -Uvh --oldpackage openssh-3.6.1...but I get the openssh-client and openssh-server need openssh-3.8.1 error...

Can somebody tell me how to do this...safetly...
 
Old 07-03-2004, 08:02 PM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 270Reputation: 270Reputation: 270
First of all, don't downgrade as some of the earlier versions had serious exploits. Secondly have you tried to just install the dependencies its asking for? But yeah, you could uninstall ssh while connected as its most likely in memory, etc and won't lose it unless you disconnected or restarted sshd, etc.

But search rpmfind.net for the libs or files its wanting, install to fulfill its needs..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel Downgrade dlc2000 Linux - General 2 10-24-2005 10:42 AM
Downgrade Kernel? apachedude SUSE / openSUSE 1 10-22-2005 05:25 AM
how to downgrade from 9.2 to 9.1 netsurf SUSE / openSUSE 10 04-10-2005 12:44 PM
downgrade glibc subash Linux - General 8 08-14-2003 12:13 AM
downgrade glibc subash Linux - General 0 08-13-2003 04:11 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration