LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-21-2010, 01:54 PM   #1
andrews-mark
Member
 
Registered: Feb 2007
Location: London
Distribution: debian
Posts: 108

Rep: Reputation: 15
disable firefox acrobat plugin?


Hi - I am trying to stop acrobat automatically opening and embedding a pdf reader in firefox whenever I download a pdf. I can't for the life of me find a way to turn it off (short of editing a file called pluginreg.dat which clearly states "Do not edit").

I have tried the following:

about:config in firefox gives me no option to disable plugins of any kind (odd, as others report that that is where one does this kind of thing using plugin.disable_full_page_plugin_for_types or some such, but nothing like that is there for me)

edit->preferences->applications is no help. it says "portable document format" should lead to an "always ask" question. clearly, this is being overridden

finally, disabling acrobat settings like "allow fast web view" does nothing.

Surely there is a way to do this?
-m
 
Old 10-21-2010, 01:57 PM   #2
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Remove the file for the plugin from your plugins directory? It's called something like nppdf.so, but about:plugins will give you the correct filename.
 
Old 10-22-2010, 01:32 AM   #3
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
1. Go to FFx's Tools menu.
2. Click on the Add-ons menu item.
3. Click on Plugins
4. Highlight the pdf plugin
5. Click on "Disable"
Job done.
jdk

Last edited by jdkaye; 10-22-2010 at 01:35 AM.
 
Old 10-22-2010, 05:39 AM   #4
andrews-mark
Member
 
Registered: Feb 2007
Location: London
Distribution: debian
Posts: 108

Original Poster
Rep: Reputation: 15
Dear jdkaye,
Done! That was embarrassingly easy (with emphasis now on the embarrassing).
thank you,
-m
 
Old 10-22-2010, 08:48 AM   #5
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
Quote:
Originally Posted by andrews-mark View Post
Dear jdkaye,
Done! That was embarrassingly easy (with emphasis now on the embarrassing).
thank you,
-m
Nah. You asked the right question and you got a solution. Nothing embarassing with that. I'm glad to have been of service. Keep on tuxin'
jdk
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Firefox problem: web server checking Acrobat plugin 298 Linux - Software 8 08-14-2015 08:28 PM
[SOLVED] ubuntu 9.10, 64, pdf won't open in firefox after disabling acrobat 9.1 plugin Ranny Linux - Software 7 12-06-2009 05:17 AM
howto disable firefox plugin - gxine? ygloo Linux - Desktop 5 03-20-2009 11:23 AM
Adobe Acrobat 7 - Plugin for Firefox broken apachedude Linux - Software 41 12-28-2006 07:09 PM
Firefox Acrobat plugin eightbits Linux - Software 1 09-18-2005 08:29 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration