LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-19-2005, 05:59 PM   #1
kentri9
Member
 
Registered: Aug 2004
Distribution: Fedora Core 2
Posts: 39

Rep: Reputation: 15
cups problem - special characters


hi

My printer doesn't print Danish special characters (like ... can you see them?) properly.
It shows simply blank space where those special characters shoud be.

On the screen, Emacs shows those characters in UTF-8.
/etc/cups/cupsd.conf says that default character set is UTF-8.

Can anyone help me?

printer is hp deskjet 920c. Distro is FC2.
 
Old 02-20-2005, 12:55 AM   #2
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 53
there is a set of international bitmap fonts for printing in emacs
i think the package is called intlfonts-bdf

i think you have to set the variable
ps-multibyte-buffer
to
bdf-font (uses bdf totally)
or
bdf-font-except-latin (uses only for non latin chars)

you may have to set the variable
bdf-directory-list
to find the fonts

of the top of my head try this in your .emacs after you install the fonts
Code:
;; BDF fonts for printing
(load-library "ps-bdf")

(setq ps-multibyte-buffer
      'bdf-font-except-latin)

(setq bdf-directory-list
      '(
        "/some/path/to/fonts"))
i think the fonts by default go somewhere like
/usr/share/fonts/emacs/bdf
or /usr/local/share
might not need to specify where they are if they are in default place
 
Old 02-23-2005, 05:08 AM   #3
kentri9
Member
 
Registered: Aug 2004
Distribution: Fedora Core 2
Posts: 39

Original Poster
Rep: Reputation: 15
how can I print out Danish characters without change language settings?

hi foo_bar_foo

Thank you for your detailed reply. I appreciate it.

After I had read your suggesion, I actually thought: 'Well... should this be that complicated?"'
Considering the small number hits by googling, no one seems to have this problem.

I came to think about something:

I have changed languegage from Japanese to Danish in:

System settings -> language


And I have changed from English to Danish in:

kcontrol -> regional & accessibility -> country/region & language

Then log in again... voila the printer now can print danish characters...

It seems that cupsd.conf is overridden by these settings...

How can I manage to print Danish characters without change language settings?
I have those language settings because I use English, Danish and Japanese equally and
this is the compromise I am most comfortable with. so I want to keep it...

Can any smart guys out there help me out?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Special characters problem MartinZ SUSE / openSUSE 5 07-12-2011 10:21 PM
Special Characters SimeonV SUSE / openSUSE 14 07-07-2006 02:29 PM
Suse 9.1 prof, special characters problem klodoma Linux - Newbie 1 09-25-2005 11:01 AM
grep problem in extracting special characters imppayel Programming 8 12-02-2004 08:28 AM
using special characters one_ro Mandriva 5 11-04-2004 09:52 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration