LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-19-2007, 07:27 PM   #1
tendonut
Member
 
Registered: Nov 2005
Location: Niagara Falls, NY
Distribution: SuSE 10.2, Fedora Core 7, Ubuntu 6.06
Posts: 49

Rep: Reputation: 15
Changing Directory Permission


I don't think I will ever get this shit to work on new linux installs.

I am setting up Samba again. I want to log in at the windows machine with a user who is part of the root group, but I am doing all the permission changing logged in as root. I am mounting my fat32 volume at /home/%USER%/WindowsShare. I tried running chmod on the directory before and after it was mounted, logged in as root. First, with the volume unmounted I would cd into the "USER" directory, then5 run "chmod 777 ./WindowsShare", then ls -l and it tells me that owner (root) has full read/write/execute permissions, but group and everyone just has read and execute. I then mount the volume and again, try changing permissions to 777 and again, comes up "rwxr-xr-x". I can't even change ownership of the directory to "%USER% which I think would solve the problem. Does anyone know what I am doing wrong? I want the directory to have full read/write/execute for everyone.

Last edited by tendonut; 08-19-2007 at 07:28 PM.
 
Old 08-19-2007, 08:57 PM   #2
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian + kde 4 / 5
Posts: 6,837

Rep: Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981
You can't use chmod on a FAT device, because that file system simply doesn't support *nix file permissions. The only thing you can do is simulate them during mounting. Take a look at the smb.conf 'create mask' and 'directory mask' options to set the permissions you want. There's also an 'inherit permissions' option that will give files the permissions of the parent directory. read man smb.conf(5) for more.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
changing permission Baghdad Linux - Newbie 3 01-20-2006 01:18 AM
Changing File Permission in a FTP directory to prevent deleting of files shawnbishop Linux - Software 3 01-10-2006 06:41 AM
Changing permission jaakkop Slackware 1 09-29-2004 01:08 PM
Changing permission. jaakkop Slackware 1 09-17-2004 02:41 PM
mount -- changing directory permission newbie_jubie Linux - Software 5 02-15-2002 02:06 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration