LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-19-2005, 08:22 AM   #1
maenho
Member
 
Registered: Nov 2003
Location: Belgium
Posts: 81

Rep: Reputation: 15
boot from software RAID 1


Hi,

I have 2 identical IDE disks which I'm trying to use as a RAID 1 system. On a third disk I compiled a custom 2.6.10 kernel supporting all necessary RAID stuff which runs perfectly (Slackware 10.0). I have 2 raid devices /dev/md0 and /dev/md1. Both come up perfectly at boot (autodetection).

I copied the entire / to /dev/md0 (using cp -xa / /newroot) and use LILO to write the MBR of both disks in the array. When I boot from the raid disks all goes well (raid is autodetected, kernel is loaded, ....) but booting hangs at:

warning: unable to open an initial console

What could be the problem here? I am using udev so maybe that has something to do with, I don't know.

can anybody help me?
 
Old 02-19-2005, 10:12 AM   #2
madluther
Member
 
Registered: Aug 2004
Distribution: LFS
Posts: 350

Rep: Reputation: 31
It sounds like /dev on your raid array is empty. Boot off your third disk, mount your raid array at /newroot and execute the following

Code:
mknod -m 600 /newroot/dev/console c 5 1
mknod -m 666 /newroot/dev/null c 1 3
This should create the minimum /dev entries needed at boot before udev runs.

HTH
Mad.

Last edited by madluther; 02-19-2005 at 11:05 AM.
 
Old 02-20-2005, 03:41 AM   #3
maenho
Member
 
Registered: Nov 2003
Location: Belgium
Posts: 81

Original Poster
Rep: Reputation: 15
indeed the /dev directory was empty. I just copied the /dev directory from the third disk and now all works.

thank you for your help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
About RHEL3 Software RAID 5 can't boot? (superblock) shen168 Red Hat 3 11-28-2005 06:46 PM
Software RAID 1 from Existing Boot Drive johnwyles Linux - General 1 08-05-2005 11:42 AM
Gentoo software raid boot problems MaDDeePee Linux From Scratch 1 08-28-2004 10:57 AM
Cannot boot from hdc with Software RAID 1 on RH 9.0 leo_tango Linux - General 3 12-19-2003 12:48 PM
boot + root on software raid 1 kris.kj.jacobs Linux - Software 2 06-03-2001 07:15 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration