LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-26-2006, 06:18 PM   #1
GTBlackwell
Member
 
Registered: Aug 2003
Location: MO, USA
Distribution: Mandrake 9.1/9.2(Laptop)
Posts: 117

Rep: Reputation: 15
avidemux ./configure behavior


when running ./configure for avidemux2 and with the libjs package installed, I get the following (nt complete, obviously):

...
checking pkg-config is at least version 0.9.0... yes
checking for FREETYPE... yes
checking /usr/local/ is full of divx... "yes"
checking win32 host... no
checking spidermonkey engine ... using : : as extra flags
checking jsapi.h usability... no
checking jsapi.h presence... no
checking for jsapi.h... no
configure: error: *** SPIDERMONKEY javascript engine not found !***
~>

At first I thought maybe I needed to enable a runlevel service, but there doesn't seem to be one related to javascript or 'spidermonkey'. Anyone have any advice?
 
Old 07-27-2006, 11:27 AM   #2
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,918

Rep: Reputation: 176Reputation: 176
Quote:
Originally Posted by GTBlackwell
when running ./configure for avidemux2 and with the libjs package installed, I get the following (nt complete, obviously):

...
checking pkg-config is at least version 0.9.0... yes
checking for FREETYPE... yes
checking /usr/local/ is full of divx... "yes"
checking win32 host... no
checking spidermonkey engine ... using : : as extra flags
checking jsapi.h usability... no
checking jsapi.h presence... no
checking for jsapi.h... no
configure: error: *** SPIDERMONKEY javascript engine not found !***
~>

At first I thought maybe I needed to enable a runlevel service, but there doesn't seem to be one related to javascript or 'spidermonkey'. Anyone have any advice?
If you were running Debian looks like you would need libmozjs-dev installed perhaps it is named similarly in your distro.

Code:
apt-cache search spidermonkey
libmozjs-dev - Development files for the Mozilla SpiderMonkey JavaScript library
libmozjs0d - The Mozilla SpiderMonkey JavaScript library
libmozjs0d-dbg - Development files for the Mozilla SpiderMonkey JavaScript library
libsmjs-dev - Migration package for the Mozilla SpiderMonkey JavaScript library
libsmjs1 - Migration package for the Mozilla SpiderMonkey JavaScript library
spidermonkey-bin - The SpiderMonkey Interpreter

apt-file search jsapi.h
libmozjs-dev: usr/include/mozjs/jsapi.h
mozilla-dev: usr/include/mozilla/js/jsapi.h
thunderbird-dev: usr/include/thunderbird/js/jsapi.h
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
trouble with avidemux and mplex GTBlackwell Linux - Software 1 12-29-2005 10:07 PM
trying to install avidemux onironaut Linux - Software 0 04-26-2005 01:32 PM
Help with Avidemux Garibaldi3489 Linux - Software 5 01-13-2005 08:34 PM
Avidemux-install recursive Fcm Linux - Software 1 08-28-2004 01:48 AM
Problem with avidemux. akihandyman Mandriva 0 06-28-2004 08:01 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration