LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-20-2005, 07:51 PM   #1
Blue1K
Member
 
Registered: Dec 2004
Location: Vancouver
Distribution: Suse 10.1, PCLinuxOS
Posts: 31

Rep: Reputation: 15
avidemux 2.0.36 from source install errors Help!


I can't seem to install avidemux. When I run configure I don't get any warning but after make I get this:

/usr/include/gtk-2.0/gdk/gdk.h:70: error: variable or field `gdk_add_option_entr
ies_libgtk_only' declared void
/usr/include/gtk-2.0/gdk/gdk.h:70: error: `GOptionGroup' was not declared in thi
s scope
/usr/include/gtk-2.0/gdk/gdk.h:70: error: `group' was not declared in this scope
In file included from /usr/include/gtk-2.0/gtk/gtkaccellabel.h:34,
from /usr/include/gtk-2.0/gtk/gtk.h:34,
from gui_filter.cpp:23:
/usr/include/gtk-2.0/gtk/gtklabel.h:133: error: `PangoEllipsizeMode' has not bee
n declared
/usr/include/gtk-2.0/gtk/gtklabel.h:133: error: ISO C++ forbids declaration of ` mode' with no type
/usr/include/gtk-2.0/gtk/gtklabel.h:134: error: `PangoEllipsizeMode' does not na me a type
In file included from /usr/include/gtk-2.0/gtk/gtk.h:114,
from gui_filter.cpp:23:
/usr/include/gtk-2.0/gtk/gtkmain.h:101: error: `GOptionEntry' has not been decla red
/usr/include/gtk-2.0/gtk/gtkmain.h:103: error: ISO C++ forbids declaration of `e ntries' with no type
/usr/include/gtk-2.0/gtk/gtkmain.h:105: error: expected constructor, destructor, or type conversion before '*' token
/usr/include/gtk-2.0/gtk/gtkmain.h:105: error: expected `,' or `;' before '*' to ken
make[3]: *** [gui_filter.o] Error 1
make[3]: Leaving directory `/home/inferno/Programs/avidemux-2.0.36/avidemux/ADM_ filter'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/inferno/Programs/avidemux-2.0.36/avidemux'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/inferno/Programs/avidemux-2.0.36'
make: *** [all] Error 2

Any help would be greatly appreciated as I use this program on a regular basis. The old version (2.0.34) sucks so I really need to get this running.

Thanks!
 
Old 02-26-2005, 12:22 AM   #2
Blue1K
Member
 
Registered: Dec 2004
Location: Vancouver
Distribution: Suse 10.1, PCLinuxOS
Posts: 31

Original Poster
Rep: Reputation: 15
I tried again with 2.038

I was using a test version of 2.0.34 but it is too unstable.
I followed the instructions from the avidemux site but I keep getting the error below.

What am I doing wrong and I can I do to get this version installed (there are no RPMS for it).
In the error message it says to check the autoconfig directions. I have no idea where this is. I could not find it in any of the install folders.

If you know to install this please help, I really need this program. Thanks!!!

[root@localhost avidemux-2.0.38rc1]# make -f Makefile.dist
This Makefile is only for the CVS repository
This will be deleted before making the distribution

*** auto-tools version check disabled **
*** Creating acinclude.m4
*** Creating list of subdirectories
*** Creating configure.in
*** Creating aclocal.m4
/usr/share/aclocal/g-wrap.m4:7: warning: underquoted definition of AC_GWRAP_CHEC K_GUILE
run info '(automake1.9)Extending aclocal'
or see http://sources.redhat.com/automake/a...ending-aclocal
/usr/share/aclocal/g-wrap.m4:23: warning: underquoted definition of AM_PATH_GWRA P
aclocal:configure.in:82: warning: macro `AM_GNU_GETTEXT' not found in library
*** Creating configure
configure.in:82: error: possibly undefined macro: AM_GNU_GETTEXT
If this token and others are legitimate, please use m4_pattern_allow.
See the Autoconf documentation.
make[1]: *** [cvs] Error 1
make: *** [all] Error 2
[root@localhost avidemux-2.0.38rc1]#
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
trying to install avidemux onironaut Linux - Software 0 04-26-2005 02:32 PM
install kernel source errors axemanW Fedora 2 03-12-2005 10:46 AM
Help with Avidemux Garibaldi3489 Linux - Software 5 01-13-2005 09:34 PM
mysql-4.1.6-gamma after source install on fedora2 - errors hq4ever Linux - Software 5 10-22-2004 05:26 PM
Avidemux-install recursive Fcm Linux - Software 1 08-28-2004 02:48 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration