LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-28-2008, 11:13 AM   #1
mgervacio
LQ Newbie
 
Registered: Jul 2008
Location: New Jersey
Distribution: Fedora Core 8
Posts: 8

Rep: Reputation: 0
After doing a full install of FC9, I am unable to boot up in run level 5


After doing a full install of FC9, I am unable to boot up with xwindows started. I get a flashing cursor but no video or I get a small red square in the lower right panel. If I edit grub to boot in runlevel 3 then startx, this seems to work fine. But if I edit initab and change the runlevel to 5, then I get the same problem booting up the box with X started. I did yum update but still got the same problem. I previously had FC8 on the box. I tried to install FC8 again to see if my box had a problem but X started upon boot-up with no problems. I tried burning the iso file to a different disk, downloading another iso from a different mirror, installing using a CD with the live install -- but I still got the same problem and could not boot up from run level 5. I know other people are having a similar problem with X since they have invidia card. I do not have an invidia card. I have intel. I am experiencing this on 2 boxes I need to upgrade. Does anyone have any clues on what is happening?
 
Old 07-29-2008, 09:24 PM   #2
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Australia
Distribution: Devuan
Posts: 5,476

Rep: Reputation: Disabled
since no-one has replied and you know others have the same issue...continue to watch those posts.

In the meantime....I think you are right to suspect video card setup...I assume you know Fedora dropped the core so its F9.

Pls you post your /etc/X11/xorg.conf or xf86free.conf if it uses that old style.

Pls name your onboard or video card.

We may be able to search for bugs at Fedora once we know your chipset.

2) Leaping ahead....lets try to just get a vesa vga graphics boot up?

assuming you have grub when you boot....do you see a "safe mode" menu?
if so what happens when you boot it?

3) if you have no such option when grub starts press E for edit and navigate to the kernel line

add single to end of line

press escape and b to boot

this boots you to the root login prompt no Xserver environment
login as root
now I do not use your distro but issue the next command to find a manual command to configure xorg
Code:
find / -name xorg*

....should output a number of lines including the current /etc/X11 file

if none next try command
find / -name xf86*
whatever you see what you are looking for is something like

xorg (or xf86free) . config ( . cfg or .cf)

and run that command please to configure a new config file
then run startx

if it works with root powers edit the /etc/inittab....making sure that 5 or whatever is the correct number for mult-user X boot...as some distros may use a number other than 5

also the syntax has to have the full colon which can be deleted by us humans
eg
id:5:initdefault:

Last edited by aus9; 07-29-2008 at 09:25 PM.
 
Old 07-30-2008, 11:18 AM   #3
mgervacio
LQ Newbie
 
Registered: Jul 2008
Location: New Jersey
Distribution: Fedora Core 8
Posts: 8

Original Poster
Rep: Reputation: 0
aus9,
Thanks for your response! I am hoping I am not the only one to have this problem since its happening very consistently on 2 new boxes that I have. The graphics card is Intel 82G33/G31 Express Integrated Graphics controller. I will paste my xorg.conf at the bottom.

I got it to bootup using vesa but the resolution was too low. I can get it to use the intel card if I start on runlevel 3 and only then startx. I make this change persistent by editing the kernel line in grub.conf to have 3 4 5 at the end of the line. When I reboot, it successfully boots up in runlevel 5 using the intel driver. But, the problem is, once I log-out, I am back to my original problem and have to restart the box again to get back to a working run level 5.

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"

# keyboard added by rhpxl
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "intel"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection
 
Old 07-30-2008, 07:39 PM   #4
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Australia
Distribution: Devuan
Posts: 5,476

Rep: Reputation: Disabled
I am unable to proceed as I forgot to ask who is the actual maker of chipset?

you can search here with luck
http://hardware4linux.info/type/5/

Last edited by aus9; 07-30-2008 at 07:44 PM.
 
Old 07-31-2008, 11:20 AM   #5
mgervacio
LQ Newbie
 
Registered: Jul 2008
Location: New Jersey
Distribution: Fedora Core 8
Posts: 8

Original Poster
Rep: Reputation: 0
aus9,
Thanks for the links! My chipset is 'G33'


(II) Module vgahw: vendor="X.Org Foundation"
compiled for 1.4.99.905, module version = 0.1.0
ABI class: X.Org Video Driver, version 4.1
(**) intel(0): Depth 24, (--) framebuffer bpp 32
(==) intel(0): RGB weight 888
(==) intel(0): Default visual is TrueColor
(II) intel(0): Integrated Graphics Chipset: Intel(R) G33
(--) intel(0): Chipset: "G33"
 
Old 07-31-2008, 07:51 PM   #6
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Australia
Distribution: Devuan
Posts: 5,476

Rep: Reputation: Disabled
yes we knew that .....who is the maker?

its a company name....you should have received a ms driver cd marked company as per link list its a name like
gigabyte
asus

since you indicate its integrated meaning onboard.....who is the maker of the motherboard pls

Last edited by aus9; 07-31-2008 at 07:53 PM.
 
Old 07-31-2008, 08:25 PM   #7
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 132Reputation: 132
Maybe (re)install gdm or, if already installed, restart it (/etc/init.d/gdm restart).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
set your default run level so you will boot to a default run level - vga console Adam555 Linux - Newbie 1 01-21-2008 05:55 PM
SUSE unable show graphics mode run level and screen resolution is not supporting vineethshyam SUSE / openSUSE 2 09-24-2006 11:04 PM
emacs in run level 3 then switch to X (level 7) then back to level 3 dsoliver Slackware 3 09-01-2006 04:31 AM
how to boot at run level 3 from the get-go cp0ff Mandriva 2 06-28-2006 06:43 PM
Unable to boot up in run level 5 casacruz Linux - General 5 01-10-2002 02:48 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration