LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 11-06-2006, 12:55 PM   #1
Storm16
LQ Newbie
 
Registered: Feb 2004
Location: Virginia
Distribution: Debian x86/SPARC
Posts: 29

Rep: Reputation: 15
Zimbra server and perl problem


I've installed Zimbra (zcs-4.0.3) on a Debian unstable box.

The box specs are as follows:

Penguin Relion 120 w/dual PIII/933 CPUs
2GB RAM
Dual 36GB SCSI hard drives, RAID 1

No mail is being delivered, everything is being deferred. The logs show errors similar to:

Code:
Nov  6 13:34:57 merrimac amavis[16336]: (16336-04) ESMTP::10024 /opt/zimbra/amavisd/tmp/amavis-20061106T133457-16336: <nessus-bounces@list.nessus.org> -> <storm@mydomain.com> SIZE=3986 Received: from merrimac.mydomain.com ([127.0.0.1]) by localhost (merrimac.mydomain.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP for <storm@mydomain.com>; Mon,  6 Nov 2006 13:34:57 -0500 (EST) Nov  6 13:34:57 merrimac amavis[16336]: (16336-04) Checking: stWep5MJHoCX [207.172.156.132] <nessus-bounces@list.nessus.org> -> <storm@mydomain.com>
Nov  6 13:34:57 merrimac amavis[16336]: (16336-04) (!!) TROUBLE in check_mail: parts_decode_ext FAILED: Error reading from file(1) utility: Bad file descriptor at (eval 51) line 151, <GEN38> line 1.
Nov  6 13:34:57 merrimac amavis[16336]: (16336-04) (!) PRESERVING EVIDENCE in /opt/zimbra/amavisd/tmp/amavis-20061106T133457-16336
Nov  6 13:34:57 merrimac postfix/smtp[18577]: 6BBB64FB63: to=<storm@mydomain.com>, relay=127.0.0.1[127.0.0.1], delay=0, status=deferred (host 127.0.0.1[127.0.0.1] said: 451 4.5.0 Error in processing, id=16336-04, parts_decode_ext FAILED: Error reading from file(1) utility: Bad file descriptor at (eval 51) line 151, <GEN38> line 1. (in reply to end of DATA command))
I have asked on the Zimbra forums, but gotten no answers, so I am hoping someone here can help. My own research shows that it appears to be amavisd. One post stated that the older versions of amavisd (2.3.3) did not play nicely with Net::Server > 0.91. Zimbra 4.0.3 ships with amavisd 2.4.1, but I downgraded to Net::Server to 0.87 from Debian/stable, to no avail. file is in the path (/usr/bin), and I have made sure both the Server.pm in /usr/share/perl5/Net and /opt/zimbra/zimbramon/lib/Net were 0.87, but still I get these errors and no mail sent or delivered. Has anyone found anything else which might cause these errors?

Thanks,
--Storm
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
PERL: cgi script copy problem from server to another <db> Programming 2 04-16-2006 09:14 PM
Anyone using Zimbra on FC4? lucktsm Fedora 1 02-23-2006 10:35 PM
zimbra configuration sailu_mvn Linux - Software 0 12-23-2005 01:52 AM
Zimbra Collaboration Email server thorn168 Linux - Software 0 11-29-2005 05:58 PM
Problem with perl module for w3c validator to work on my local Apache+PHP+perl instal tbamt Linux - Software 0 12-16-2004 05:37 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 08:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration