LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 12-05-2016, 11:49 AM   #46
c0wb0y
Member
 
Registered: Jan 2012
Location: Inside the oven
Distribution: Windows
Posts: 417

Rep: Reputation: 74

There's your problem, your $HOME is incorrectly set.
 
Old 12-05-2016, 03:02 PM   #47
nibraz
Member
 
Registered: Oct 2008
Posts: 219

Original Poster
Rep: Reputation: 18
Quote:
Originally Posted by c0wb0y View Post
There's your problem, your $HOME is incorrectly set.
Ah.. how can I make this right? thanks for pointing it out c0wb0y
 
Old 12-05-2016, 03:05 PM   #48
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 4,237

Rep: Reputation: 1655Reputation: 1655Reputation: 1655Reputation: 1655Reputation: 1655Reputation: 1655Reputation: 1655Reputation: 1655Reputation: 1655Reputation: 1655Reputation: 1655
Centos/Rhel land would be:
Code:
usermod -d /home/user user
 
Old 12-06-2016, 12:12 PM   #49
wpeckham
Senior Member
 
Registered: Apr 2010
Location: Continental USA
Distribution: Debian, Ubuntu, Fedora, RedHat, DSL, Puppy, CentOS, Knoppix, Mint-DE, Sparky, Vsido, tinycore, Q4OS
Posts: 3,421

Rep: Reputation: 1485Reputation: 1485Reputation: 1485Reputation: 1485Reputation: 1485Reputation: 1485Reputation: 1485Reputation: 1485Reputation: 1485Reputation: 1485
Quote:
Originally Posted by c0wb0y View Post
Y
Just a guess, your ssh user's $HOME is probably /c/Users... Can you post this:

Code:
echo $HOME
grep <ssh-user> /etc/passwd
That was a good call. Until you suggested I had not considered that the creation of 'user' might have been messed up and the passwd record and file system in disagreement.
 
Old 12-06-2016, 01:54 PM   #50
c0wb0y
Member
 
Registered: Jan 2012
Location: Inside the oven
Distribution: Windows
Posts: 417

Rep: Reputation: 74
Based on his log file, the location of his identity file seems strange which is mostly likely related to his $HOME not properly set.

If nibraz can marked this [SOLVED], that would be great so we don't have to redo the process.
 
Old 12-07-2016, 08:55 AM   #51
nibraz
Member
 
Registered: Oct 2008
Posts: 219

Original Poster
Rep: Reputation: 18
Hi Guys

I will test this from my home laptop when I get home.

I have set the directory to /user/home and when I do echo $HOME its now showing /user/home/

Will test this when i go home, redo the pub key authenication and recreate the authorized key file.

Thanks
 
Old 03-08-2018, 06:23 AM   #52
Benedegu
LQ Newbie
 
Registered: Mar 2018
Posts: 2

Rep: Reputation: Disabled
private key without password

Hi!

I have a problem with a private key.

The private key has not password, but when I would like use this key with scp command, I get a prompt password, why? How can I solve this problem?

Code:
scp -i /path/private_key_file -P portnumber user@remote_server:/path/remote/file /path/local/folder/
Enter passphrase for key /path/private_key_file'':
user@remote_server's password:
I use this private key with WinSCP software In Windows. There is working!
Why is not working in Linux?
 
Old 03-08-2018, 06:58 AM   #53
sundialsvcs
LQ Guru
 
Registered: Feb 2004
Location: SE Tennessee, USA
Distribution: Gentoo, LFS
Posts: 9,078
Blog Entries: 4

Rep: Reputation: 3181Reputation: 3181Reputation: 3181Reputation: 3181Reputation: 3181Reputation: 3181Reputation: 3181Reputation: 3181Reputation: 3181Reputation: 3181Reputation: 3181
Ordinarily, SSH certificates are not encrypted with a passphrase, but if they are you'll have to enter it.

SSH uses a client-side "password agent" daemon, but as far as I know it won't supply a passphrase for you. (That would be defeating the purpose of passphrases, I think.)

Also – when you are using certificates, you probably should remove the "fall back to asking for a password" option that you see being done here. If you're using certificates for authentication and don't possess a valid certificate, IMHO you should be denied access altogether (to that place).

Just to be clear: a passphrase is an encryption key that is applied to the contents of the certificate, rendering it useless to someone who just stole your laptop. It is used only on the client side.

Last edited by sundialsvcs; 03-08-2018 at 07:01 AM.
 
Old 03-08-2018, 08:03 AM   #54
Benedegu
LQ Newbie
 
Registered: Mar 2018
Posts: 2

Rep: Reputation: Disabled
I resolved my problem.

It was very stupid thing. I generateed the key file with puttygen, it is not openssh, so I had to convert to openssh format. Now its working. Sorry!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] ssh authenication failure screwzm Linux - Networking 5 11-15-2012 08:06 AM
SSH: Permission denied (publickey). clapclash Linux - Networking 6 10-19-2012 06:49 AM
Trying to think of a way to ssh without interactivity and not using the publickey... trist007 Linux - Newbie 3 07-30-2010 08:26 AM
ssh publickey authentication spx2 Linux - Security 11 01-11-2008 05:27 AM
Trouble configuring SSH publickey pioniere Linux - Security 4 02-25-2005 02:20 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 12:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration