LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 06-13-2009, 04:54 AM   #1
Ammad
Member
 
Registered: Apr 2004
Distribution: redhat 9.0, fc4, redhat as 4
Posts: 522

Rep: Reputation: 31
Postfix mail delivery failure


HI,

i am using postfix, when i try to send email to other domain, my emails are rejected from remote domain. in /var/log/maillog

Code:
host xxxxxxxxxxxx.com[xxx.xx.xx.xx] said: 503
    This mail server requires authentication when attempting to send to a
    non-local e-mail address. Please check your mail client settings or contact
    your administrator to verify that the domain or address is defined for this
    server. (in reply to RCPT TO command)
 
Old 06-13-2009, 05:00 AM   #2
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Can you post "postconf -n"?
 
Old 06-13-2009, 05:17 AM   #3
Ammad
Member
 
Registered: Apr 2004
Distribution: redhat 9.0, fc4, redhat as 4
Posts: 522

Original Poster
Rep: Reputation: 31
Code:
alias_maps = hash:/etc/aliases
always_bcc = archives@mydomain.com
bounce_size_limit = 500000
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
debug_peer_level = 2
disable_dns_lookups = yes
html_directory = no
inet_interfaces = all
local_recipient_maps = unix:passwd.byname $alias_maps
mail_owner = postfix
mail_spool_directory = /var/spool/mail
mailbox_command = /usr/bin/procmail
mailbox_size_limit = 5120000000
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain
mydomain = mydomain.com
mynetworks_style = subnet
myorigin = $mydomain
newaliases_path = /usr/bin/newaliases.postfix
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
sample_directory = /usr/share/doc/postfix-2.3.3/samples
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
smtp_generic_maps = hash:/etc/postfix/generic
smtp_tls_loglevel = 1
transport_maps = hash:/etc/postfix/transport
unknown_local_recipient_reject_code = 550
 
Old 06-13-2009, 05:33 AM   #4
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
That wasn't as helpful as I'd hoped.

Do you have permit_mynetworks in your smtpd_recipient_restrictions settings? IF not, you will need to add it.

It may be worth you showing us what you smtpd_recipient_restrictions are.
 
Old 06-13-2009, 08:13 AM   #5
Ammad
Member
 
Registered: Apr 2004
Distribution: redhat 9.0, fc4, redhat as 4
Posts: 522

Original Poster
Rep: Reputation: 31
This is not set in default and so i didn't, i want to highlight another point, when i was using smtp.gmail.com as smarthost, i wasn't getting this error, since there is porblem in smtp.gmail.com, google removes the sender email to authenticated user, which is causing to reciver to unable view orignal sender, so i removed "smart host (relay)" configuration.

let me check smtpd_recipient_restrictions this, i will update you on this


thanks
 
Old 06-13-2009, 08:48 AM   #6
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,824

Rep: Reputation: 613Reputation: 613Reputation: 613Reputation: 613Reputation: 613Reputation: 613
Is host xxxxxxxxxxxx.com[xxx.xx.xx.xx] your server?
 
Old 06-14-2009, 06:42 AM   #7
Ammad
Member
 
Registered: Apr 2004
Distribution: redhat 9.0, fc4, redhat as 4
Posts: 522

Original Poster
Rep: Reputation: 31
yes, ..

is this can be problem of dynamic ip pool ( i am using dynamic ip pool on DSL modem). if yes then how remote smtp checks this, either i am using dnynamic or static IP pool.

thanks
 
Old 06-14-2009, 06:50 AM   #8
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Yo ustill haven't shown you recipient restrictions
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help With Postfix Delivery Failure carlosinfl Linux - Server 2 09-05-2008 05:36 PM
Strange Postfix Delivery Failure carlosinfl Linux - Server 1 04-16-2008 11:57 AM
Mail delivery tracking - PostFix shritesh Linux - Software 3 09-01-2006 03:25 AM
postfix mail delivery berrance Linux - Networking 4 02-28-2005 07:46 AM
Postfix mail delivery issue kokke Linux - Software 6 05-13-2003 06:50 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 07:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration