LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 02-26-2010, 10:50 AM   #1
sanjay2004
Member
 
Registered: Dec 2004
Location: BIJAPUR
Posts: 86

Rep: Reputation: 15
how to configure ssh (xinetd) service


hai,

recently i installed redhat linux4.4
i.e in text mode only,

now i want to access my linux remotely using putty,

what r the settings require at server,

telnet not installed.
 
Old 02-26-2010, 11:17 AM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 20,818

Rep: Reputation: 5151Reputation: 5151Reputation: 5151Reputation: 5151Reputation: 5151Reputation: 5151Reputation: 5151Reputation: 5151Reputation: 5151Reputation: 5151Reputation: 5151
Quote:
Originally Posted by sanjay2004 View Post
hai,

recently i installed redhat linux4.4
i.e in text mode only,

now i want to access my linux remotely using putty,

what r the settings require at server,

telnet not installed.
Spell out your words, and write clearly please.

Do you mean RedHat ENTERPRISE 4, or RedHat 4? One is fairly new, the other isn't. And you should just have to make sure the SSH daemon is started. Type in "/etc/init.d/sshd status". If it's not running, type in "/etc/init.d/sshd start".

If you want to enable/disable options, modify what's there, read the man page on sshd_config, or look on Google for any of the MANY how-tos.
 
Old 02-27-2010, 07:23 AM   #3
sanjay2004
Member
 
Registered: Dec 2004
Location: BIJAPUR
Posts: 86

Original Poster
Rep: Reputation: 15
ok,

the service is started but, I can't able to access the server..
 
Old 02-27-2010, 07:26 AM   #4
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,528

Rep: Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899Reputation: 899
Do you have a firewall?
is port 22 forwarded to the server on the router?
try to connect from the server
Code:
ssh 127.0.0.1
 
Old 02-27-2010, 04:14 PM   #5
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 20,818

Rep: Reputation: 5151Reputation: 5151Reputation: 5151Reputation: 5151Reputation: 5151Reputation: 5151Reputation: 5151Reputation: 5151Reputation: 5151Reputation: 5151Reputation: 5151
Quote:
Originally Posted by sanjay2004 View Post
ok,

the service is started but, I can't able to access the server..
You "can't able to access"?? In what way? What error(s) do you get? What user are you trying to log in as?

As repo said...check your firewall, and check to make sure you can access it via the localhost address. Chances are, you'll have to allow SSH through your firewall, if you have one enabled.
 
Old 03-01-2010, 01:23 AM   #6
sanjay2004
Member
 
Registered: Dec 2004
Location: BIJAPUR
Posts: 86

Original Poster
Rep: Reputation: 15
How to configure network TCP/ip?

each time when I restart there is no ip,

pl tell me how to configure ip add,

Conditions:
(using RHL9,using in texd mode only, installed minum rpm, suspect with my cd not reading properly, need to install one by one rpm what I required )
 
Old 03-01-2010, 01:28 AM   #7
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.10, Centos 7.5
Posts: 17,569

Rep: Reputation: 2426Reputation: 2426Reputation: 2426Reputation: 2426Reputation: 2426Reputation: 2426Reputation: 2426Reputation: 2426Reputation: 2426Reputation: 2426Reputation: 2426
You're posts disagree on which distro you've got; your first seems to be RHEL 4.4 ( a bit old but still current) but your last says RHL 9 which has been obsolete/unsupported and not patched for many years.
If you've got the latter, replace with something current eg RHEL 5.4 or the free Centos version.
See
http://en.wikipedia.org/wiki/RHL
http://en.wikipedia.org/wiki/Red_Hat_Enterprise_Linux
http://en.wikipedia.org/wiki/CentOS

Last edited by chrism01; 03-01-2010 at 10:07 PM.
 
Old 03-01-2010, 03:37 AM   #8
sanjay2004
Member
 
Registered: Dec 2004
Location: BIJAPUR
Posts: 86

Original Poster
Rep: Reputation: 15
Lightbulb

Thanks lot,

That really I required to change,

right now I have RHL9 only, shortly I will make arrange for Fedura core

Thanks for immediate respond
 
Old 03-01-2010, 10:50 AM   #9
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 20,818

Rep: Reputation: 5151Reputation: 5151Reputation: 5151Reputation: 5151Reputation: 5151Reputation: 5151Reputation: 5151Reputation: 5151Reputation: 5151Reputation: 5151Reputation: 5151
Quote:
Originally Posted by sanjay2004 View Post
Thanks lot,

That really I required to change,

right now I have RHL9 only, shortly I will make arrange for Fedura core

Thanks for immediate respond
Again, SPELL OUT YOUR WORDS AND WRITE CLEARLY. It's "Fedora core", and "please".

If you're not getting an IP address on reboot, how about telling us how the system is set up? Are you using DHCP? Cable plugged in when you boot? Getting any errors?? If you tried to Google this, you'd have found:

http://www.redhat.com/docs/manuals/l...nterfaces.html

from RedHat, telling you what to edit, and how.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xinetd: unrecognized service ??? Why?? stewchcken Linux - Networking 8 07-14-2005 09:23 AM
Help:xinetd controlled service? sti2envy Linux - Networking 1 10-19-2004 10:16 AM
xinetd uses service --> slackware uses ??? kntgtaid Slackware 1 06-06-2004 03:10 PM
Adding new xinetd service Aldric Linux - Networking 1 06-03-2004 12:40 PM
xinetd service not starting porous Linux - Networking 4 10-14-2003 07:50 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 03:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration