LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 02-19-2010, 04:19 AM   #16
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,238

Rep: Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685

Quote:
Only solution given was to configure SMTP authentication which I already have done. I have configured my zimbra to use SMTP authentication while sending emails from go daddy server using my account.
Can you send email from a mail client using godaddy as outgoing mail server and your credentials?
Also what gives:
Code:
dig mx yourdomain.com
 
Old 02-19-2010, 04:20 AM   #17
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Original Poster
Rep: Reputation: Disabled
Bathory,

In this error

Code:
host smtpout.where.secureserver.net[72.167.82.80] said: 553 Sorry, that domain
    isn't in my list of allowed rcpthosts. (in reply to RCPT TO command)
What does that domain refers to? Is the receiver? Like gmail or yahoo I am trying to send to?
 
Old 02-19-2010, 04:23 AM   #18
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Original Poster
Rep: Reputation: Disabled
Yes I can. I am using thunderbird as my email client and no just me but all our organizational employees use Outlook Office.

And this is the outcome of the dig command.

Code:
dig mx inspirebridge.com

; <<>> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5_4.2 <<>> mx inspirebridge.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 24360
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;inspirebridge.com.		IN	MX

;; ANSWER SECTION:
inspirebridge.com.	3600	IN	MX	0 smtp.secureserver.net.
inspirebridge.com.	3600	IN	MX	10 mailstore1.secureserver.net.

;; Query time: 540 msec
;; SERVER: 192.168.2.2#53(192.168.2.2)
;; WHEN: Fri Feb 19 15:39:48 2010
 
Old 02-19-2010, 04:24 AM   #19
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Original Poster
Rep: Reputation: Disabled
Hey just a minute. Is it because that my internal domain name is different from the Live domain that has been hosted by go daddy?
 
Old 02-19-2010, 04:34 AM   #20
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,238

Rep: Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685
Quote:
What does that domain refers to? Is the receiver? Like gmail or yahoo I am trying to send to?
Exactly

Quote:
Hey just a minute. Is it because that my internal domain name is different from the Live domain that has been hosted by go daddy?
AFAIK to authenticate you need to use a username like: user@domain.com and a password and I guess the domain.com should be the same as the one registered with godaddy.
 
Old 02-19-2010, 05:38 AM   #21
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Original Poster
Rep: Reputation: Disabled
As you said to authenticate, I am using a username that is available and on a domain registered with go daddy.
My domain registered is inspirebridge.com. And the user name I am using for SMTP authentication say user@inspirebridge.com is actually there and is already in use on one of our systems.
But the internal domain is say inspirebridge.com.local. Can this be done?
I will use user and password registered with go daddy to authenticate their SMTP server.
 
Old 02-19-2010, 06:01 AM   #22
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,238

Rep: Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685
I think you should re-read the "Enabling SMTP authentication" in the 1st link I gave you and especially the part:
Quote:
Configure postfix to use the outgoing servername rather than the canonical server name:

postconf -e smtp_cname_overrides_servername=no

smtp_cname_overrides_servername=no is used because many smtp servers forward the connection different server than the one set in the smtp_sasl_password_maps file.

Example of the problem :

/opt/zimbra/conf/relay_password :

smtp.gmail.com username@gmail.comassword

but postfix connects to gmail-smtp.l.google.com

Postfix will not send the authentication info contained in smtp_sasl_password_maps file because it as no entry for the server gmail-smtp.l.google.com but has one for smtp.gmail.com
 
Old 02-19-2010, 07:26 AM   #23
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Original Poster
Rep: Reputation: Disabled
I think I advanced a bit but there is this problem now

Quote:
Host refused to talk to me. Your access to this mail system has been rejected due to the sending MTA's poor reputation. If you believe this is in error, please contact the intended recipient via alternate means.
 
Old 02-19-2010, 07:38 AM   #24
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,238

Rep: Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685
Who is giving this response? godaddy or the final destination smtp server?
 
Old 02-19-2010, 07:58 AM   #25
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Original Poster
Rep: Reputation: Disabled
Edit:
Here is the message that I can see in zimbra message queue. it is not the final destination smtp server but the go daddy server it seems

Quote:
host smtp.where.secureserver.net refused to talk to me: 554-p3pismtp01-003.prod.phx3.secureserver.net 554 your access to this mail system has been rejected due to the sending mts's poor reputation. If you believe this failure is in error, please contact the intended recipient via alternate means.

Last edited by linuxlover.chaitanya; 02-19-2010 at 08:10 AM. Reason: changes in the message.
 
Old 02-19-2010, 08:35 AM   #26
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,238

Rep: Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685Reputation: 1685
It is not your end, but what is says is that your smtp server was refused due to poor reputation (meaning spam suspect).
Is p3pismtp01-003.prod.phx3.secureserver.net also a godaddy server? I guess you should contact them.
 
Old 02-19-2010, 11:35 PM   #27
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Original Poster
Rep: Reputation: Disabled
I guess yes. That is also a go daddy server. I thought it could be that my internal server was blacklisted but the internal server is not online. Let me check out with go daddy guys what they have to say about this.
 
Old 02-20-2010, 12:43 AM   #28
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Original Poster
Rep: Reputation: Disabled
Thanks bathory for keeping up with me. I have finally been able to send the mails using the external go daddy server and my domain user registered with go daddy from internal zimbra server.
There are some changes that I tried though from my side. One is that I did not use the cname and instead used smtpout.secureserver.net itself rather than the canonical name smtpout.where.secureserver.net. And go daddy uses port 80 for relaying.
In addition, while I do not configure tls or ssl authentication in mail clients (thunderbird or outlook), I had to do that here.

I would mark this thread solved once the changes are persistent.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't send mails from Linux Server to Windows200 Server...plz help me out..... Vicksss Linux - Server 1 07-29-2009 03:42 AM
Switching to google mail want internal server to send now points to external Eileen1 Linux - Newbie 1 03-25-2009 11:07 PM
To restrict a user to send mails only to 3 e-mails IDs using postfix mail server sharath41 Linux - Newbie 2 07-21-2008 07:38 PM
using external mail server with internal web server blckspder Linux - Server 1 01-07-2008 08:31 PM
mail server: just send mails out, but not receive hamish Linux - Software 4 02-27-2005 11:06 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 12:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration