LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 08-07-2011, 05:34 AM   #16
enzym
LQ Newbie
 
Registered: Jul 2011
Posts: 19

Original Poster
Rep: Reputation: Disabled

Seems like googles opendns responded a bit differently from the isp DNS servers..

Should I try to use only googles servers?

Would it help to remove forwarders? Are they necessary?
 
Old 08-07-2011, 07:39 AM   #17
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,790

Rep: Reputation: 650Reputation: 650Reputation: 650Reputation: 650Reputation: 650Reputation: 650
Forwarders aren't necessary but they're preferred, give it a go without and if it works leave it that way.
 
Old 08-13-2011, 04:19 PM   #18
enzym
LQ Newbie
 
Registered: Jul 2011
Posts: 19

Original Poster
Rep: Reputation: Disabled
I removed my forwarders, and reset the config file, and now it has worked for several days without restaring the named service. =) Happy camper!
 
Old 07-09-2013, 03:23 AM   #19
hassan12399
LQ Newbie
 
Registered: Jul 2013
Posts: 1

Rep: Reputation: Disabled
I was getting the same error while trying configuring forwarding-only DNS server on CentOS 6.3 on my virtual machine. I solved it by changing these lines

dnssec-enable yes;
dnssec-validation yes;

to

dnssec-enable no;
dnssec-validation no;

in named.conf
 
Old 07-11-2013, 01:36 AM   #20
thwarted
LQ Newbie
 
Registered: Jul 2013
Posts: 2

Rep: Reputation: Disabled
Check that the time on your system is accurate. Time being off can influence if crypto-related things, like DNSSEC, work or not.

In my case, my DNS server is virtualized and was turned off for about 6 hours. When it came back up, the time was off, and ntp couldn't work because it could resolve ntp.org to sync the time against because DNS wasn't working. Nice chicken-and-egg problem. I manually set the time to be accurate, and named started validating responses and things started working.

This page is the one that lead me to checking the system time: http://spectlog.com/content/BIND_nam....com/A/IN'
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Bind.DNS Help needed on Split DNS server manya Linux - Server 3 10-28-2010 09:39 AM
Slave DNS server hangs during restart (Bind) marinko Linux - Networking 0 03-19-2009 07:54 PM
How to get Windows Clients to be served DNS from a Linux BIND-DNS Server texmansru47 Linux - Networking 12 07-10-2008 08:06 PM
Bind takes long time to replicate A record change to secondary DNS server tech_contact Linux - Networking 3 10-23-2007 08:14 AM
Samba server ok at boot, later fails to bind to IP. smbd restart doesn't help. tisource Linux - Networking 1 04-09-2005 09:16 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 10:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration