Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Security
User Name
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.


  Search this Thread
Old 05-18-2005, 10:04 AM   #1
Registered: Oct 2004
Posts: 52

Rep: Reputation: 15
Trying to copy a user folder from ntfs hd that is locked.

Here is the situation:

I have a laptop hard drive here which has HPFS/NTFS fs.
Also have the hard drive that i'd like to copy the files/folders from the laptop hard drive over to which is vfat filesystem.

Now i've never come across this problem before but in my gui when i'm looking at the ntfs laptop drive which was mounted obviously ro in the fstab the user folder that I need to copy shows up as a file with a lock on it. When I try to click it I get this message:
You do not have enough permissions to read file:/mnt/hdc1/Documents and Settings/The File

Alright, this is a windows xp hard drive where i'm trying to get to the my documents folder of the user The File. But the permissions are obviously locked up.

How would I go about getting this over to my vfat drive and clearing the permissions so I can then view it as a directory? Or, what do you think is the correct way to get this to work for me?

I've tried
Setting up the captive-ntfs and mounting like so:
mount -t captive-ntfs /dev/hdc1 /mnt/hdc1 -o rw,users,uid=000
And the output of this action was receiving this error: ls: .:Stale NFS file handle

So we see there is also a problem with mounting it as captive-ntfs.

Is there something I should do with dd?

Your help is greatly appreciated. Thank You
Old 05-18-2005, 02:28 PM   #2
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,696

Rep: Reputation: 232Reputation: 232Reputation: 232
Re: Trying to copy a user folder from ntfs hd that is locked.

Originally posted by bluedevlx

mount -t captive-ntfs /dev/hdc1 /mnt/hdc1 -o rw,users,uid=000
Try something different:
mount -t captive-ntfs /dev/hdc1 /mnt/hdc1 -o rw,users,umask=0
You probably have the default setting for mounted filesystem configured in such a way that only owner (root) can access (both read and write) the device. Umask parameter changes the default and should allow other users to read the disk.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
unlock a locked folder in Suse 10.0 dcg757s Linux - Newbie 6 11-11-2005 04:54 PM
locked folder garyozzy Fedora 4 08-01-2005 07:40 AM
Auto Change Date on copy to user folder mariusak Linux - General 4 05-28-2005 06:42 PM
Locked NTFS Mount Pleiades Fedora 9 05-09-2004 05:33 AM
NTFS Drive Locked sillouette Linux - General 1 04-03-2004 04:47 AM > Forums > Linux Forums > Linux - Security

All times are GMT -5. The time now is 06:26 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration