Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 09-11-2007, 03:00 PM   #1
Registered: Jul 2007
Location: Penang , Malaysia.
Distribution: red hat linux
Posts: 133

Rep: Reputation: 15
Smile write permision on mount drive samba server

1. i am using RHLE AS3, i share a folder "abc" /abc as samba share folder,than i change this folder permision to 777, ok my Windows xp system can READ&WRITE this folder.
NOW I ADD 1PCS HARDDISK so i use command mount: # mount -v /dev/hdc1 /mnt/hdc1 . i success mount this 2nd harddisk partion on /mnt/hdc1, Now i want to set this folder as also same like folder "abc" can READ&WRITE on my windows XP. Now i can READ only this folder /mnt/hdc1 from my Windows xp, but cannot WRITE. PROBLEM I CANNOT CHANGE THIS FOLDER(/mnt/hdc1) PERMISION TO 777, so i cannot write to this folder(/mnt/hdc1) WHY CANNOT CHANGE THHIS FOLDER(/mnt/hdc1) PERMITION TO 777??? How to make it can READ&WRITE on this MOUNT partion /mnt/hdc1 on Windows xp by SAMBA server.


Last edited by hocheetiong; 09-11-2007 at 03:04 PM. Reason: forgot to said this partition files system: this /mnt/hdc1 partition file system is FAT32.
Old 09-11-2007, 04:46 PM   #2
LQ Guru
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
Please don't use so much capitalization. It makes the post hard to read. Also run it through the spell checker before posting.

You may want to compare the share definitions of both the [abc] share and the new share in your smb.conf file. You also need to run "testparm" after editing your smb.conf file to check it for correctness. You may simply need to restart samba so that the config file is reread.

For a globally writable share, you should set the sticky bit on the directory.
There are three books that usually come either with samba or a samba-doc package that you could look at as well.
Old 09-11-2007, 07:55 PM   #3
LQ Newbie
Registered: Aug 2007
Location: Mexico DF
Distribution: Debian and Fedora
Posts: 21

Rep: Reputation: 15
write = yes

This look like the problem is your smb.conf (/etc/smb.conf in Fedora/centOS/Redhat)

comment = Share Directory
path = /mnt/yourpath
read only = no
public = yes
writable = yes
printable = no
write = yes
write list = admin, root, @staff, users

# Write list, is the users can write in share, this option is on or off is for more security, @ means group.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenVPN no write permision bjojoi Linux - Software 1 09-05-2006 03:51 AM
Unable to mount AND write to USB jump drive TimmerKahuna Linux - Hardware 5 08-13-2006 01:31 PM
Cannot mount a USB drive as read/write. icheyne MEPIS 2 06-28-2005 01:48 AM
How do I mount a samba directory with write permissions? xerogravity Linux - Newbie 7 12-05-2004 01:43 PM
HELP! Error from mount: drive is write-protected... won't mount writeable. system Linux - General 2 12-27-2001 09:08 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:53 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration