LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-23-2004, 01:13 PM   #1
random kid
LQ Newbie
 
Registered: Jul 2004
Posts: 19

Rep: Reputation: 0
when installing limewire cant find jvm


I have already installed a JVM but when i try to install LimeWireLinux.bin i get the following error message:

[root@localhost root]# sh ./LimeWireLinux.bin
Preparing to install...
Extracting the installation resources from the installer
Configuring the installer for this system's environment.
No Java virtual machine could be found from your PATH
environment variable. You must install a VM prior to
running this program

I think I have to configure some paths, but I do not know how.

I am logged in as root and i am in the konsole if that has anything to do with it.
 
Old 07-23-2004, 03:09 PM   #2
enygma
Member
 
Registered: Mar 2003
Distribution: CentOS 5.2
Posts: 43

Rep: Reputation: 15
Goto java.sun.com and make sure you download the Java runtime environment. Install that into a directory of your choosing. When you go to install limewire, edit your PATH as such: (using bash)

PATH=<path to java directory>:$PATH; export PATH

try and run the installer once you have done that. It should work.
 
Old 07-23-2004, 04:01 PM   #3
random kid
LQ Newbie
 
Registered: Jul 2004
Posts: 19

Original Poster
Rep: Reputation: 0
i installed limewire in /home/ryan/
so then i typed:

[root@localhost root]# PATH=/home/ryan/:$PATH;export PATH
[root@localhost root]# sh ./LimeWireLinux.bin
Preparing to install...
Extracting the installation resources from the installer archive...
Configuring the installer for this system's environment...
No Java virtual machine could be found from your PATH
environment variable. You must install a VM prior to
running this program.

the same message comes up. I am sure that i have downloaded and installed j2re-1.2.4.05-linux-i586.rpm.bin. I must be doing something wrong with the PATH.

i thought I had to edit the path in something like /etc/profile, but i get this message:

[root@localhost root]# /etc/profile
bash: /etc/profile: Permission denied

please help.
 
Old 07-23-2004, 05:00 PM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
here's the solution.. don't bother with limewire, it sucks... just because you might have used it in windows doesn't mean there is nothing else available for linux. try qtella, gtk-gnutella, gift, bittorrent... all NATIVE solutions that will work first time, with no frustrating java to get in the way.

seriously... a Newbies first hangup here is nearly always either LimeWire or Winex / Cedega...
 
Old 07-23-2004, 05:05 PM   #5
random kid
LQ Newbie
 
Registered: Jul 2004
Posts: 19

Original Poster
Rep: Reputation: 0
Actually i used Bearshare in windows. I have never heard of any of the sites you listed. I will try them though,

Thanks
 
Old 07-23-2004, 05:26 PM   #6
enygma
Member
 
Registered: Mar 2003
Distribution: CentOS 5.2
Posts: 43

Rep: Reputation: 15
Quote:
[root@localhost root]# PATH=/home/ryan/:$PATH;export PATH
I am talking about the Java Runtime environment. Find out where the runtime environment is installed. For example, if it was installed in /home/ryan/j2re1.2.4.whatever, you would do the following:

PATH=/home/ryan/j2re1.2.4.whatever:$PATH;export PATH
Quote:
[root@localhost root]# /etc/profile
bash: /etc/profile: Permission denied
What you just did there was attempt to execute a file without executable permissions. You want to actually edit the file itself by opening it up in a text editor.
 
Old 07-23-2004, 06:43 PM   #7
random kid
LQ Newbie
 
Registered: Jul 2004
Posts: 19

Original Poster
Rep: Reputation: 0
okay i did what you told me and it still didn't work. I typed,

[root@localhost root]# PATH=/j2re1.2.4.05/j2re-1_4_2_05-linux-i586-rpm.bin:$PATH;export PATH

which is the path for the java runtime environment. After i typed that, this

[root@localhost root]#

appears. Will something "happen" if exporting the path works?

I think my computer hates me.
 
Old 07-24-2004, 02:37 AM   #8
enygma
Member
 
Registered: Mar 2003
Distribution: CentOS 5.2
Posts: 43

Rep: Reputation: 15
From the looks of things you may need to install the actual software first. Follow the documentation or instructions on Suns website for installing the software. Find out where the software was installed, then set a path to the root directory of the program.

You just aren't doing it correctly. Steps you need to take:

1 - install the software as per the instructions Sun provides. you may have to change the permissions of the file first by running chmod u+x j2re-1_4_2_05-linux-i586-rpm.bin before continuing to install the software.

2 - Find where j2re was installed

3 - set the path. For example, after installing the software, if j2re was installed in /opt/j2re-1.4.2_05, then you would do PATH=/opt/j2re-1.2.4_05:$PATH;export PATH

You won't see anything happen when you set the path, but if you type echo $PATH you should see the directory you added in there, among with other directories, such as /usr/bin and /usr/local/bin. Once this is done, then continue to install Limewire, without closing your terminal session, or you will have to reset the $PATH variable again. Sorry I can't be more exact for you. I am not in front of my linux box at the moment.
 
Old 07-24-2004, 03:03 AM   #9
fEcAlMaTteR
LQ Newbie
 
Registered: Mar 2004
Distribution: Gentoo 2004.2
Posts: 17

Rep: Reputation: 0
Code:
chmod u+x j2re-1_4_2_05-linux-i586-rpm.bin
hold enter until you see the Do you agree question hit y then enter...
Code:
rpm -Uvh j2re-1.4.2_05-linux-i586.rpm
blah blah its installed most likely to /usr/java/j2re-1.4.2_05
now to install Limewire...NOT AS ROOT!
Code:
chmod u+x LimeWireLinux.bin
PATH=$PATH:/usr/java/j2re-1.4.2_05/bin \
sh ./LimeWireLinux.bin
Bam follow the instructions and start using Limewire!!!
 
Old 07-24-2004, 02:25 PM   #10
random kid
LQ Newbie
 
Registered: Jul 2004
Posts: 19

Original Poster
Rep: Reputation: 0
enygma, what exactly do you mean by
Quote:
Find where j2re was installed
???

i know where i downloaded it from sun.java.com. Is that what you mean or would it ahve installed it another place? Is there a way for me to find where it is installed other than just looking through alll my files?
 
Old 07-24-2004, 02:26 PM   #11
random kid
LQ Newbie
 
Registered: Jul 2004
Posts: 19

Original Poster
Rep: Reputation: 0
nevermind i found where it created the new folder...I think
 
Old 07-24-2004, 02:57 PM   #12
random kid
LQ Newbie
 
Registered: Jul 2004
Posts: 19

Original Poster
Rep: Reputation: 0
silly java creating its silly folders. doesnt it know tricks arer for kids? It works now just fine.

Thanks all for helping me out, but now its time to listen to some funky town!
 
Old 08-03-2004, 04:58 PM   #13
Fudge150
LQ Newbie
 
Registered: Aug 2004
Location: Scotland, UK
Distribution: SUSE 9.2
Posts: 8

Rep: Reputation: 0
Question How about creating a launcher to that then?

By the help that you have given; i have installed LimeWire.

However, to run it; i still require the PATH prefix to the sh ./runLime.sh command.

Is there a way i can configure this so that i no longer need to put the prefix in? Or can i create a launcher icon with the prefix?

[Up till now, i can create a launcher to the runLime.sh file, but this doesn't work because it needs the PATH prefix]

Thanks!
 
Old 08-03-2004, 06:05 PM   #14
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
You mean the PATH to the Java runtime? Yeah, put:
Code:
export PATH=$PATH:/path/to/java/bin
in your .bashrc file.

obviously replacing the last bit with the path to your Java bin subdirectory. Open a new bash terminal and then try it. (cos changes won't take affect until next time you start bash)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
JVM is disabled even after installing JDK... jiapei100 Linux - Software 2 09-30-2005 12:53 AM
Help me ! Installing JVM on embedded pc malvin10 Linux - Software 1 02-26-2004 04:35 AM
Trouble Invoking JVM From C: Cannot Find libjava.so. eric.r.turner Programming 0 10-20-2003 11:36 PM
Installing NetBeans -> JVM Could Not Be Found eastj1974 Linux - Software 1 05-11-2003 03:49 AM
Installing the JVM AMDPwred Linux - General 1 01-16-2002 04:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration