LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-19-2017, 06:23 PM   #1
rz1a
LQ Newbie
 
Registered: Nov 2013
Posts: 5

Rep: Reputation: Disabled
Unhappy VIM Error- E353: Nothing in register "


Got a Pi and finally started messing with linux again. Was messing around with the vimtutor and everything worked ok. Later I go back to it and when i type "p" I get the error: Error- E353: Nothing in register "

How do I fix it? I had installed tmux earlier, but both had been working ok. The error happens when I have tmux running or closed.
 
Old 02-19-2017, 08:27 PM   #2
Myk267
Member
 
Registered: Apr 2012
Location: California
Posts: 422
Blog Entries: 16

Rep: Reputation: Disabled
p is for paste. If there's nothing in the register to paste, you get an error. You can "fix" it by first yanking (y) or cutting (d) some text.
 
Old 02-19-2017, 09:17 PM   #3
rz1a
LQ Newbie
 
Registered: Nov 2013
Posts: 5

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Myk267 View Post
p is for paste. If there's nothing in the register to paste, you get an error. You can "fix" it by first yanking (y) or cutting (d) some text.
you know what, I think I just understood the instructions wrong. You were right. I should have used dd or y before using p. Noob mistake. But thank you!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vim error "leere fenc um sie zu erzwingen" (german chars) Xeratul Linux - Software 4 03-01-2015 10:35 AM
[SOLVED] Fedora shows 'man vim' but when execute 'vim' got "bash: vim: command not found..." ? flash_os Linux - Newbie 19 01-03-2015 11:56 PM
[SOLVED] Vim: how sort content of a register porphyry5 Programming 2 09-24-2011 05:02 PM
error when compiling VPNC: "Incorrect register `%rdx' used with `l' suffix" flowher Slackware 0 03-11-2010 03:03 PM
what means "Error:junk 'string' after register" qqrilxk Programming 1 03-17-2005 02:58 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration