LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-11-2002, 04:27 PM   #1
Goog
LQ Newbie
 
Registered: Dec 2002
Posts: 14

Rep: Reputation: 0
Upgrade mozilla from 1.0.1 to 1.2.1 RH8


I'm trying to upgrade from the default mozilla 1.0.1 that redhat 8 comes with.

I tried to first remove mozilla with this command:
rpm -e mozilla
and I get these errors:
libmozjs.so is needed by (installed) mozilla-mail-1.0.1-26
libmozjs.so is needed by (installed) mozilla-psm-1.0.1-26
libxpcom.so is needed by (installed) mozilla-mail-1.0.1-26
libxpcom.so is needed by (installed) mozilla-psm-1.0.1-26
mozilla = 1.0.1-26 is needed by (installed) mozilla-mail-1.0.1-26
mozilla = 1.0.1-26 is needed by (installed) mozilla-psm-1.0.1-26

Then I tried to upgrade anyway, so I got the new mozilla 1.2.1 rpm, and I tried this:
rpm -Uvh mozilla-1.2.1-0_rh8.i386.rpm
and I get these errors:
error: Failed dependencies:
mozilla-nspr = 1.2.1-0_rh8 is needed by mozilla-1.2.1-0_rh8
mozilla = 1.0.1-26 is needed by (installed) mozilla-mail-1.0.1-26
mozilla = 1.0.1-26 is needed by (installed) mozilla-psm-1.0.1-26

Any ideas what is wrong? Thanks a ton for any help!
 
Old 12-11-2002, 04:29 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
why do you assume that something is wrong?? you have dependencies. kinda like cooties but for linux. get those additional packages (or remove them, esp that psm and mail junk. then just install them all in one comand line.
 
Old 12-11-2002, 04:47 PM   #3
Goog
LQ Newbie
 
Registered: Dec 2002
Posts: 14

Original Poster
Rep: Reputation: 0
Hrm, it worked. Thanks a bunch. I still have the mail and psm "junk" though..

I tried this to remove the mail package:
rpm -e *moz*mail*
but it said package not found... but I'm pretty sure I installed it. Same thing happens when I try to uninstall psm.
 
Old 12-12-2002, 12:40 AM   #4
Deepu Sudhakar
LQ Newbie
 
Registered: Oct 2002
Posts: 25

Rep: Reputation: 15
i keep getting this dependency error when i try installing all the packages at once:

indexhtml is needed by mozilla-1.2.1-0_rh8_xft

any suggestions?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
RH8 Mozilla Java zadox Linux - Newbie 1 02-11-2005 11:00 PM
How far can you upgrade RH8? tcurt Linux - Newbie 2 06-07-2004 01:20 PM
upgrade RH8 to RH9 - upgrade or clean install PAB Linux - General 0 03-13-2004 04:55 PM
printing problems in RH8 and Mozilla scoob8000 Linux - General 11 07-06-2003 06:53 PM
upgrading mozilla on rh8.0 linowes Linux - Software 3 01-17-2003 05:20 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration