LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-14-2015, 08:09 PM   #1
Tim__
LQ Newbie
 
Registered: Mar 2015
Location: Boston, Ma
Distribution: Manjaro and CentOS at work, Ubuntu at home
Posts: 16

Rep: Reputation: Disabled
Terminal wont load in openbox on Arch


I've just installed Arch, and Installed and configured openbox and gnome terminal. Openbox starts, firefox works, but when I try to start gnome terminal, I curser spins for a moment and then it doesnt load.

I've tried to find a resolution to this but I'm not seeing much relevant to this specific scenerio. Also, this is my first time ever installing Arch, or any distro without a graphic installer or a kickstart script. My experience is pretty basic. I've used ubuntu/mint/centos for quite a while but figured this will be a good way to get me learning.

After I post this I am going to reboot to get back to command line and look at the installation and maybe install another terminal and see if this makes much a difference.
 
Old 03-14-2015, 08:17 PM   #2
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 284Reputation: 284Reputation: 284
How are you trying to start GNOME-terminal?

How did you install Arch?

Did you follow the guide in my signature?

I think you should try xterm or rxvt-unicode instead.
 
1 members found this post helpful.
Old 03-15-2015, 07:43 AM   #3
joe_2000
Member
 
Registered: Jul 2012
Location: Aachen, Germany
Distribution: Void, Arch, Debian
Posts: 844

Rep: Reputation: 243Reputation: 243Reputation: 243
No need to reboot to get to the command line.
Openbox typically has an Exit option in the menu (that you get from right-clicking on the desktop, sorry if I am stating the obvious)

On top of that, you can also press ctrl-alt-f1 to get back to the terminal tty1.
ctrl-alt-f2 will get you to tty2 and so forth.

Are you starting openbox from the command line (with startx)? If you do, you might get some useful error output there for the application that failed to start. (Which you could see by going back to the tty you ran startx from with the above-mentioned shortcuts).

Alternatively, as suggested, try running xterm. If that is successfull, try starting gnome-terminal from within xterm, to hopefully get meaningful error output.

How did you install gnome-terminal? Are you sure it actually is installed?
 
1 members found this post helpful.
Old 03-15-2015, 08:45 AM   #4
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852
You can see if you get error messages without having to install another terminal, just switch to the first VT with Ctrl+Alt+F1, log in as your user and start gnome-terminal from there with
Code:
DISPLAY=:0 gnome-terminal
It should show you any error messages relating to your problem on that console.
 
2 members found this post helpful.
Old 03-15-2015, 12:32 PM   #5
Tim__
LQ Newbie
 
Registered: Mar 2015
Location: Boston, Ma
Distribution: Manjaro and CentOS at work, Ubuntu at home
Posts: 16

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Head_on_a_Stick View Post
How are you trying to start GNOME-terminal?

How did you install Arch?

Did you follow the guide in my signature?

I think you should try xterm or rxvt-unicode instead.
I installed arch kind of by just winging it and troubleshooting my way through it. booted, partitioned (very simply, 512M swap, everything else in a single bootable part), enabled wifi, installed base system, set password and such. I got stuck at a few points such as getting drivers and packages installed for networking, and then getting openbox to work at all. I installed gnome-terminal, firefox, and links. I think thats just about it. The only other thing I did was create a user account for myself and added it to sudoers.

I installed Konsole which is working. All of the fonts look strange and the cursor doesn't like up properly.

I used the beginners guide a few times to get past a few road blocks.


Also thanks, going to try xterm now.
 
Old 03-15-2015, 12:53 PM   #6
Tim__
LQ Newbie
 
Registered: Mar 2015
Location: Boston, Ma
Distribution: Manjaro and CentOS at work, Ubuntu at home
Posts: 16

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by TobiSGD View Post
You can see if you get error messages without having to install another terminal, just switch to the first VT with Ctrl+Alt+F1, log in as your user and start gnome-terminal from there with
Code:
DISPLAY=:0 gnome-terminal
It should show you any error messages relating to your problem on that console.
This did the trick, although I did end up switching to Xterm which is working great right now. I forgot how gratifying it is building a system from the ground up (my friend is trolling me for not going with gentoo though)

Also, this may be off topic but Im curious. I've got a question about this particular command. At work I have a couple of TVs on the sales floor where they run this tool that streams sales figures from our CRM in real time. I ended up using a stripped down ubuntu install for this and have them on a couple of Intel NUCs strapped to the back. I can always SSH into them without a problem but whenever I go to VNC, I HAVE to ssh in first, run

x11vnc -display :0
then when I connect to it I have to use this convention on each box
VNC server: hotname:01
(using vnc viewer on windows)

Seems strange. I've now got them automated with a cron script that auto refreshes twice a day to get the new numbers and keep it in sync so Its been a while but it always struck me as off that doing this always got it to connect.

Thanks again, this community is great.
 
Old 03-15-2015, 01:06 PM   #7
Tim__
LQ Newbie
 
Registered: Mar 2015
Location: Boston, Ma
Distribution: Manjaro and CentOS at work, Ubuntu at home
Posts: 16

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by joe_2000 View Post
No need to reboot to get to the command line.
Openbox typically has an Exit option in the menu (that you get from right-clicking on the desktop, sorry if I am stating the obvious)

On top of that, you can also press ctrl-alt-f1 to get back to the terminal tty1.
ctrl-alt-f2 will get you to tty2 and so forth.

Are you starting openbox from the command line (with startx)? If you do, you might get some useful error output there for the application that failed to start. (Which you could see by going back to the tty you ran startx from with the above-mentioned shortcuts).

Alternatively, as suggested, try running xterm. If that is successfull, try starting gnome-terminal from within xterm, to hopefully get meaningful error output.

How did you install gnome-terminal? Are you sure it actually is installed?
Good tip on just exiting. I'm need to break the windows habit of rebooting.

Yes I am keeping things as rudimentary as possible until I get everything more and more configured. My plan with this is ultimately to get this configured to the point I can use it for day to day use, then start using this as a jumping off point to learn some real industry tools. I have a synology that will be a great tool for things like that, but I want to build a small desktop server to work in unison with things on that. For now I'm keeping it startx to get to gui when I NEED it. I even want to keep networking off unless I specifically NEED it so I'm still manually starting that. My gentoo buddy said that doing these granular self reliant things helps get comfortable with the keyboard. He even goes as far as configuring time drift on his clock to not require an NTP server. It may be something I'll never do in the real world but it's the troubleshooting skills I'm also looking to pick up.

I'm marking this thread as solved but may be back if I run into some other things. Right now on my regular user account I am required to sudo to startx even after copying .Xauthority to the home directory. But this is probably better suited in a separate thread. I'll do some troubleshooting on my own and if I do find a solution or get stuck again I'll post results in a new thread and just link it to this (for my own tracking). I'll post my notes as I go along somewhere in case someone else starting out wants to benefit from my trial and error with these problems.

Ultimately my plan is when my kids come of age, when they want a computer I'm going to make them earn it the same way I earned my first car. My father parked an old beat up manual transmission truck at the bottom of the tallest steepest hill in the region. Told me when I can get that truck to the top, I can have it. I'm trying to take the same approach here. ...Make them compile OS for their first phone? Hmm... Okay.. anywho Im getting distracted.

Thanks again, gents.

Last edited by Tim__; 03-15-2015 at 01:07 PM.
 
Old 03-15-2015, 01:25 PM   #8
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 284Reputation: 284Reputation: 284
Quote:
Originally Posted by Tim__ View Post
I am required to sudo to startx
That is a phenomenally bad idea...
 
Old 03-15-2015, 04:52 PM   #9
Tim__
LQ Newbie
 
Registered: Mar 2015
Location: Boston, Ma
Distribution: Manjaro and CentOS at work, Ubuntu at home
Posts: 16

Original Poster
Rep: Reputation: Disabled
Terminal wont load in openbox on Arch

that's why I want to see what the issue is. as soon as i get back to it I can tell you the feedback its giving when you just try to startx as nonroot. Should I start a new thread for that or is it cool to just post it here?
 
Old 03-15-2015, 05:30 PM   #10
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 284Reputation: 284Reputation: 284
Start a new thread please.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Firefox Wont Open in Openbox on Arch Vorsaykal Linux - Newbie 1 02-03-2012 03:16 PM
arch linux fails to log out of xfce4 / openbox correctly esteeven Linux - General 1 07-04-2010 06:03 AM
Im thinking I am having permission problems with oblogout and openbox in arch. bret381 Arch 3 04-21-2010 05:42 PM
[SOLVED] Automount feature for Arch + Openbox MichalKvacek Linux - Software 5 12-28-2009 06:43 PM
gnome-terminal OpenBox WM_CLASS xprop ycr Linux - Desktop 1 06-09-2007 02:47 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration