LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-31-2003, 01:21 AM   #1
End11
Member
 
Registered: Sep 2003
Distribution: slackware 9.1
Posts: 39

Rep: Reputation: 15
stupid resolution problem


so i know this is probably stupid, but here goes anyway.
i want to run 1280x960 as my default resolution. it works and i like it. i also want to have other resolutions enabled (640x480 especially, for starcraft)

the screen section of my XF86Config-4 looks like this

Code:
Section "Screen"
    Identifier  "Screen0"
    Device      "ATI Graphics Adapter"
    Monitor     "Monitor0"
    DefaultDepth 24
    #Option "backingstore"

    Subsection "Display"
        Depth       24
        Modes       "1280x960" # "1152x864" "1024x768" "800x600" "640x480"
        ViewPort    0 0  # initial origin if mode is smaller than desktop
#        Virtual     1280 960
    EndSubsection
EndSection
the problem is that unless 1280x960 is the ONLY option, i can't use it. as soon as a lower res is enabled, for example if i use

Modes "1280x960" "640x480"

i can only use the smaller one. i've tried switching with ctrl+alt+'+'.

i've searched this site and google but havent found anybody with exactly the same problem

i'm running mandrake 9.2 with fluxbox 0.9.6, i have the proprietary drivers installed for my radeon 9000 pro, and my monitor is a SyncMaster 955df, the exact model of which is set up in my config.

is it possible to use 1280x960, but have others enabled? it seems like it should just work. but it doesnt.
 
Old 12-31-2003, 08:42 AM   #2
Netizen
Member
 
Registered: Sep 2003
Location: Texas
Distribution: Slackware and Ubuntu
Posts: 355

Rep: Reputation: 30
Did you change the Verticalsysnc and Horizontalsync parms in the same file to match those of your monitor?

Netizen
 
Old 12-31-2003, 02:38 PM   #3
End11
Member
 
Registered: Sep 2003
Distribution: slackware 9.1
Posts: 39

Original Poster
Rep: Reputation: 15
actually all my modelines are commented out :/ it looks like this
Code:
Section "Monitor"
    Identifier  "Monitor0"
    HorizSync   31.5 - 91.1
    VertRefresh 60 - 100
    Option "DPMS"

# === mode lines based on GTF ===
# VGA @ 100Hz
# Modeline "640x480@100" 43.163 640 680 744 848 480 481 484 509 +hsync +vsync
# SVGA @ 100Hz
# Modeline "800x600@100" 68.179 800 848 936 1072 600 601 604 636 +hsync +vsync
# XVGA @ 100Hz
# Modeline "1024x768@100" 113.309 1024 1096 1208 1392 768 769 772 814 +hsync +vsync
# 1152x864 @ 60Hz
# Modeline "1152x864@60" 81.642 1152 1216 1336 1520 864 865 868 895 +hsync +vsync
# 1152x864 @ 85Hz
# Modeline "1152x864@85" 119.651 1152 1224 1352 1552 864 865 868 907 +hsync +vsync
# 1152x864 @ 100Hz
# Modeline "1152x864@100" 143.472 1152 1232 1360 1568 864 865 868 915 +hsync +vsync
# 1280x960 @ 75Hz
# Modeline "1280x960@75" 129.859 1280 1368 1504 1728 960 961 964 1002 +hsync +vsync
# 1280x960 @ 100Hz
# Modeline "1280x960@100" 178.992 1280 1376 1520 1760 960 961 964 1017  +hsync +vsync
etc. etc. with res's up to 1920x2400

is that the right section?

anyway the thing is the all the resolutions work, im in 1280x960 right now, the problem only comes when I enable other ones
 
Old 01-01-2004, 03:48 AM   #4
Zero-0-Effect
Member
 
Registered: Sep 2002
Location: Texas
Distribution: SlackWare - Current LFS - CVS
Posts: 267

Rep: Reputation: 31
Modes "1280x960" # "1152x864" "1024x768" "800x600" "640x480"

Remove that # mark. It should default to the first entry of 1280x960.

When in a smaller resolution (1024x768) you said 'ctrl'+'alt'+'+' doesnt work, Is it still a virtual screen resolution of 1280x960?
 
Old 01-01-2004, 06:31 AM   #5
End11
Member
 
Registered: Sep 2003
Distribution: slackware 9.1
Posts: 39

Original Poster
Rep: Reputation: 15
that's exactly what i tried Zero, unfortunately when i put
Modes "1280x960" "1152x864" "1024x768" "800x600" "640x480"
it seems to default to 1024x768 instead of the first one like you would expect. also i have no virtual screen resolution set, that was commented out. will that help?
 
Old 01-01-2004, 03:41 PM   #6
Zero-0-Effect
Member
 
Registered: Sep 2002
Location: Texas
Distribution: SlackWare - Current LFS - CVS
Posts: 267

Rep: Reputation: 31
It will allow you to have a vritual 1280x960 if in 1024x768 but it still looks like a 1024x768 desktop.
What driver are you useing? A radeon driver off of gatos.sourceforge.net or the driver that came with mandrake?
 
Old 01-01-2004, 05:35 PM   #7
End11
Member
 
Registered: Sep 2003
Distribution: slackware 9.1
Posts: 39

Original Poster
Rep: Reputation: 15
im using the proprietary ati drivers, because they're the only ones that run games properly (i need those fps in tuxracer)

anyway, i solved half my problem. i generated and manually put in a modeline for 1280x960 at 85 hertz. it will now actually use the default res, and switch between the others fine. my only problem now is that when i go down to 640x480 everything gets all messed up. i can't really explain it, it's like i see small rectangular fragments of stuff all over my screen.

oh well at least i can change down to 800x600 without problems now
 
Old 01-01-2004, 07:50 PM   #8
kc8tbe
Member
 
Registered: Feb 2003
Location: Cleveland, Ohio (USA)
Distribution: Gentoo, Kubuntu 6.06
Posts: 179

Rep: Reputation: 30
Xfree-drm, the old kernel Xfree drivers, support ATI radeon just fine. Just be sure you don't compile xfree-dri AND xfree-drm into the kernel - then nothing will work!

The Xfree-drm in the 2.4.x kernel is a little iffy, but some third party xfree-drm work fine. So if after compiling xfree-drm into the kernel instead of xfree-dri things still don't work, don't compile either one into the kernel and look for an xfree-drm package on the internet.
 
Old 01-02-2004, 01:06 AM   #9
End11
Member
 
Registered: Sep 2003
Distribution: slackware 9.1
Posts: 39

Original Poster
Rep: Reputation: 15
thanks for the advice, but I dont think i'm at the stage where i want to compile a kernel :S
 
Old 01-02-2004, 10:10 AM   #10
kc8tbe
Member
 
Registered: Feb 2003
Location: Cleveland, Ohio (USA)
Distribution: Gentoo, Kubuntu 6.06
Posts: 179

Rep: Reputation: 30
> thanks for the advice, but I dont think i'm at the stage where i want to compile a kernel :S

Kernel compilation isn't actually all that exciting.

Here are the pertinent sections of my XF86Config using the radeon 9000 pro video card. Maybe it'll help.
Code:
Section "Module"
        Load  "extmod"
        Load  "dri"
        Load  "dbe"
        Load  "record"
        Load  "xtrap"
        Load  "glx"
        Load  "speedo"
        Load  "type1"
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Future Power"
        ModelName    "17DB77"
        HorizSync    30-70
        VertRefresh  50-150
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "NoAccel"                   # [<bool>]
        #Option     "SWcursor"                  # [<bool>]
        #Option     "Dac6Bit"                   # [<bool>]
        #Option     "Dac8Bit"                   # [<bool>]
        #Option     "ForcePCIMode"              # [<bool>]
        #Option     "CPPIOMode"                 # [<bool>]
        #Option     "CPusecTimeout"             # <i>
        #Option     "AGPMode"                   # <i>
        #Option     "AGPFastWrite"              # [<bool>]
        #Option     "AGPSize"                   # <i>
        #Option     "RingSize"                  # <i>
        #Option     "BufferSize"                # <i>
        #Option     "EnableDepthMoves"          # [<bool>]
        #Option     "EnablePageFlip"            # [<bool>]
        #Option     "NoBackBuffer"              # [<bool>]
        #Option     "DRIReinit"                 # [<bool>]
        #Option     "PanelOff"                  # [<bool>]
        #Option     "DDCMode"                   # [<bool>]
        #Option     "MonitorLayout"             # [<str>]
        #Option     "IgnoreEDID"                # [<bool>]
        #Option     "OverlayOnCRTC2"            # [<bool>]
        #Option     "CloneMode"                 # [<str>]
        #Option     "CloneHSync"                # [<str>]
        #Option     "CloneVRefresh"             # [<str>]
        #Option     "UseFBDev"                  # [<bool>]
        #Option     "VideoKey"                  # <i>
        Identifier  "Card0"
        Driver      "ati"
        VendorName  "ATI Technologies Inc"
        BoardName   "Radeon R250 If [Radeon 9000]"
        BusID       "PCI:1:0:0"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        DefaultDepth 16

        SubSection "Display"
                Depth     1
        EndSubSection
        SubSection "Display"
                Depth     4
        EndSubSection
        SubSection "Display"
                Depth     8
        EndSubSection
        SubSection "Display"
                Depth     15
        EndSubSection
        SubSection "Display"
                Depth     16
                Modes     "1280x1024"
                Viewport  0 0
        EndSubSection
        SubSection "Display"
                Depth     24
        EndSubSection
EndSection
Also, be aware that your monitor may not run a resolution higher than 1152x864. Have you been able to get to a 1280x960 before (i.e. in windoze)?
 
Old 01-02-2004, 05:47 PM   #11
End11
Member
 
Registered: Sep 2003
Distribution: slackware 9.1
Posts: 39

Original Poster
Rep: Reputation: 15
yes thank you, i have 1280 x 960 running nicely at 85 hertz now, and it switches back and forth. the only problem im having is now 640x480 is messed up, but i think it might just be a matter of manually making a modeline for it.
 
Old 01-02-2004, 06:25 PM   #12
kc8tbe
Member
 
Registered: Feb 2003
Location: Cleveland, Ohio (USA)
Distribution: Gentoo, Kubuntu 6.06
Posts: 179

Rep: Reputation: 30
When you try to go to 640x480 are you just casually using your desktop or trying to play a game?
 
Old 01-02-2004, 06:31 PM   #13
End11
Member
 
Registered: Sep 2003
Distribution: slackware 9.1
Posts: 39

Original Poster
Rep: Reputation: 15
starcraft only runs in 640x480, and there is no option for resolution change ingame.
it's not desperate as i can just boot in windows to play it, but it would be nice to be able to play it well in linux.
 
Old 01-03-2004, 11:33 AM   #14
kc8tbe
Member
 
Registered: Feb 2003
Location: Cleveland, Ohio (USA)
Distribution: Gentoo, Kubuntu 6.06
Posts: 179

Rep: Reputation: 30
Will native Linux games like Chromium or Tuxracer run in 640x480? What about the quake 2 & 3 game engines for Linux? What about changing your desktop resolution to 640x480?

If a) the error occurs when you are in 640x480 and b) you are only in 640x480 while playing Starcraft, it follows that c) the error only occurs while you are playing Starcraft. Maybe the fault here lies with Starcraft or Wine/WineX, and not with the X server.
 
Old 01-03-2004, 03:22 PM   #15
End11
Member
 
Registered: Sep 2003
Distribution: slackware 9.1
Posts: 39

Original Poster
Rep: Reputation: 15
that's the thing, it's NOT just in starcraft. if i run tuxracer in full screen it does it, and if i even just switch my resolution by ctrl+alt+'+' it does it. and, if i add in a modeline for 640x480, i go back to my original problem of not being able to switch to either of them! (640x480 or 1280x960)

by the way thanks for taking the time to help me kc8tbe.

i think maybe i'll just wait until the next release of wine. it's free, it runs starcraft, and it has the option to run in a window :S
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Stupid, stupid question; I lost Klaptop. :( Surfrider Slackware 2 08-31-2005 09:12 PM
My Last Stupid Problem mtecknology Linux - Software 8 07-15-2005 03:32 PM
Stupid problem k1ll3r_x Linux - Hardware 4 01-06-2005 08:21 AM
stupid cdrom problem phatbastard Linux - Newbie 4 03-11-2004 02:02 AM
Stupid problem with gDesklets deigote Linux - Software 0 11-22-2003 06:13 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration