LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-15-2007, 07:31 AM   #1
goggo
LQ Newbie
 
Registered: Sep 2003
Location: Australia Sydney
Distribution: Vector SOHO 5, Solaris 9 (SPARC)
Posts: 19

Rep: Reputation: 0
sftp/svn+ssh connect problem


Hi

When i connect to my vector box for sftp or svn+ssh:// i get

xhost: unable to open display ""



Can someone help me? (i'm logged on as regular user. i don't want to use root to sftp etc.)
 
Old 03-16-2007, 11:14 AM   #2
pokemaster
Member
 
Registered: Apr 2005
Location: Massachusetts, USA
Distribution: debian,ubuntu,slackware
Posts: 110

Rep: Reputation: 17
Explain?

- is that error on your client or server?
- when you 'connect to your vector box for sftp', are you using sftp from the terminal? Last time I checked, sftp wasn't an X11 program...
- Tell us the circumstances where your root account works, but not the normal user.
 
Old 03-18-2007, 02:33 AM   #3
goggo
LQ Newbie
 
Registered: Sep 2003
Location: Australia Sydney
Distribution: Vector SOHO 5, Solaris 9 (SPARC)
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by pokemaster
Explain?

- is that error on your client or server?
- when you 'connect to your vector box for sftp', are you using sftp from the terminal? Last time I checked, sftp wasn't an X11 program...
- Tell us the circumstances where your root account works, but not the normal user.
I'm using a linux client to sftp or ssh+svn into my vector box. I've enabled X11 forwarding on ssh as i can xlogo when i ssh in.

the error i get is from the client. i am using the terminal. i tried a svn import svn+ssh:// and used the -m parameter for the message
 
Old 03-18-2007, 06:39 AM   #4
pokemaster
Member
 
Registered: Apr 2005
Location: Massachusetts, USA
Distribution: debian,ubuntu,slackware
Posts: 110

Rep: Reputation: 17
That sounds a bit odd -- svn+ssh obviously shouldn't need an X11 connection. Have you tried the same command without X11 forwarding?

another thing to try is
Code:
export DISPLAY=localhost:10.0
and try again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
anon svn read-only over apache: '.svn/entries': No such file hedpe Linux - Software 2 04-29-2009 05:31 AM
Trying to connect to SVN server after setup jaristr Linux - Server 2 11-01-2006 11:01 AM
svn+ssh hgb Linux - Server 1 10-10-2006 06:35 AM
Can't connect using SFTP nethook Linux - Security 3 04-14-2005 01:17 PM
sftp does not connect tpjets62 Fedora 9 02-17-2004 10:45 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration