LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-05-2008, 02:40 AM   #16
okos
Member
 
Registered: May 2007
Location: California
Distribution: Slackware/Ubuntu
Posts: 609

Rep: Reputation: 38

BEFORE YOU DO ANYTHING backup your X11
open console
su
cp -R /etc/X11 /etc/X11.bak

Quote:
Originally Posted by Labman View Post
OK, I downloaded it to my desktop.

dick@xantha:~$ su root
Password:
xantha:/home/dick# sh NVIDIA-Linux-x86-169.12-pkg1.run
sh: NVIDIA-Linux-x86-169.12-pkg1.run: No such file or directory
Do I need to have it somewhere besides the desktop?

You are not on your desktop.
It would say /home/dick/Desktop.
When you are in a directory type "ls" (no quotes) to list the files in the directory. To change directory to Desktop, while you are in your home directory, type "cd Desktop". OR cd /home/dick/Desktop if you are in any other directory. See the following link for man pages on the cd command. I am not sure how to articulate this; one note, omit the "/" to cd to a directory attached to your currently location. For example, you are in your home directory, "/home/dick" to change to Desktop (one up from /home/dick) omit the slash "/" just cd Desktop NOT cd /Desktop. I hope this make sense

Anyways, simply way follow these commands:
cd /home/dick/Desktop
ls (should show you the Nvidia file)
./NVIDIA-Linux-x86-169.12-pkg1.run

Secondly I am with General Failure, I suggest to change your settings. Once you install the nvidia driver you might still have to edit the /etc/X11/xorg.conf file as I did with nvidia.

To change your settings.
open console
su
password
nano /etc/X11/xorg.conf

Then change
Quote:
Modes "1280x1024" "1024x768" "800x600" "640x480"
to
Quote:
Modes "1024x768" "800x600" "640x480"
As General Failure has stated.

Last edited by okos; 04-05-2008 at 02:47 AM.
 
Old 04-05-2008, 08:20 AM   #17
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Since your Desktop is not likely to be in you PATH variable, you have to give the whole path when executing a file. The alternative is to cd to the directory and then do:
./NV*
(The * tells bash to "expand" the command to include the full name of the file.)

You first probably need to change permissions to allow execution:
chmod 755 NV*
 
Old 04-05-2008, 10:26 AM   #18
General Failure
Member
 
Registered: Jan 2007
Location: Germany
Distribution: Slackware 13.37
Posts: 387

Rep: Reputation: 35
Quote:
Originally Posted by Labman View Post
I su to root, and open /etc/X11/xorg.conf in Kate, and delete the 1280 mode.
Where and how did you su to root? I suggest pressing Alt-F2 to bring up the Run command window in KDE and typing "kdesu kate", without quotes. Enter your root password when prompted and kate will open. Edit xorg.conf and save. That should do it.
 
Old 04-07-2008, 09:57 PM   #19
Labman
Member
 
Registered: Apr 2004
Location: Nothern USA
Distribution: Kubuntu 11.10
Posts: 104

Original Poster
Rep: Reputation: 15
Even if I am slow to respond, I do appreciate your help. After a busy weekend and day, I finally tried some of the later suggestions. I seemed to be making some progress when I got a message I had to shut down X to change the driver. Maybe I will try again later. I am sorry, but I am about as interested in all this as the average person is in rebuilding the engine of their car.

As I said, I am not sure why I ended up with the wrong driver, but suspect that long term, I am better off getting the right one installed. Since it is the same chip, do I need the right driver to get the VMWare player working?
 
Old 04-11-2008, 12:00 PM   #20
Labman
Member
 
Registered: Apr 2004
Location: Nothern USA
Distribution: Kubuntu 11.10
Posts: 104

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by okos View Post
BEFORE YOU DO ANYTHING backup your X11
open console
su
cp -R /etc/X11 /etc/X11.bak ....
I did that. I didn't get a save dialog, so I am not sure where it saved it.

Quote:
Originally Posted by pixellany View Post
Since your Desktop is not likely to be in you PATH variable, you have to give the whole path when executing a file. The alternative is to cd to the directory and then do:
./NV*
(The * tells bash to "expand" the command to include the full name of the file.)

You first probably need to change permissions to allow execution:
chmod 755 NV*
I was able to make that work, but when it executed, it came back with a error that X was running. After I exited X, I couldn't get into the Desktop directory, ''Bash no such file'' cd Desktop didn't work.
./home/dick/Desktop/NV* didn't work.

Although I have managed to edit xorg and now have the 1024 X 768 resolution, I still think long term, I want the correct driver.


Quote:
Originally Posted by General Failure View Post
Where and how did you su to root? I suggest pressing Alt-F2 to bring up the Run command window in KDE and typing "kdesu kate", without quotes. Enter your root password when prompted and kate will open. Edit xorg.conf and save. That should do it.
I tried that, and it worked

Question? Would have Kate worked the same if I just opened it from the menu? Did you just suggest that because you knew it would work?

I then went into the control center and changed the 20 point fonts to 12 point. I am now finding most stuff usable, seeming to have slightly too large of font in places and slightly too small in others, but quite usable.

My Yahoo still comes up in an unreadable tiny font. I did manage to get their change back link to work, and the old My Yahoo is usable as well as Yahoo Mail. Considering their ''Configure your system to our site'' attitude, I am looking at alternatives.

My biggest problem now is Iceweasel. It works better than Konqueror with some sites, including All Experts where I spend a lot of time. The menu bar, and the menus are still in a tiny, fuzzy font that hurts my eyes. I can't find anything in the preferences to change it.
 
Old 04-11-2008, 03:32 PM   #21
General Failure
Member
 
Registered: Jan 2007
Location: Germany
Distribution: Slackware 13.37
Posts: 387

Rep: Reputation: 35
cp is the copy command in Linux. You issued "cp -R /etc/X11 /etc/X11.bak", which means you copied /etc/X11 recursively (=the whole directory) to /etc/X11.bak. You could also have typed "cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak", which would only have created a copy of xorg.conf as xorg.conf.bak. There was no save dialog because it's just unnecessary if using the command like you did.

The "./NV*" thing will only will only work if you are in the directory where there is an NV* file, because "./" tells the shell to run that file in the current directory. So "cd /home/dick/Desktop/" and then "./NV*".
Quote:
Would have Kate worked the same if I just opened it from the menu? Did you just suggest that because you knew it would work?
No it wouldn't have. kdesu is a KDE program that let's you run a program as root. If you run kate from the menu, it's started as the user you're logged in as. So yes, I suggested that because I knew it would work

For the fonts problem: Firefox/Iceweasel have their own font settings, so you need to set up your desired fonts and sizes inside the program. Generally, if you want nice fonts, see if you can install the liberation fonts (they should be in your package repositories) or the MS TTF core fonts.
 
Old 04-12-2008, 03:49 PM   #22
Fred Caro
Member
 
Registered: May 2007
Posts: 999

Rep: Reputation: 166Reputation: 166
resolution from fred

Without reading back in detail I take it you have a working copy of Debian 4. I use 'view' 'zoom' to overcome the difficulties of reading text as am a bit short-sighted. If you want to do anything more complicated then that is of no use but it is a solution for simple folk.
 
Old 04-12-2008, 04:03 PM   #23
Doctorzongo
Member
 
Registered: Mar 2008
Distribution: Fedora 11
Posts: 72

Rep: Reputation: 15
Quote:
Originally Posted by Labman View Post
OK, I su to root and put in /etc/X11/xorg.conf It comes back permission denied.
Type
Code:
su
vim /etc/X11/xorg.conf
I sometimes have to change the graphics driver to
Code:
vesa
to get anything to work.
 
Old 04-12-2008, 11:28 PM   #24
Labman
Member
 
Registered: Apr 2004
Location: Nothern USA
Distribution: Kubuntu 11.10
Posts: 104

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Fred Caro View Post
Without reading back in detail I take it you have a working copy of Debian 4. I use 'view' 'zoom' to overcome the difficulties of reading text as am a bit short-sighted. If you want to do anything more complicated then that is of no use but it is a solution for simple folk.
As I reported above, I did manage to edit /xorg.conf. It took some further tweaking of the number of pixils under fonts in the control center.

I now have usable fonts in almost everything. It seems there is no making Netscape 4.X Messenger work in a modern Debian. I looked at Icedove, but it came up in a gigantic, unusable font. It is a rather poor excuse of an email program. I can't belief how much better NS 4.X is than any of the newer things I have looked at.
 
Old 04-13-2008, 06:57 PM   #25
okos
Member
 
Registered: May 2007
Location: California
Distribution: Slackware/Ubuntu
Posts: 609

Rep: Reputation: 38
Hi
If you want to install the nVidia driver, since you downloaded it already, you will have to find it on your system. I know having changed from windows, that it takes a while to understand the linux file system.

Anyways you will need to know where you saved it.
If you can see the file on your desktop when x is running, it will be located in the following directory:
/home/dick/Desktop/

If it is not on your desktop, for a noobie I think the easiest way to find the nvidia driver in KDE is to click KDE>find files> Name: nvidia, Lookin: / Your computer will find the driver. Remember where it is located or write it down.

To install the nvidia driver you will have to close x and use only commandline. The cd it the command for change directories.
Once you logged out,

cd /home/dick/Desktop (or where ever the file is located)
su
password
sh NVIDIA-Linux-x86-169.12-pkg1.run

That's it!
 
Old 04-13-2008, 10:23 PM   #26
Labman
Member
 
Registered: Apr 2004
Location: Nothern USA
Distribution: Kubuntu 11.10
Posts: 104

Original Poster
Rep: Reputation: 15
Yeah, it is right there on the Desktop. I may try that. I am busy having a life outside the net, moving into my new system, etc.

I am quite pleased Foxmarks works with Iceweasel. Maybe the next thing I will try is adding it to Konqueror where most of my newer bookmarks, perhaps including Linux questions are.

What I really need to do is choose an email program.
 
Old 04-13-2008, 10:23 PM   #27
Labman
Member
 
Registered: Apr 2004
Location: Nothern USA
Distribution: Kubuntu 11.10
Posts: 104

Original Poster
Rep: Reputation: 15
Yeah, it is right there on the Desktop. I may try that. I am busy having a life outside the net, doing my regular net stuff, moving into my new system, etc.

I am quite pleased Foxmarks works with Iceweasel. Maybe the next thing I will try is adding it to Konqueror where most of my newer bookmarks, perhaps including Linux questions are.

What I really need to do is choose an email program.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Display resolution per user (xinerama, KDE, Debian) johnsfine Linux - Newbie 4 03-02-2008 07:38 AM
Problem setting display resolution / desktop size Robhogg SUSE / openSUSE 2 02-23-2006 09:16 PM
Setting up display resolution on HP zv 5000 laptop J--Lew Linux - Newbie 2 10-13-2005 09:36 PM
Dual head display problem and setting resolution Navyblue Linux - Newbie 4 08-01-2005 11:18 AM
Setting the highest display resolution artemis Fedora 3 06-16-2004 03:32 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration