LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-09-2017, 11:06 PM   #1
DavidLemlerM
LQ Newbie
 
Registered: Jun 2017
Distribution: Linux Mint
Posts: 6

Rep: Reputation: Disabled
Set Custom Firefox As Default Browser On Linux Mint


I was just curious if someone could help me out with this. I have been using Firefox as my main browser (at least on Linux) for a while, and I have recently decided to start using the Nightly and Beta (and Developer) versions, as I like trying out beta things. The one problem I have is that whenever I open a link from another application, it always opens the regular (stable release channel) version. I went into the Preferred Applications section, but even when I show the list of all applications, I don't see the Beta, Developer, or Nightly versions of Firefox. When I installed them, I simply extracted the zip download from the website to my home folder (a different folder for each browser) and then used alacarte to add links to the "firefox" file in each folder to the Mint menu. I have tried adding this code into a .mailcap folder in my home directory (I replaced the Firefox folder names and my username in the code), but it still shows the regular Firefox in the preferred applications section and still opens it when I click on a link in another app. If someone could tell me something that could allow this to work, it would be greatly appreciated.
 
Old 10-11-2017, 02:24 AM   #2
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 17,231
Blog Entries: 10

Rep: Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160
you need to show us where and how you installed firefox.
 
Old 10-11-2017, 12:43 PM   #3
DavidLemlerM
LQ Newbie
 
Registered: Jun 2017
Distribution: Linux Mint
Posts: 6

Original Poster
Rep: Reputation: Disabled
Like I had said in the original post, I extracted the archives from the Firefox download site and a placed them in my home folder. I put them into these three folders: ".Firefox Nightly", ".Firefox Developer", ".Firefox Beta". Then I used alacarte (menu editor) to add shortcuts to the file named "firefox" in each folder (I found that double clicking on this file launched that version of Firefox).
 
Old 10-11-2017, 02:18 PM   #4
jamison20000e
Senior Member
 
Registered: Nov 2005
Location: ...uncanny valley... infinity\1975; (randomly born:) Milwaukee, WI, US( + travel,) Earth( I wish,) END BORDER$!◣◢┌∩┐ Fe26-E,e...
Distribution: any GPL that works well on my cheapest; has been KDE or CLI but open... http://goo.gl/NqgqJx &c ;-)
Posts: 4,390
Blog Entries: 3

Rep: Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436
Have you switched Nightly's preferences to always see if it's the default browser? What desktop is Mint using? In KDE or others you can switch text\HTML's "file associations" to a default choice...

maybe add Nightly to your usr\bin you don't say where* said ^"shortcut"^ is?

Edit\added missing word: preferences

Last edited by jamison20000e; 10-11-2017 at 06:41 PM.
 
Old 10-11-2017, 04:59 PM   #5
DavidLemlerM
LQ Newbie
 
Registered: Jun 2017
Distribution: Linux Mint
Posts: 6

Original Poster
Rep: Reputation: Disabled
I'm using the Cinnamon desktop. I used the menu editor (I think it's alacarte) to add the shortcuts to the menu (like Windows start menu). I added a screenshot of the menu editor I used in the attachments. In the XFCE desktop, what I did to set my custom Firefox as default is I went to the preferred applications section in the settings, and just pointed it to the specific file I wanted to use. However, in Cinnamon, it only gives me a list of programs, but no option to pick a specific file. I didn't know if there was another way to pick a specific file (like in XFCE), or if there was a way to add a specific file to the programs list. I also attached a screenshot of the programs selection list, as well as how I was able to get it working in XFCE.

Also, I tried clicking to option in Nightly to set it as the default browser, but that did nothing. Also, setting Nightly (custom program selection) to be the default program to open HTML files worked for HTML files, but didn't work when doing something like clicking a link in an email.
Attached Thumbnails
Click image for larger version

Name:	Menu Editor.png
Views:	291
Size:	66.5 KB
ID:	26084   Click image for larger version

Name:	Application List.png
Views:	287
Size:	19.7 KB
ID:	26085   Click image for larger version

Name:	XFCE.jpg
Views:	235
Size:	3.1 KB
ID:	26086  
 
Old 10-11-2017, 07:01 PM   #6
jamison20000e
Senior Member
 
Registered: Nov 2005
Location: ...uncanny valley... infinity\1975; (randomly born:) Milwaukee, WI, US( + travel,) Earth( I wish,) END BORDER$!◣◢┌∩┐ Fe26-E,e...
Distribution: any GPL that works well on my cheapest; has been KDE or CLI but open... http://goo.gl/NqgqJx &c ;-)
Posts: 4,390
Blog Entries: 3

Rep: Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436
Quote:
Originally Posted by DavidLemlerM View Post
... However, in Cinnamon, it only gives me a list of programs, but no option to pick a specific file. I didn't know if there was another way to pick a specific file (like in XFCE), ..
I ran apps from the folders toO but forget how you set it up so the system sees it as installed? I'd try searching around that... time to start work for me have fun.
 
Old 10-11-2017, 07:07 PM   #7
DavidLemlerM
LQ Newbie
 
Registered: Jun 2017
Distribution: Linux Mint
Posts: 6

Original Poster
Rep: Reputation: Disabled
Thanks for your help. I was playing around in /usr/share/applications and I think I might be onto something, and I might post if I find out a definite solution.
 
Old 10-11-2017, 10:12 PM   #8
jamison20000e
Senior Member
 
Registered: Nov 2005
Location: ...uncanny valley... infinity\1975; (randomly born:) Milwaukee, WI, US( + travel,) Earth( I wish,) END BORDER$!◣◢┌∩┐ Fe26-E,e...
Distribution: any GPL that works well on my cheapest; has been KDE or CLI but open... http://goo.gl/NqgqJx &c ;-)
Posts: 4,390
Blog Entries: 3

Rep: Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436Reputation: 1436
Brake time.

A quick search on installing app folders found this, may help... https://unix.stackexchange.com/quest...-and-usr-local
 
Old 10-12-2017, 02:17 AM   #9
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 17,231
Blog Entries: 10

Rep: Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160
i think you need something like "preferred applications" (gui setting)
and/or "alternatives x-www-browser" (full program name eludes me atm) (command line).

your last screenshot seems to confirm that you did the first part.
it should've been enough.
maybe log out/in is required?
 
Old 10-14-2017, 05:23 PM   #10
DavidLemlerM
LQ Newbie
 
Registered: Jun 2017
Distribution: Linux Mint
Posts: 6

Original Poster
Rep: Reputation: Disabled
I just found the solution! I still haven't found how to select a specific file to make as my default browser, but I was able to install Firefox Nightly from a repository, and now it comes up as an option for the default web browser. To install it, just run these three commands in the terminal (you'll have to enter an admin account password for the first one):
Code:
sudo add-apt-repository ppa:ubuntu-mozilla-daily/ppa
sudo apt-get update
sudo apt-get install firefox-trunk
I'd still like to know how to set a custom program this way, but at least now I can use Nightly as my default browser. One other note is that installing it this way, it will automatically use a different profile folder, so unless you want to have Nightly be on a different profile, you'll need to edit the profiles file to point to one profile folder for both browsers to use.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to set default browser in RHEL and install plugins (for firefox) ? onur.aktas Linux - Newbie 0 08-12-2008 10:32 AM
RHEL 5 w/ Gnome - How to set 32 bit Firefox as default browser? rkmason Red Hat 2 07-01-2007 10:42 AM
Can't set Firefox as default browser under Mandrake/kde Gustavoang Mandriva 1 09-19-2005 01:18 PM
set firefox as default web browser Knowledgements Slackware 10 07-25-2005 07:54 AM
How do i set firefox as default web browser in 10.1 official rockmeisster Mandriva 4 12-24-2004 11:12 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration