LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-19-2008, 09:15 PM   #1
linuxitis
LQ Newbie
 
Registered: Aug 2008
Posts: 3

Rep: Reputation: Disabled
rt73 / GW-US54Mini2G Wireless USB


Hello all,
I need help installing the above device in openSUSE11. I tried to use the linux drivers from the CD and from their site as well. I made sure that make and gcc were installed. I am new to linux and don't know what I am missing. Thank you in advance.
This is my output:

jl@batmanOS:~/bin/GW-US54Mini2_Linux_v1.0.3.6_Eng/Module> su
Password:
batmanOS:/home/jl/bin/GW-US54Mini2_Linux_v1.0.3.6_Eng/Module # uname -r
2.6.25.11-0.1-pae
batmanOS:/home/jl/bin/GW-US54Mini2_Linux_v1.0.3.6_Eng/Module # ls
assoc.c config.mk ifcfg-rausb0 load Makefile.6 mlme.c README rt73.h rtmp_def.h rtmp_init.c rtmp_type.h rtusb_data.c sync.c wpa.h
auth.c Configure iwpriv_usage.txt Makefile md5.c mlme.h ReleaseNote rt73sta.dat rtmp.h rtmp_main.c rtmp_wep.c rtusb_io.c unload
auth_rsp.c connect.c license Makefile.4 md5.h oid.h rt73.bin rt_config.h rtmp_info.c rtmp_tkip.c rtusb_bulk.c sanity.c wpa.c
batmanOS:/home/jl/bin/GW-US54Mini2_Linux_v1.0.3.6_Eng/Module # cp Makefile.6 ./Makefile
batmanOS:/home/jl/bin/GW-US54Mini2_Linux_v1.0.3.6_Eng/Module # make all
make -C /lib/modules/2.6.25.11-0.1-pae/build SUBDIRS=/home/jl/bin/GW-US54Mini2_Linux_v1.0.3.6_Eng/Module modules
make[1]: Entering directory `/usr/src/linux-2.6.25.11-0.1-obj/i386/pae'
make[1]: *** No rule to make target `modules'. Stop.
make[1]: Leaving directory `/usr/src/linux-2.6.25.11-0.1-obj/i386/pae'
make: *** [all] Error 2
batmanOS:/home/jl/bin/GW-US54Mini2_Linux_v1.0.3.6_Eng/Module #
 
Old 08-20-2008, 11:42 PM   #2
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 223Reputation: 223Reputation: 223
The rt73usb driver is in Suse already. Use Yast to configure your network.

I have a usb stick that uses the same chipset. All I had to do was plug it in, run Yast to configure the network -it had to download the firmware from a repo, so make sure you do have a current net connection- input my wireless config options, and everything worked
 
Old 08-21-2008, 05:20 PM   #3
linuxitis
LQ Newbie
 
Registered: Aug 2008
Posts: 3

Original Poster
Rep: Reputation: Disabled
I opened YaST which opened the YaST Control Center, then I clicked on Network Devices, then Network Settings. I get the YaST2 window with the Network Settings and under the Overview tab I can see my wire-connected NIC and my "802.11 bg WLAN" which is "Not configured". If I click on "Edit" I get a message: "The device needs a firmware to function properly. It can be usually downloaded from your verndor web page. If you have already downloaded and installed the firmware, click 'Continue' to configure the device. Otherwise click 'Cancel' and return to this dialog once you have installed the firmare."
What repository did you get the firmware from and how did you configure it?
Excuse me please for asking so many questions, but I have put many hours on this without results.
Again thank you.

Last edited by linuxitis; 08-22-2008 at 09:32 PM.
 
Old 08-22-2008, 09:43 PM   #4
linuxitis
LQ Newbie
 
Registered: Aug 2008
Posts: 3

Original Poster
Rep: Reputation: Disabled
rt73 - I finally got it working

This is how I got my wireless device up and running. I will give little details so that it can help other newbies save time and patience. Remember this is in openSUSE11 with KDE.

Go to Http://packages.opensuse-community.org. Pick your openSUSE version and search for the chipset manufacturer or the chipset itself, in this case “ralink”. This will give you the option to install the firmware thru YaST. Click on the “Install” button (usually first option); when the opening window pops up click on “open with YaST Meta Package Handler” and click on “OK”. Choose all the default settings and click on “Next”. Once the firmware is installed open YaST, then click on “Network Devices”, then “Network Settings”. Under the “Overview” tab you'll see your “*** WLAN” device “Not configured”. Highlight it and click on the “Edit” button. When you get the message “The device needs a firmware to funtion properly...” click on “Continue”. Under the “General” tab in the “Device Activation” section choose “At Boot Time”; under the “Address” tab “Dynamic Address DHCP”, under the “Hardware” tab in the “Kernel Module” section make sure you choose “rt73usb” or the available one. Click on Next and Finish. Go back to the “Network Settings” window and under the “Global Options” tab in the “Network Setup Method” section, choose “User Controlled with Network Manager”. Click on Finish. Close all your windows.
Go to the start menu, System, Desktop Applet, and click on Network Manager. This will give you an icon on your lower right next to the clock where you'll see your wireless usb device active and ready to connect to your wireless gateway.
I hope this can help others as well.

I forgot to mention, this will work with any wireless device with the rt73 chipset not only the one above. I tested this with my other wireless device without needing to modify Network Settings. I only had to reconnect to the wireless signal.

Last edited by linuxitis; 08-22-2008 at 10:52 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
rt73 wn321g+ wireless usb adapter problem. Please help me hide1713 Slackware 1 02-07-2008 02:20 PM
Problem connecting on mandriva 2008 wireless (rt73) jessica_lilly Linux - Wireless Networking 1 12-01-2007 01:58 PM
[Request] RT73.ini RT73.sys Muchalipski Linux - Wireless Networking 1 08-29-2007 01:05 PM
wireless usb - rt73 ex625 Slackware 6 05-03-2007 05:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration