LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-26-2019, 05:28 PM   #1
maschelsea
Member
 
Registered: Dec 2016
Distribution: Slackware 64bit 14.2
Posts: 332

Rep: Reputation: Disabled
Retroarch, netplay won't connect


Note: I am not a newbie. This just seemed the best place to post this question.

I enjoy playing video games. I posted to linuxquestion.org several years ago and someone suggested retroarch to me. I installed it and I love it. I'm having a small problem with it though at this moment.

I am currently on Slackware 14.2. I do have ten years experience with Gentoo though, so I am (almost) no stranger to building my own software. I am running retroarch 1.7.7 on my Slackware system. Trouble is, all the rooms available through netplay are running 1.7.6. I am not sure how to downgrade to 1.7.6 from 1.7.7

I play Pokemon. I have Fire Red and Leafy Green. I was planning to play both of them, and then connect the two games together through netplay to trade Pokemon between the two games. This strategy is proving problematic for me.

When I try to connect to any of the suggested hosts, I get a message flashed at the bottom of the screen: "\| Failed to locate matching content by either CRC or filename."

I issued
Code:
michael@caitlyn ~ $ retroarch --menu --verbose &> log.txt
And that came up with
Code:
michael@caitlyn ~ $ cat log.txt
[INFO] === Build =======================================
[INFO] CPU Model Name: Intel(R) Pentium(R) CPU G3250 @ 3.20GHz
[INFO] Capabilities: MMX MMXEXT SSE1 SSE2 SSE3 SSSE3 SSE4 SSE4.2 
[INFO] Built: Jul 18 2019
[INFO] Version: 1.7.7
[INFO] =================================================
[INFO] Environ SET_PIXEL_FORMAT: RGB565.
[INFO] Version of libretro API: 1
[INFO] Compiled against API: 1
[INFO] [Audio]: Set audio input rate to: 30000.00 Hz.
[INFO] [Video]: Video @ fullscreen
[INFO] [GLX]: GLX_OML_sync_control and GLX_MESA_swap_control supported, using better swap control method...
[INFO] [GL]: Found GL context: x
[INFO] [GL]: Detecting screen resolution 1366x768.
[INFO] [GLX]: Window manager is Xfwm4.
[INFO] [XINERAMA]: Xinerama version: 1.1.
[INFO] [XINERAMA]: Xinerama screens: 1.
[INFO] [GLX]: Using Xinerama on screen #0.
[INFO] [GLX]: X = 0, Y = 0, W = 1366, H = 768.
[INFO] [GLX]: Using windowed fullscreen.
[INFO] [GLX]: Found swap function: glXSwapIntervalMESA.
[INFO] [GLX]: glXSwapInterval(1)
[INFO] [GL]: Vendor: nouveau, Renderer: Gallium 0.4 on NVA8.
[INFO] [GL]: Version: 3.0 Mesa 11.2.2.
[INFO] [GL]: Using resolution 1366x768
[INFO] [GL]: Default shader backend found: glsl.
[INFO] [Shader driver]: Using GLSL shader backend.
[INFO] [GLSL]: Checking GLSL shader support ...
[WARN] [GL]: Stock GLSL shaders will be used.
[INFO] [GLSL]: Found GLSL vertex shader.
[INFO] [GLSL]: Found GLSL fragment shader.
[INFO] [GLSL]: Linking GLSL program.
[INFO] [GLSL]: Found GLSL vertex shader.
[INFO] [GLSL]: Found GLSL fragment shader.
[INFO] [GLSL]: Linking GLSL program.
[INFO] [GLSL]: Found GLSL vertex shader.
[INFO] [GLSL]: Found GLSL fragment shader.
[INFO] [GLSL]: Linking GLSL program.
[INFO] Setting up menu pipeline shaders for XMB ... 
[INFO] [GLSL]: Compiling ribbon shader..
[INFO] [GLSL]: Found GLSL vertex shader.
[INFO] [GLSL]: Found GLSL fragment shader.
[INFO] [GLSL]: Linking GLSL program.
[INFO] [GLSL]: Compiling simple ribbon shader..
[INFO] [GLSL]: Found GLSL vertex shader.
[INFO] [GLSL]: Found GLSL fragment shader.
[INFO] [GLSL]: Linking GLSL program.
[INFO] [GLSL]: Compiling snow shader..
[INFO] [GLSL]: Found GLSL vertex shader.
[INFO] [GLSL]: Found GLSL fragment shader.
[INFO] [GLSL]: Linking GLSL program.
[INFO] [GLSL]: Compiling modern snow shader..
[INFO] [GLSL]: Found GLSL vertex shader.
[INFO] [GLSL]: Found GLSL fragment shader.
[INFO] [GLSL]: Linking GLSL program.
[INFO] [GLSL]: Compiling bokeh shader..
[INFO] [GLSL]: Found GLSL vertex shader.
[INFO] [GLSL]: Found GLSL fragment shader.
[INFO] [GLSL]: Linking GLSL program.
[INFO] [GLSL]: Compiling snowflake shader..
[INFO] [GLSL]: Found GLSL vertex shader.
[INFO] [GLSL]: Found GLSL fragment shader.
[INFO] [GLSL]: Linking GLSL program.
[INFO] [GL]: Using 4 textures.
[INFO] [GL]: Loaded 1 program(s).
[INFO] [GL]: Using GL_RGB565 for texture uploads.
[INFO] [udev]: Plugged pad: Logitech Gamepad F310 (1133:49693) on port #0.
[INFO] [udev]: Pad #0 (/dev/input/event13) supports force feedback.
[INFO] [udev]: Pad #0 (/dev/input/event13) supports 16 force feedback effects.
[INFO] [Autoconf]: 0 profiles found.
[INFO] [Autoconf]: no profiles found for Logitech Gamepad F310 (1133/49693).
[INFO] [Joypad]: Found joypad driver: "udev".
[INFO] [Font]: Using font rendering backend: freetype.
[INFO] [X11]: Suspending screensaver (X11, xdg-screensaver).
[INFO] [Video]: Found display server: x11
[INFO] [PulseAudio]: Requested 24576 bytes buffer, got 18432.
[INFO] [Menu]: Found menu display driver: "gl".
[INFO] [Font]: Using font rendering backend: freetype.
[INFO] [Font]: Using font rendering backend: freetype.
[INFO] [Menu]: Found menu display driver: "gl".
[INFO] [Font]: Using font rendering backend: freetype.
[INFO] [Font]: Using font rendering backend: freetype.
[INFO] [LED]: LED driver = 'null' 0xd6c7c0
[INFO] [MIDI]: Initializing ...
[INFO] [MIDI]: Input disabled.
[INFO] [MIDI]: Output disabled.
[INFO] [MIDI]: Initialized "null" driver.
[WARN] Input device ID 5 is unknown to this libretro implementation. Using RETRO_DEVICE_JOYPAD.
[INFO] SRAM will not be saved.
[INFO] Loading history file: [/home/michael/.config/retroarch/content_history.lpl].
[INFO] Loading history file: [/home/michael/.config/retroarch/content_favorites.lpl].
[INFO] Loading history file: [/home/michael/.config/retroarch/content_music_history.lpl].
[INFO] Loading history file: [/home/michael/.config/retroarch/content_video_history.lpl].
[INFO] Loading history file: [/home/michael/.config/retroarch/content_image_history.lpl].
[INFO] [GL]: VSync => on
[INFO] [GLX]: glXSwapInterval(1)
[INFO] [GL]: VSync => on
[INFO] [GLX]: glXSwapInterval(1)
[INFO] [PulseAudio]: Pausing.
[INFO] [Font]: Using font rendering backend: freetype.
[INFO] [Font]: Using font rendering backend: freetype.
[INFO] [lobby] searching playlist: /home/michael/.config/retroarch/content_history.lpl
[INFO] [netplay] buf 99.235.158.141|55435
[INFO] [netplay] connecting to 99.235.158.141:55435 (deferred)
None of which is helpful to me. Can anyone out there make sense of this output? Can anyone advise me on how to connect my two games together? Thank you in advance to anyone willing to try.
 
Old 08-26-2019, 05:53 PM   #2
rtmistler
Moderator
 
Registered: Mar 2011
Location: USA
Distribution: MINT Debian, Angstrom, SUSE, Ubuntu, Debian
Posts: 8,316
Blog Entries: 13

Rep: Reputation: 3703Reputation: 3703Reputation: 3703Reputation: 3703Reputation: 3703Reputation: 3703Reputation: 3703Reputation: 3703Reputation: 3703Reputation: 3703Reputation: 3703
We can move it to software or games if you like.

We'll see if there are any bites.

Is that IP address one known to you? That seems to be the first problem.

Is there a log you can get on that other system? It may show you information about why it's not connecting.
 
Old 08-26-2019, 06:47 PM   #3
maschelsea
Member
 
Registered: Dec 2016
Distribution: Slackware 64bit 14.2
Posts: 332

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by rtmistler View Post
We can move it to software or games if you like.

We'll see if there are any bites.

Is that IP address one known to you? That seems to be the first problem.

Is there a log you can get on that other system? It may show you information about why it's not connecting.
Yes, please move this thread over to games.

Re: IP address.
I don't remember many of the tricks I used to use in my Gentoo days, but I tried to dig the IP address 99.235.158.141 with no luck
Code:
michael@caitlyn ~ $ dig 99.235.158.141

; <<>> DiG 9.11.9 <<>> 99.235.158.141
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 51863
;; flags: qr rd ra ad; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;99.235.158.141.			IN	A

;; AUTHORITY SECTION:
.			3600	IN	SOA	a.root-servers.net. nstld.verisign-grs.com. 2019082601 1800 900 604800 86400

;; Query time: 18 msec
;; SERVER: 24.116.0.53#53(24.116.0.53)
;; WHEN: Mon Aug 26 17:51:15 CDT 2019
;; MSG SIZE  rcvd: 118
IIRC, a code of NXDOMAIN meant that the DNS record is not correct. Meaning that I can't get there from here.

Last edited by maschelsea; 08-26-2019 at 06:51 PM.
 
Old 08-27-2019, 01:02 PM   #4
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 13,223
Blog Entries: 9

Rep: Reputation: 3617Reputation: 3617Reputation: 3617Reputation: 3617Reputation: 3617Reputation: 3617Reputation: 3617Reputation: 3617Reputation: 3617Reputation: 3617Reputation: 3617
The problem description is so specific to retroarch; you say something about version incompatibility (I guess you mean retroarch itself), but don't show us where and how it manifests. Then you also seem to be saying that you are trying to connect two of your own games, and that "doesn't work" either - but they would be on the same version then? So the version incompatibility cannot be the problem?

There's no error messages in the log.

Maybe you can whittle it down to a general Linux networking problem, we might be able to help.

Or wait for retroarch experts.

Or open an issue on retroarch's git repo.
 
Old 08-29-2019, 10:54 PM   #5
maschelsea
Member
 
Registered: Dec 2016
Distribution: Slackware 64bit 14.2
Posts: 332

Original Poster
Rep: Reputation: Disabled
I read on another site (tab it was in is closed now, and it was closed so long ago that it is no longer on my history) that a version mismatch between the server you're trying to connect to and your client version can cause this problem. When I try to connect to myself, the second retroarch window I open has a pure white background, and is not really interactive at all. I try to only use retroarch on weekends, leaving weekday times for actual work. This is why I'm just getting back to you now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
RetroArch won't recognize my Logitech gamepad Michael Piziak Linux - Games 0 11-29-2018 06:44 PM
[SOLVED] Retroarch won't take my inputs maschelsea Slackware 4 04-09-2018 08:28 AM
[SOLVED] ANNOUNCE: RetroArch for Slackware dugan Slackware 15 03-12-2017 05:45 PM
Retroarch ad infinitum BenCollver Linux - Games 0 08-02-2014 06:45 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration