LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-20-2002, 01:39 PM   #1
DC12k
LQ Newbie
 
Registered: Apr 2002
Posts: 27

Rep: Reputation: 15
Question Red Hat 7.3 problem


I am new to linux and am having a problem when I boot up. For some reason, when the computer boots, it goes to a log on screen in the console mode and not the Graphical mode. Is there some way that I can get it to launch the Graphical mode? Or is there some other reason for it not doing that?

Thanks
 
Old 08-20-2002, 03:15 PM   #2
DC12k
LQ Newbie
 
Registered: Apr 2002
Posts: 27

Original Poster
Rep: Reputation: 15
Ok, I searched back in the forums and ran startx. When I did, the screen went blank and retuned giving me this:


(EE) failed to load module GLcore (module does not exist)
(EE) VESA (O): No matching modes
(EE) Screen(s) found, but none have useable configuration

Fatal server error:
no screens found

XIO: Fatal IO error 104(connections reset by peer) on xserver ":0,0" after 0 requests (0 Known processed) with 0 events remaining.



Can anyone tell me how I can solve this?


Thanks.
 
Old 08-20-2002, 05:04 PM   #3
DC12k
LQ Newbie
 
Registered: Apr 2002
Posts: 27

Original Poster
Rep: Reputation: 15
I tried downloading new drivers for my graphics card (Geforce4 Ti4400) from the Nvidia site. I installed these and edited the XF86Config-4 file to say:

Driver "nvidia"

instead of

Driver "vesa"

as the installation instructions told me. Now the VESA error is gone and a new one saying that the NVIDIA driver failed pops up.

Can anyone please help me? I am completely clueless on what to try next. Any help would be greatly appreciated.
 
Old 08-21-2002, 05:25 AM   #4
Sfin
Member
 
Registered: Apr 2002
Location: Michigan
Distribution: Slackware 8.0
Posts: 197

Rep: Reputation: 30
First of all what Distro are you using?

1) To boot into the GUI by default edit the folowing line in the /etc/inittab file:

id:3:initdefault

to

id:5:initdefault

or

id:4:initdefualt ---> Use this if you are using Slackware Distribution.


2) First of all run xf86config to set up the Horizontal + Vertical syncs of your screen, and a couple other options.

The edit the XF86Config-4 like the driver installation README told you.

Also post the error that you got when you tried the Nvidia driver.
 
Old 08-21-2002, 08:28 PM   #5
DC12k
LQ Newbie
 
Registered: Apr 2002
Posts: 27

Original Poster
Rep: Reputation: 15
OK, if you noticed, the name of the distrobution that I am using is Red Hat 7.3 (in the subject). I did edit the inittab file and it had already said id:5:initdefault.

I checked and the Horizontal and Vertical syncs are all set up and every other option is set.
I did edit the XF86Config-4 file EXACTLY to what the intallation readme for my graphics card drivers said. I'll go check what that nvidia driver error was for sure but I believe it just said failure to run it or something like that.
 
Old 08-21-2002, 09:31 PM   #6
DC12k
LQ Newbie
 
Registered: Apr 2002
Posts: 27

Original Poster
Rep: Reputation: 15
I checked the error that it gives me and it is :

(EE) NVIDIA(0): Failed to initiate the NVdriver Kernel module
NVIDIA ***ABORTING***
 
Old 08-22-2002, 02:27 PM   #7
mavness
Member
 
Registered: Aug 2002
Location: Chicago
Distribution: Debian 3.1
Posts: 45

Rep: Reputation: 15
dc12k, i had this problem. (i have redhat 7.3 and a geforce4 4400) DO NOT use the rpm's for the NVIDIA drivers. Dl the kernel tar.gz and the GLX tar.gz Follow the directions on the README on NVIDIA's site. It worked perfectly for me this way every time. Btw, just make sure you are on root when you do this.
 
Old 08-22-2002, 04:03 PM   #8
DC12k
LQ Newbie
 
Registered: Apr 2002
Posts: 27

Original Poster
Rep: Reputation: 15
Thanks a lot mavness. I never thought of trying that.
I hope this works!



Oh, I noticed that on their site they do not have links for the tar.gz Kernal drivers...

Last edited by DC12k; 08-22-2002 at 04:12 PM.
 
Old 08-22-2002, 04:16 PM   #9
DC12k
LQ Newbie
 
Registered: Apr 2002
Posts: 27

Original Poster
Rep: Reputation: 15
nm I read on the forums there that the source tar.gz file is the one
 
Old 08-22-2002, 05:34 PM   #10
DC12k
LQ Newbie
 
Registered: Apr 2002
Posts: 27

Original Poster
Rep: Reputation: 15
hmm. That didn't work. The GLX drivers install fine, but the kernel drivers give me a bunch of errors. Am I doing something wrong? I un-tar the file by typing:

tar xvzf NVIDIA_kernel-1.0-2960.tar.gz

then I change into the directory where it put all the files (/NVIDIA_kernel-1.0-2960) and I type:
make install
and it pops up with a bunch of errors about missing files and directories. I did the exact thing with the GLX drivers and it worked flawlessly.
here is what the error said:
cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wpointer-arith -Wcast-qual -Wno-multichar -O -MD -D__KERNEL__ -DMODULE -D_LOOSE_KERNEL_NAMES -D_X86=1 -Di386=1 -DUNIX -DLINUX -DNV4_HW -DNTRM -DRM20 -D_GNU_SOURCE -DRM_HEAPMGR -D_LOOSE_KERNEL_NAMES -D__KERNEL__ -DMODULE -DNV_MAJOR_VERSION=1 -DNV_MINOR_VERSION=0 -DNV_PATCHLEVEL=2960 -I. -I/usr/src/linux/include -Wno-cast-qual nv.c
In file included from /usr/include/linux/vmalloc.h:8,
from nv-linux.h:29,
from nv.c:27:
/usr/include/asm/pgtable.h:17:24: asm/fixmap.h: No such file or directory
In file included from nv-linux.h:53,
from nv.c:27:
/usr/include/linux/autoconf.h:1:2: #error Invalid kernel header included in userspace
In file included from nv.c:41:
/usr/include/linux/delay.h:13:23: asm/delay.h: No such file or directory
In file included from nv.c:42:
/usr/include/linux/interrupt.h:44:25: asm/hardirq.h: No such file or directory
/usr/include/linux/interrupt.h:45:25: asm/softirq.h: No such file or directory
nv.c:57:53: asm/uaccess.h: No such file or directory
nv.c:59:51: asm/softirq.h: No such file or directory
In file included from /usr/include/linux/highmem.h:5,
from nv.c:63:
/usr/include/asm/pgalloc.h:6:24: asm/fixmap.h: No such file or directory
make: *** [nv.o] Error 1


In the Nvidia forums, people said that upgrading the kernel should allow the tarballs to work better. Is this true, and how would I go about doing this?
Any help is greatly appreciated.

Last edited by DC12k; 08-22-2002 at 05:56 PM.
 
Old 08-23-2002, 07:25 AM   #11
mavness
Member
 
Registered: Aug 2002
Location: Chicago
Distribution: Debian 3.1
Posts: 45

Rep: Reputation: 15
Did you install the nvidia kernel first? You must install the kernel then the GLX. If you going to attempt this again, you must delete the folders and un-extract them from the tar.gz again.

EDIT: OH YA! You CANNOT be in X while attempting this. They reccomend just rebooting, logging in at the command prompt and doing it. THEN startx. I noticed you pasted the entire error, im guessing you tried this in a termnial in X. Thats probably why its not working. Good luck

Last edited by mavness; 08-23-2002 at 10:05 AM.
 
Old 08-23-2002, 10:34 AM   #12
ScottL
LQ Newbie
 
Registered: Aug 2002
Posts: 5

Rep: Reputation: 0
Cool

Hello,

I'm new to linux but have been installing various distributions lately to become familiar with this OS. I thought of something (a little off base) but could be of some help.


I've noticed when installing various linux distributions and it comes time to configure things for the X system (choose a graphics card, monitor, screen resolution) there is an option to use/enable "3D". After choosing this option linux prompted me with a warning that all such drivers were "developmental" and could cause problems.

I realize this doesn't fix your problem but I figure it could possibly buy you some time until more compatible software is available.

Scott
 
Old 08-24-2002, 04:43 AM   #13
lynch
Member
 
Registered: Nov 2000
Location: A Mid-Atlantic state
Distribution: SuSE 8.1,Knoppix 3.2,Mandrake 9.1
Posts: 388

Rep: Reputation: 30
There are a few little things to do in XF86Config:
#comment these 2 lines by putting a # in front like this:

#Load "dri"
#Load "GLcore"

I use ATI cards myself,but I found the above tip to be helpful to NVidia users

lynch
 
Old 08-24-2002, 03:27 PM   #14
DC12k
LQ Newbie
 
Registered: Apr 2002
Posts: 27

Original Poster
Rep: Reputation: 15
The problem is that the Kernel drivers are giving me errors. I keep getting the errors that I stated above. I do install the kernel drivers first but that is what gives me the error. Is there some way that I can get this to work? Is there some certain way that I must extract the tarball before doing this? I extract it into the / directory and run it from there and I get errors. Should I be extracting it somewhere else like the root dir, or does it not matter?
 
Old 08-25-2002, 11:15 AM   #15
BruceCadieux
Member
 
Registered: Apr 2002
Location: Wales MA.
Distribution: openSuSE 11.1
Posts: 409

Rep: Reputation: 32
I have a few friends who were having a hard time getting Nvidia drivers to work in RedHat. So the instructions start out with getting the files while in windows. Substitute your own OS.

I tossed together some instructions for using .rpm files that assume they can not get to the GUI. This has worked for me and all of my friends.

Heres the link, I tried to make it as easy to understand as I could. http://www.cadieux.netfirms.com/screenshots/nvidia.html

I have some screen shots using mcedit to edit the XF86Config-4 file. This isn't exactly advanced stuff, I tried to keep it very, very simple. It may or may not help you but may be worth a try.

Let me know if it works out for you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Red Hat custom Kernel compilation mini-How-To for Red Hat 8-9 Thetargos Red Hat 431 04-13-2007 05:19 AM
Red Hat does not plan to release another product in the red hat linux line... Whitehat General 5 11-03-2003 06:33 PM
red hat 9.0.93. -beta red hat 10-xmms problem ronss Red Hat 1 09-08-2003 04:00 AM
Red Hat Enterprise vs. Red Hat Linux Project RedHatMN Linux - Distributions 2 07-29-2003 04:16 AM
Red Hat 7.2... & a modem with Red Hat 7.1 driver support rahduku Linux - Distributions 1 02-14-2002 11:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration