LinuxAnswers - the LQ Linux tutorial section.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 10-08-2012, 10:58 AM   #1
Registered: Jul 2012
Location: UK
Distribution: Debian x64
Posts: 65

Rep: Reputation: Disabled
"Not Authorized" to mount external USB drive or Windows filesystem from Debian

Afternoon all.

I have two USB sticks and a 1TB USB drive attached to my computer (dual boot Debian stable/Windows 7

When I open pcmanfm from my standard user account, I see in the left panel

4.0 GB Filesystem (USB stick, I can access)
427 GB Filesystem (Windows Filesystem, I can't access)
Tenso 32 GB (USB stick, I can access)
Elements (1TB external HDD, I can't access)
System Reserved (I don't know what this is, but I can't access it)

I see it as a standard user, but cannot access it. As root, I can't even see it on pcmanfm.

Any help would be greatly appreciated
Old 10-08-2012, 11:38 AM   #2
Senior Member
Registered: May 2010
Location: Planet Earth
Distribution: Debian
Posts: 1,030

Rep: Reputation: 379Reputation: 379Reputation: 379Reputation: 379
You will need to manually mount your 1TB drive. As root type fdisk -l to find out what device is you 1TB, so it may be, example: /dev/sdb2
Then to mount it, example:
# mount /dev/sdb2 /mnt/
You could also create a folder inside of you user directory and mount it there, or inside of mnt folder.

1 members found this post helpful.
Old 10-08-2012, 02:30 PM   #3
Senior Member
Registered: Dec 2005
Location: Florida
Distribution: CentOS/Fedora
Posts: 2,625

Rep: Reputation: 487Reputation: 487Reputation: 487Reputation: 487Reputation: 487
you can also setup sudo to allow the user to mount that drive.

as root run visudo and find your user account name. if it is not here add it and make it look something like the following:

user    ALL =(root) NOPASSWD: /bin/dmesg -n 1, /usr/rx30/, /usr/bin/, /bin/mount -t iso9660 /dev/dvd /mnt/dvd, /bin/umount /dev/dvd, /usr/bin/, /usr/bin/dvd+rw-format -force /dev/dvd, /b
in/mount /dev/dvd /mnt/dvd, /bin/mount -t iso9660 /dev/cdrom /mnt/cdrom, /bin/umount /mnt/cdrom, /usr/bin/eject, /usr/bin/eject -t, /usr/bin/fixprinter, /bin/cp, /bin/chmod, /bin/chown, /bin/mount /mnt/backup, /bin/umo
unt /mnt/backup , /bin/mount /mnt/usb, /bin/umount /mnt/usb, /tmp/, /bin/mount /mnt/cifs, /bin/umount /mnt/cifs
Note the bold section is the how that user will access the drive.

so as user you would type:

$ sudo /bin/mount /mnt/usb

Last edited by lleb; 10-08-2012 at 02:32 PM.
Old 01-15-2013, 01:40 PM   #4
Registered: Jul 2012
Location: UK
Distribution: Debian x64
Posts: 65

Original Poster
Rep: Reputation: Disabled
Sorry about neglecting this thread.

pcmanfm seemed unable to mount my drives from the file manager, whereas Thunar and numerous others could.

To mount my external drive on Debian, I used
sudo mount -t ntfs /dev/sdb1 /media/Elements
Where /dev/sdb1 was the name of the disk I wanted to mount, and /media/Elements is the directory to mount to

pcmanfm could read my directories once I manually mounted the drive


debian, mount, permissions, usb

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
fedora 16 live usb fails on boot with "cant mount root filesystem" ikarus Fedora 4 06-04-2012 12:39 PM
"Urgent" Unable to mount USB External Hard Drive sanrock Linux - Hardware 7 12-16-2011 10:21 AM
managing mount points for external drive "farm" SaintDanBert Linux - Hardware 4 09-28-2010 04:09 PM
Installing Debian from USB flash drive - Cannot mount "CD-ROM" Jinouchi Linux - Software 1 07-29-2010 11:52 AM
USB hard drive mounts as "Read Only Filesystem" augu2000 Linux - Hardware 11 07-12-2007 11:37 AM

All times are GMT -5. The time now is 12:32 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration