LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-04-2003, 08:37 PM   #1
jade
LQ Newbie
 
Registered: Dec 2003
Location: SoCal
Distribution: Mandrake 9.0
Posts: 4

Rep: Reputation: 0
Networking Problems


I need to know how to set up my OS so that I can connect to the internet. My comp is connected to a router that is connected to a cable modem. I'm running Mandrake 9.0 (but this lack of connectivity forces me to use WinXP)

I have tried to configurine the network setting to no avail. If more details are needed, ask and I'll go about booting Linux up to get them.

*update*

I get this message when I run the config wizard in the Mandrake control panel for the internet connection: "No ethernet network adapter has been detected on your system. I cannot setup this connection type." However, my adapter does show up in the hardware list and when I run the wizard.

Last edited by jade; 12-04-2003 at 09:15 PM.
 
Old 12-04-2003, 08:40 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
The questions I'd have aren't Linux-dependent :}

Does your router provide DHCP for the computer,
or do you have a static IP? Do you use a normal
route, or do you have to use PPPoE?


Cheers,
Tink
 
Old 12-04-2003, 09:12 PM   #3
jade
LQ Newbie
 
Registered: Dec 2003
Location: SoCal
Distribution: Mandrake 9.0
Posts: 4

Original Poster
Rep: Reputation: 0
The protocal is DHCP and it seems to use a normal route.

Last edited by jade; 12-04-2003 at 09:16 PM.
 
Old 12-04-2003, 09:27 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Can you give me the output of

lspci -v

in Linux (run as root)

Or maybe you know that ... what network card
are you using?


Cheers,
Tink
 
Old 12-04-2003, 09:53 PM   #5
jade
LQ Newbie
 
Registered: Dec 2003
Location: SoCal
Distribution: Mandrake 9.0
Posts: 4

Original Poster
Rep: Reputation: 0
[root@localhost root]# lspci -v
00:00.0 Host bridge: nVidia Corporation: Unknown device 01a4 (rev b2)
Flags: bus master, 66Mhz, fast devsel, latency 0
Memory at ec000000 (32-bit, prefetchable) [size=64M]
Capabilities: [40] AGP version 2.0
Capabilities: [60] #08 [2001]

00:00.1 RAM memory: nVidia Corporation: Unknown device 01ac (rev b2)
Subsystem: Compaq Computer Corporation: Unknown device 00a8
Flags: 66Mhz, fast devsel

00:00.2 RAM memory: nVidia Corporation: Unknown device 01ad (rev b2)
Subsystem: Compaq Computer Corporation: Unknown device 00a8
Flags: 66Mhz, fast devsel

00:00.3 RAM memory: nVidia Corporation: Unknown device 01aa (rev b2)
Subsystem: Compaq Computer Corporation: Unknown device 00a8
Flags: 66Mhz, fast devsel

00:01.0 ISA bridge: nVidia Corporation: Unknown device 01b2 (rev c3)
Flags: bus master, 66Mhz, fast devsel, latency 0
Capabilities: [50] #08 [01e1]

00:01.1 SMBus: nVidia Corporation: Unknown device 01b4 (rev c1)
Subsystem: Compaq Computer Corporation: Unknown device 00a8
Flags: 66Mhz, fast devsel, IRQ 10
I/O ports at 24a0 [size=16]
I/O ports at 24b0 [size=16]
I/O ports at 2480 [size=32]
Capabilities: [44] Power Management version 2

00:02.0 USB Controller: nVidia Corporation: Unknown device 01c2 (rev c3) (prog-if 10 [OHCI])
Subsystem: Compaq Computer Corporation: Unknown device 00a8
Flags: bus master, 66Mhz, fast devsel, latency 0, IRQ 11
Memory at f8500000 (32-bit, non-prefetchable) [size=4K]
Capabilities: [44] Power Management version 2

00:03.0 USB Controller: nVidia Corporation: Unknown device 01c2 (rev c3) (prog-if 10 [OHCI])
Subsystem: Compaq Computer Corporation: Unknown device 00a8
Flags: bus master, 66Mhz, fast devsel, latency 0, IRQ 3
Memory at f8501000 (32-bit, non-prefetchable) [size=4K]
Capabilities: [44] Power Management version 2

00:04.0 Ethernet controller: nVidia Corporation: Unknown device 01c3 (rev c2)
Subsystem: Compaq Computer Corporation: Unknown device 00a8
Flags: bus master, 66Mhz, fast devsel, latency 0, IRQ 5
Memory at f8503000 (32-bit, non-prefetchable) [size=1K]
I/O ports at 24d0 [size=8]
Capabilities: [44] Power Management version 2

00:08.0 PCI bridge: nVidia Corporation: Unknown device 01b8 (rev c2) (prog-if 00 [Normal decode])
Flags: bus master, 66Mhz, fast devsel, latency 0
Bus: primary=00, secondary=02, subordinate=02, sec-latency=64
I/O behind bridge: 00001000-00001fff
Memory behind bridge: f8200000-f84fffff

00:09.0 IDE interface: nVidia Corporation nForce IDE (rev c3) (prog-if 8a [Master SecP PriP])
Subsystem: Compaq Computer Corporation: Unknown device 00a8
Flags: bus master, 66Mhz, fast devsel, latency 0
I/O ports at 24c0 [size=16]
Capabilities: [44] Power Management version 2

00:1e.0 PCI bridge: nVidia Corporation: Unknown device 01b7 (rev b2) (prog-if 00 [Normal decode])
Flags: bus master, 66Mhz, medium devsel, latency 66
Bus: primary=00, secondary=01, subordinate=01, sec-latency=34
Memory behind bridge: f9000000-fa1fffff
Prefetchable memory behind bridge: f0000000-f81fffff

01:00.0 VGA compatible controller: nVidia Corporation NV15 [GeForce2 - nForce GPU] (rev b1) (prog-if 00 [VGA])
Subsystem: Compaq Computer Corporation: Unknown device 00a8
Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 5
Memory at f9000000 (32-bit, non-prefetchable) [size=16M]
Memory at f0000000 (32-bit, prefetchable) [size=128M]
Expansion ROM at <unassigned> [disabled] [size=64K]
Capabilities: [60] Power Management version 2
Capabilities: [44] AGP version 2.0

02:06.0 Multimedia audio controller: Creative Labs SB Audigy (rev 03)
Subsystem: Creative Labs SB0090 Augidy Player
Flags: bus master, medium devsel, latency 64, IRQ 3
I/O ports at 1000 [size=32]
Capabilities: [dc] Power Management version 2

02:06.1 Input device controller: Creative Labs SB Audigy MIDI/Game port (rev 03)
Subsystem: Creative Labs SB Audigy MIDI/Gameport
Flags: bus master, medium devsel, latency 64
I/O ports at 1020 [size=8]
Capabilities: [dc] Power Management version 2

02:06.2 FireWire (IEEE 1394): Creative Labs SB Audigy FireWire Port (prog-if 10
[OHCI])
Subsystem: Creative Labs: Unknown device 0010
Flags: bus master, medium devsel, latency 66, IRQ 5
Memory at f8414000 (32-bit, non-prefetchable) [size=2K]
Memory at f8410000 (32-bit, non-prefetchable) [size=16K]
Capabilities: [44] Power Management version 2

02:07.0 Communication controller: Conexant HSF 56k HSFi Modem (rev 01)
Subsystem: GVC Corporation: Unknown device 8d8c
Flags: bus master, medium devsel, latency 64, IRQ 3
Memory at f8400000 (32-bit, non-prefetchable) [size=64K]
I/O ports at 1028 [size=8]
Capabilities: [40] Power Management version 2

[root@localhost root]#
 
Old 12-04-2003, 10:28 PM   #6
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Google is your friend ;)

Been here ?



Cheers,
Tink
 
Old 12-04-2003, 11:41 PM   #7
jade
LQ Newbie
 
Registered: Dec 2003
Location: SoCal
Distribution: Mandrake 9.0
Posts: 4

Original Poster
Rep: Reputation: 0
That did indeed solve the problem. I really feel like a total newb for not considering that. I should know better!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Networking problems Nullhellfire Slackware 4 03-28-2005 11:58 PM
networking problems purdue_mike Fedora 2 11-24-2004 02:10 AM
networking problems nacha Debian 3 06-18-2004 12:01 PM
networking problems zZeEkiEeZz Linux - Networking 3 07-02-2003 10:00 PM
Networking problems Shil Linux - Newbie 2 12-12-2000 12:04 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration