LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-25-2003, 09:55 PM   #1
Budious
LQ Newbie
 
Registered: Jan 2003
Location: Georgia
Distribution: Dapper Drake
Posts: 24

Rep: Reputation: 15
Configuring NTFS mount point.


I have Slackware 9.1 up and running, kernel has been recompiled for Athlon arch, NTFS read support, 4gb memory support (1.5gb installed), and 4 channel sound. I want to add my 160gb windows XP ntfs partition to /mnt/ntfs for read-only access, followed some instructions from other sites I found, but it doesn't seem to work, may be I have wrong "umask=000"?

my fstab:

/dev/hdf1 swap swap defaults 0 0
/dev/hde1 / ext3 defaults 1 1
/dev/hde2 /usr/local ext3 defaults 1 2
/dev/hdf2 /home ext3 defaults 1 2
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0

I tried adding the line : /dev/hda1 /mnt/ntfs ntfs users,owner,ro,umask=000 0 0

#mount -a returned error: [mntent]: warning: no final newline at the end of /etc/fstab
mount: wrong fs type, bad option, bad superblock on /dev/hda1,
or too many mounted file systems


#fdisk -l shows these hard drives, I need to get my /dev/hda1 mapped to /mnt/ntfs

Disk /dev/hde: 30.7 GB, 30735581184 bytes
255 heads, 63 sectors/track, 3736 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hde1 * 1 1216 9767488+ 83 Linux
/dev/hde2 1217 3736 20241900 83 Linux

Disk /dev/hdf: 46.1 GB, 46103371776 bytes
255 heads, 63 sectors/track, 5605 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdf1 * 1 124 995998+ 82 Linux swap
/dev/hdf2 125 5605 44026132+ 83 Linux

Disk /dev/hda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 19456 156280288+ 7 HPFS/NTFS

Last edited by Budious; 12-25-2003 at 10:48 PM.
 
Old 12-25-2003, 10:58 PM   #2
Berhanie
Senior Member
 
Registered: Dec 2003
Location: phnom penh
Distribution: Fedora
Posts: 1,625

Rep: Reputation: 165Reputation: 165
Please try this:

/dev/hda1 /mnt/ntfs ntfs users,ro,umask=0222 0 0
 
Old 12-25-2003, 11:01 PM   #3
mikshaw
LQ Addict
 
Registered: Dec 2003
Location: Maine, USA
Distribution: Slackware/SuSE/DSL
Posts: 1,320

Rep: Reputation: 45
try umask=0222

I gotta learn to type faster....
 
Old 12-25-2003, 11:01 PM   #4
Budious
LQ Newbie
 
Registered: Jan 2003
Location: Georgia
Distribution: Dapper Drake
Posts: 24

Original Poster
Rep: Reputation: 15
/dev/hdf1 swap swap defaults 0 0
/dev/hde1 / ext3 defaults 1 1
/dev/hde2 /usr/local ext3 defaults 1 2
/dev/hdf2 /home ext3 defaults 1 2
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0
/dev/hdd /mnt/cdrom1 iso9660 noauto,owner,ro 0 0
/dev/hda1 /mnt/ntfs ntfs users,ro,unmask=0222 0 0

root@linux:/# mount -a
mount: wrong fs type, bad option, bad superblock on /dev/hda1,
or too many mounted file systems

Nope, that sure didn't work either, same error.
 
Old 12-25-2003, 11:06 PM   #5
mikshaw
LQ Addict
 
Registered: Dec 2003
Location: Maine, USA
Distribution: Slackware/SuSE/DSL
Posts: 1,320

Rep: Reputation: 45
maybe "user" instead of "users"...it's the only thing that looks off to me
 
Old 12-25-2003, 11:11 PM   #6
Budious
LQ Newbie
 
Registered: Jan 2003
Location: Georgia
Distribution: Dapper Drake
Posts: 24

Original Poster
Rep: Reputation: 15
changed to user, same error. Also can I in this file change permissions for my cdrom devices /dev/cdrom and /dev/hdd so that any user can mount them. I have made shortcuts on KDE to both cdroms but tells me only root can mount them.
 
Old 12-25-2003, 11:15 PM   #7
mikshaw
LQ Addict
 
Registered: Dec 2003
Location: Maine, USA
Distribution: Slackware/SuSE/DSL
Posts: 1,320

Rep: Reputation: 45
yes.
I've got unhide,ro,noauto,user,exec as /dev/cdrom options, and users can mount it.
 
Old 12-25-2003, 11:20 PM   #8
Budious
LQ Newbie
 
Registered: Jan 2003
Location: Georgia
Distribution: Dapper Drake
Posts: 24

Original Poster
Rep: Reputation: 15
Ok, thank you... that got my cdroms to mount as a user. Now I just need this NTFS partition readable
 
Old 12-25-2003, 11:23 PM   #9
mikshaw
LQ Addict
 
Registered: Dec 2003
Location: Maine, USA
Distribution: Slackware/SuSE/DSL
Posts: 1,320

Rep: Reputation: 45
maybe if you add "auto" to the entry...perhaps it's using the default "noauto" and therefore won't automatically mount it when you boot


I'm just making guesses at this point....it's Christmassy beer time....

Last edited by mikshaw; 12-25-2003 at 11:25 PM.
 
Old 12-25-2003, 11:31 PM   #10
Budious
LQ Newbie
 
Registered: Jan 2003
Location: Georgia
Distribution: Dapper Drake
Posts: 24

Original Poster
Rep: Reputation: 15
root@linux:/home/noah# mount /dev/hda1 /mnt/ntfs
root@linux:/home/noah# cd /mnt/ntfs
root@linux:/mnt/ntfs# ls
ATI MSOCache RECYCLER ntldr
Documents and Settings NTDETECT.COM System Volume Information pagefile.sys
Drivers Perl WINDOWS
Files Program Files WUTemp
IntelPRO Programs boot.ini


Okay, nm... i mounted it manually and it works now, just would not come up with the mount -a command.
 
Old 12-25-2003, 11:32 PM   #11
Berhanie
Senior Member
 
Registered: Dec 2003
Location: phnom penh
Distribution: Fedora
Posts: 1,625

Rep: Reputation: 165Reputation: 165
Budious,
I noticed you have unmask=0222 instead of umask=0222.
 
Old 12-25-2003, 11:43 PM   #12
Budious
LQ Newbie
 
Registered: Jan 2003
Location: Georgia
Distribution: Dapper Drake
Posts: 24

Original Poster
Rep: Reputation: 15
Ok, thanks for noticing that, my bad. Must have been a typo... too much christmas turkey, well now everything seems to work, guess I'll go doze off. Thanks for all the help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
need help with mount points! rmanocha Linux - Hardware 2 10-26-2003 04:23 PM
help with mount points rmanocha Linux - Software 12 10-26-2003 02:32 PM
SCRIPT: check if auto-mount mount-points are still mounted markus1982 Linux - Software 0 05-25-2003 06:48 AM
Mount Points? Mr_Floppy4 Linux - General 2 10-14-2002 11:03 PM
mount points... Jeffrey Linux - General 6 02-24-2001 01:09 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration