LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-26-2004, 09:06 AM   #1
Gary_Menegon
Member
 
Registered: Jun 2004
Location: Joliet, Illinois
Distribution: slackware
Posts: 38

Rep: Reputation: 15
minicom disconnect


I got minicom to work (turned out to be a hardware problem), but now I can't disconnect, won't recognize any control keys. This is a direct cable to a Cisco 2501 router into the console port (no modem). I have to reboot the computer to disconnect. Any ideas on the proper way to disconnect?

Thankyou,

Gary
 
Old 07-27-2004, 02:05 AM   #2
idaho
Member
 
Registered: Aug 2003
Location: Portland, Oregon
Distribution: RedHat, Libranet
Posts: 438

Rep: Reputation: 30
<CTRL><A> - <Q> is supposed to be the disconnect sequence.

The minicom man page has notes about how to configure an alternative to <CTRL> as the command key (e.g., -m to use <ALT>)
 
Old 07-27-2004, 09:26 AM   #3
Gary_Menegon
Member
 
Registered: Jun 2004
Location: Joliet, Illinois
Distribution: slackware
Posts: 38

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by idaho
<CTRL><A> - <Q> is supposed to be the disconnect sequence.

The minicom man page has notes about how to configure an alternative to <CTRL> as the command key (e.g., -m to use <ALT>)
I have tried the control keys, they don't seem to respond. I have not changed any of the default values associated with control keys. Minicom works fine, but I can't disconnect.

Gary
 
Old 07-27-2004, 11:55 AM   #4
idaho
Member
 
Registered: Aug 2003
Location: Portland, Oregon
Distribution: RedHat, Libranet
Posts: 438

Rep: Reputation: 30
So, did you try the -m argument to make <ALT> your command key?
 
Old 07-28-2004, 09:15 AM   #5
Gary_Menegon
Member
 
Registered: Jun 2004
Location: Joliet, Illinois
Distribution: slackware
Posts: 38

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by idaho
So, did you try the -m argument to make <ALT> your command key?
No I didn't. I thought that was the default. Is it necessary to set the argument?

Gary
 
Old 07-28-2004, 10:36 AM   #6
idaho
Member
 
Registered: Aug 2003
Location: Portland, Oregon
Distribution: RedHat, Libranet
Posts: 438

Rep: Reputation: 30
The default is to use <CTRL> as your command key.
 
Old 07-30-2004, 09:47 AM   #7
Gary_Menegon
Member
 
Registered: Jun 2004
Location: Joliet, Illinois
Distribution: slackware
Posts: 38

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by idaho
The default is to use <CTRL> as your command key.
I used minicom -m and it works fine, but why must I use -m for each session? I checked the modem settings and choice k hang up string is ~~+++~~ATH^M, which if I edit and enter ALT Q is that string. It's not a big deal only 2 more characters to type, I am just curious. Any thoughts?

Thanks,

Gary
 
Old 07-30-2004, 12:03 PM   #8
idaho
Member
 
Registered: Aug 2003
Location: Portland, Oregon
Distribution: RedHat, Libranet
Posts: 438

Rep: Reputation: 30
Probably something to do with the hardware you are talking to or from. minicom works fine for me without the -m option.

Just be thankful that the authors were kind enough to provide an option to change the default for folks like you for whom the default wasn't appropriate.
 
Old 07-30-2004, 06:36 PM   #9
Gary_Menegon
Member
 
Registered: Jun 2004
Location: Joliet, Illinois
Distribution: slackware
Posts: 38

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by idaho
Probably something to do with the hardware you are talking to or from. minicom works fine for me without the -m option.

Just be thankful that the authors were kind enough to provide an option to change the default for folks like you for whom the default wasn't appropriate.
I am connecting to the console port of a Cisco 2501 router. Minicom -m works fine, I was just curious why the -m was needed. I built a little script so I wouldn't have to type so much.

Thanks for all your help!

Gary
 
Old 07-31-2004, 12:38 PM   #10
kzamora
LQ Newbie
 
Registered: Jul 2004
Posts: 1

Rep: Reputation: 0
You don't have to use the -m option when you start minicom if you configure it permanently via < minicom -s > . The -s is for "setup". In setup go to SCREEN SETTINGS. THe first option is what you type for the command. It defaults to CTRL-A. Go in any change it to ALT Z. Just type in <ALT-Z> . THe prompts are a little funny cause it asks you about metachars, etc. But just type in ALT-Z and it will change.

Then, you need to NAME your new configuration. In my case, I don't have a modem so I just called it com1. The next time you invoke minicom, just type minicom yourconfigFile. THats it.
 
Old 08-02-2004, 08:39 AM   #11
Gary_Menegon
Member
 
Registered: Jun 2004
Location: Joliet, Illinois
Distribution: slackware
Posts: 38

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by kzamora
You don't have to use the -m option when you start minicom if you configure it permanently via < minicom -s > . The -s is for "setup". In setup go to SCREEN SETTINGS. THe first option is what you type for the command. It defaults to CTRL-A. Go in any change it to ALT Z. Just type in <ALT-Z> . THe prompts are a little funny cause it asks you about metachars, etc. But just type in ALT-Z and it will change.

Then, you need to NAME your new configuration. In my case, I don't have a modem so I just called it com1. The next time you invoke minicom, just type minicom yourconfigFile. THats it.
Thanks, I try that.

Gary
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
minicom flensplop Linux - Newbie 2 08-30-2004 09:21 PM
Can't disconnect raysr Linux - Networking 2 05-23-2004 11:00 AM
using minicom Pico_01 Linux - General 5 02-12-2004 04:01 AM
something about minicom Kamrul Hakim Linux - Software 1 01-21-2003 03:45 PM
Can't disconnect!!! Nik Linux - Software 1 12-15-2002 04:32 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration